Update to the latest git, all removing patches applied upstream
This commit is contained in:
parent
c5b91e6553
commit
da38d7069f
1
.gitignore
vendored
1
.gitignore
vendored
@ -25,3 +25,4 @@ libfm-0.1.12.tar.gz
|
||||
/libfm-1.2.3.tar.xz
|
||||
/libfm-1.2.3-699810d3bd0c5d9d508fcd9aa3a65442f2afee3f.tar.gz
|
||||
/libfm-1.2.3-577806e29d2ec27ce5fee9dc816566fb4e23b155.tar.gz
|
||||
/libfm-1.2.3-D20150525git8f38f90e04b648637509f2fa2d4208027ae59b5c.tar.gz
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 0a695b72b51bb6b4c5463279ef8751ab3eef7286 Mon Sep 17 00:00:00 2001
|
||||
From: Mamoru TASAKA <mtasaka@fedoraproject.org>
|
||||
Date: Sat, 23 May 2015 02:59:18 +0900
|
||||
Subject: [PATCH] Make file search dialog work
|
||||
|
||||
At least with GTK 3.4+, GtkNotebook no longer
|
||||
support tab_border, tab_hborder, tab_vborder
|
||||
property. With leaving these properties,
|
||||
gtk_builder_add_from_file () fails, which
|
||||
leads to file search dialog malfunction.
|
||||
|
||||
Note that GTK 2 has already deprecated
|
||||
these, so removing these should also be
|
||||
find on GTK 2
|
||||
|
||||
https://developer.gnome.org/gtk2/stable/GtkNotebook.html
|
||||
https://developer.gnome.org/gtk3/stable/GtkNotebook.html
|
||||
---
|
||||
data/ui/filesearch.glade | 3 ---
|
||||
1 file changed, 3 deletions(-)
|
||||
|
||||
diff --git a/data/ui/filesearch.glade b/data/ui/filesearch.glade
|
||||
index d8e93d4..f689a57 100644
|
||||
--- a/data/ui/filesearch.glade
|
||||
+++ b/data/ui/filesearch.glade
|
||||
@@ -183,9 +183,6 @@
|
||||
<property name="visible">True</property>
|
||||
<property name="can_focus">True</property>
|
||||
<property name="scrollable">True</property>
|
||||
- <property name="tab_border">0</property>
|
||||
- <property name="tab_hborder">0</property>
|
||||
- <property name="tab_vborder">0</property>
|
||||
<child>
|
||||
<object class="GtkVBox" id="general_settings_container">
|
||||
<property name="visible">True</property>
|
||||
--
|
||||
2.4.1
|
||||
|
@ -1,60 +0,0 @@
|
||||
From 3355a737e0a4dcb87bda28868c30b70b1cd2eb34 Mon Sep 17 00:00:00 2001
|
||||
From: Mamoru TASAKA <mtasaka@fedoraproject.org>
|
||||
Date: Sat, 23 May 2015 15:51:55 +0900
|
||||
Subject: [PATCH] Fix gdk_window_get_device_position device argument
|
||||
|
||||
http://sourceforge.net/p/pcmanfm/bugs/959/
|
||||
---
|
||||
src/gtk-compat.h | 2 ++
|
||||
src/gtk/fm-dnd-auto-scroll.c | 5 +++--
|
||||
src/gtk/fm-folder-view.c | 5 +++--
|
||||
3 files changed, 8 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/gtk-compat.h b/src/gtk-compat.h
|
||||
index 3f37fab..e460f74 100644
|
||||
--- a/src/gtk-compat.h
|
||||
+++ b/src/gtk-compat.h
|
||||
@@ -33,6 +33,8 @@ G_BEGIN_DECLS
|
||||
gdk_window_get_pointer(win,xptr,yptr,mptr)
|
||||
#else
|
||||
# define gdk_cursor_unref(obj) g_object_unref(obj)
|
||||
+# define GDK_GET_DEVICE_FROM_WINDOW(window) \
|
||||
+ gdk_device_manager_get_client_pointer (gdk_display_get_device_manager (gdk_window_get_display(window)))
|
||||
#endif
|
||||
|
||||
#if !GTK_CHECK_VERSION(2, 21, 0)
|
||||
diff --git a/src/gtk/fm-dnd-auto-scroll.c b/src/gtk/fm-dnd-auto-scroll.c
|
||||
index 72d866a..2861355 100644
|
||||
--- a/src/gtk/fm-dnd-auto-scroll.c
|
||||
+++ b/src/gtk/fm-dnd-auto-scroll.c
|
||||
@@ -55,8 +55,9 @@ static gboolean on_auto_scroll(gpointer user_data)
|
||||
if(g_source_is_destroyed(g_main_current_source()))
|
||||
return FALSE;
|
||||
|
||||
- gdk_window_get_device_position (gtk_widget_get_window(widget),
|
||||
- gtk_get_current_event_device(),
|
||||
+ GdkWindow *window = gtk_widget_get_window(widget);
|
||||
+ gdk_window_get_device_position (window,
|
||||
+ GDK_GET_DEVICE_FROM_WINDOW(window),
|
||||
&x, &y, NULL);
|
||||
gtk_widget_get_allocation(widget, &allocation);
|
||||
|
||||
diff --git a/src/gtk/fm-folder-view.c b/src/gtk/fm-folder-view.c
|
||||
index 21e7dff..8ee020e 100644
|
||||
--- a/src/gtk/fm-folder-view.c
|
||||
+++ b/src/gtk/fm-folder-view.c
|
||||
@@ -1106,8 +1106,9 @@ static void popup_position_func(GtkMenu *menu, gint *x, gint *y,
|
||||
gtk_widget_realize(GTK_WIDGET(menu));
|
||||
/* get all the relative coordinates */
|
||||
gtk_widget_get_allocation(widget, &a);
|
||||
- gdk_window_get_device_position(gtk_widget_get_window(widget),
|
||||
- gtk_get_current_event_device(), &x2, &y2, NULL);
|
||||
+ GdkWindow *window = gtk_widget_get_window(widget);
|
||||
+ gdk_window_get_device_position(window,
|
||||
+ GDK_GET_DEVICE_FROM_WINDOW(window), &x2, &y2, NULL);
|
||||
gtk_widget_get_allocation(GTK_WIDGET(menu), &ma);
|
||||
parent_window = gtk_widget_get_parent_window(widget);
|
||||
screen = gtk_widget_get_screen(widget);
|
||||
--
|
||||
2.4.1
|
||||
|
@ -1,26 +0,0 @@
|
||||
From cc726fc6cf1477f23d7d7352a757a0cb47cd5882 Mon Sep 17 00:00:00 2001
|
||||
From: Mamoru TASAKA <mtasaka@fedoraproject.org>
|
||||
Date: Sat, 23 May 2015 16:41:53 +0900
|
||||
Subject: [PATCH] exec-file.glade: remove has_separator property from GtkDialog
|
||||
|
||||
has_separator property is already deprecated from GTK 2.22
|
||||
and GTK 3 no longer supports this.
|
||||
---
|
||||
data/ui/exec-file.glade | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/data/ui/exec-file.glade b/data/ui/exec-file.glade
|
||||
index 042f1f1..7c51df6 100644
|
||||
--- a/data/ui/exec-file.glade
|
||||
+++ b/data/ui/exec-file.glade
|
||||
@@ -7,7 +7,6 @@
|
||||
<property name="title" translatable="yes">Execute File</property>
|
||||
<property name="window_position">center</property>
|
||||
<property name="type_hint">normal</property>
|
||||
- <property name="has_separator">False</property>
|
||||
<child internal-child="vbox">
|
||||
<object class="GtkVBox" id="dialog-vbox1">
|
||||
<property name="visible">True</property>
|
||||
--
|
||||
2.4.1
|
||||
|
@ -1,42 +0,0 @@
|
||||
From 72e0ca0aa2a90a05045eec9cdbc632fcedaac924 Mon Sep 17 00:00:00 2001
|
||||
From: Mamoru TASAKA <mtasaka@fedoraproject.org>
|
||||
Date: Sun, 24 May 2015 00:28:49 +0900
|
||||
Subject: [PATCH] choose-icon.ui: remove no longer supported property
|
||||
|
||||
GtkDialog.has_separator has been deprecated since
|
||||
GTK+ 2.22 and no longer supported on GTK 3.
|
||||
Note that the default is false, no removing this has
|
||||
no effect.
|
||||
https://developer.gnome.org/gtk2/stable/GtkDialog.html#GtkDialog--has-separator
|
||||
|
||||
GtkIconView.orientation is deprecated since GTK+ 2.22
|
||||
and now item-orientation should be used. GTK 3 no longer
|
||||
supports orientation.
|
||||
---
|
||||
data/ui/choose-icon.ui | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/data/ui/choose-icon.ui b/data/ui/choose-icon.ui
|
||||
index 32375b5..812c3a4 100644
|
||||
--- a/data/ui/choose-icon.ui
|
||||
+++ b/data/ui/choose-icon.ui
|
||||
@@ -16,7 +16,6 @@
|
||||
<property name="gravity">GDK_GRAVITY_NORTH_WEST</property>
|
||||
<property name="focus_on_map">True</property>
|
||||
<property name="urgency_hint">False</property>
|
||||
- <property name="has_separator">False</property>
|
||||
<child internal-child="vbox">
|
||||
<object class="GtkVBox" id="dialog-vbox1">
|
||||
<property name="visible">True</property>
|
||||
@@ -164,7 +163,7 @@
|
||||
<property name="visible">True</property>
|
||||
<property name="can_focus">True</property>
|
||||
<property name="selection_mode">GTK_SELECTION_SINGLE</property>
|
||||
- <property name="orientation">GTK_ORIENTATION_VERTICAL</property>
|
||||
+ <property name="item-orientation">GTK_ORIENTATION_VERTICAL</property>
|
||||
<property name="reorderable">False</property>
|
||||
</object>
|
||||
</child>
|
||||
--
|
||||
2.4.1
|
||||
|
15
libfm-1.2.3-right-click-sf926.patch
Normal file
15
libfm-1.2.3-right-click-sf926.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/src/gtk/fm-folder-view.c.sf926 2015-05-26 01:14:45.000000000 +0900
|
||||
+++ libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/src/gtk/fm-folder-view.c 2015-05-31 14:56:56.010343707 +0900
|
||||
@@ -1107,7 +1107,11 @@
|
||||
/* get all the relative coordinates */
|
||||
gtk_widget_get_allocation(widget, &a);
|
||||
gdk_window_get_device_position(gtk_widget_get_window(widget),
|
||||
- gtk_get_current_event_device(), &x2, &y2, NULL);
|
||||
+ gdk_device_manager_get_client_pointer(
|
||||
+ gdk_display_get_device_manager(
|
||||
+ gdk_window_get_display(
|
||||
+ gtk_widget_get_window(widget)))),
|
||||
+ &x2, &y2, NULL);
|
||||
gtk_widget_get_allocation(GTK_WIDGET(menu), &ma);
|
||||
parent_window = gtk_widget_get_parent_window(widget);
|
||||
screen = gtk_widget_get_screen(widget);
|
28
libfm.spec
28
libfm.spec
@ -8,12 +8,12 @@
|
||||
%global prerpmver %(echo "%{?prever}" | sed -e 's|-||g')
|
||||
|
||||
%global usegit 1
|
||||
%global mainrel 7
|
||||
%global mainrel 8
|
||||
|
||||
%global githash 577806e29d2ec27ce5fee9dc816566fb4e23b155
|
||||
%global githash 8f38f90e04b648637509f2fa2d4208027ae59b5c
|
||||
%global shorthash %(TMP=%githash ; echo ${TMP:0:10})
|
||||
%global gitdate Thu, 21 May 2015 21:12:05 +0900
|
||||
%global gitdate_num 20150521
|
||||
%global gitdate Mon, 25 May 2015 19:14:45 +0300
|
||||
%global gitdate_num 20150525
|
||||
|
||||
%if 0%{?usegit} >= 1
|
||||
%global fedorarel %{mainrel}.D%{gitdate_num}git%{shorthash}
|
||||
@ -32,21 +32,14 @@ Group: System Environment/Libraries
|
||||
License: GPLv2+
|
||||
URL: http://pcmanfm.sourceforge.net/
|
||||
%if 0%{?usegit} >= 1
|
||||
Source0: https://github.com/lxde/libfm/archive/%{githash}/%{name}-%{version}-%{githash}.tar.gz
|
||||
Source0: https://github.com/lxde/libfm/archive/%{githash}/%{name}-%{version}-D%{gitdate_num}git%{githash}.tar.gz
|
||||
%else
|
||||
Source0: http://downloads.sourceforge.net/pcmanfm/%{name}-%{mainver}%{?prever}.tar.xz
|
||||
%endif
|
||||
# Fedora specific patches
|
||||
# Firefox uses firefox.desktop for desktop name, drop
|
||||
#Patch0: libfm-0.1.9-pref-apps.patch
|
||||
# http://sourceforge.net/p/pcmanfm/bugs/950/
|
||||
Patch101: 0001-Make-file-search-dialog-work-with-GTK3.patch
|
||||
# http://sourceforge.net/p/pcmanfm/bugs/959/
|
||||
Patch102: 0002-Fix-gdk_window_get_device_position-device-argument.patch
|
||||
# http://sourceforge.net/p/pcmanfm/bugs/961/
|
||||
Patch103: 0003-exec-file.glade-remove-has_separator-property-from-G.patch
|
||||
# http://sourceforge.net/p/pcmanfm/bugs/962/
|
||||
Patch104: 0004-choose-icon.ui-remove-no-longer-supported-property.patch
|
||||
Patch101: libfm-1.2.3-right-click-sf926.patch
|
||||
|
||||
BuildRequires: libexif-devel
|
||||
BuildRequires: gtk3-devel
|
||||
@ -146,10 +139,8 @@ This package containg development documentation files for %{name}.
|
||||
#%%setup -q -n %{name}-%{version}%{?prever}
|
||||
#%%patch0 -p1 -b .orig
|
||||
%setup -q -n %{name}-%{githash}
|
||||
%patch101 -p1
|
||||
%patch102 -p1
|
||||
%patch103 -p1
|
||||
%patch104 -p1
|
||||
|
||||
%patch101 -p1 -b .sf926
|
||||
|
||||
%if 0%{?usegit} >= 1
|
||||
sh autogen.sh
|
||||
@ -294,6 +285,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun May 31 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.2.3-8.D20150525git8f38f90e04
|
||||
- Update to the latest git, all removing patches applied upstream
|
||||
|
||||
* Sun May 24 2015 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.2.3-7.D20150521git577806e29d
|
||||
- Fix another GTK3 related bug
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user