Fix crash when pasting large string when completion matches (bug 1437443)
Build error fix with vala 0.36
This commit is contained in:
parent
b4931f71b3
commit
cbb465a476
11
libfm-1.2.5-gtk-completion-segv-fix-when-paste.patch
Normal file
11
libfm-1.2.5-gtk-completion-segv-fix-when-paste.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- libfm-1.2.5/src/gtk/fm-path-entry.c.comp 2016-02-20 09:02:10.000000000 +0900
|
||||
+++ libfm-1.2.5/src/gtk/fm-path-entry.c 2017-04-07 12:11:11.442747622 +0900
|
||||
@@ -746,7 +746,7 @@
|
||||
gtk_tree_model_get(model, iter, COL_BASENAME, &model_file_name, -1);
|
||||
model_file_name_len = strlen(model_file_name);
|
||||
|
||||
- if( priv->highlight_completion_match )
|
||||
+ if( priv->highlight_completion_match && (model_file_name_len >= priv->typed_basename_len) )
|
||||
{
|
||||
int buf_len = model_file_name_len + 14 + 1;
|
||||
gchar* markup = g_malloc(buf_len);
|
20
libfm-1.2.5-vala-036.patch
Normal file
20
libfm-1.2.5-vala-036.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- libfm-1.2.5/src/actions/action.vala.vala036 2016-02-20 09:02:10.000000000 +0900
|
||||
+++ libfm-1.2.5/src/actions/action.vala 2017-04-07 12:18:03.127932008 +0900
|
||||
@@ -78,7 +78,7 @@
|
||||
id = desktop_id;
|
||||
try {
|
||||
kf.load_from_file(desktop_id, 0);
|
||||
- FileAction.from_keyfile(kf);
|
||||
+ this.from_keyfile(kf);
|
||||
}
|
||||
catch(KeyFileError err) {
|
||||
}
|
||||
@@ -141,7 +141,7 @@
|
||||
id = desktop_id;
|
||||
try {
|
||||
kf.load_from_file(desktop_id, 0);
|
||||
- FileActionMenu.from_keyfile(kf);
|
||||
+ this.from_keyfile(kf);
|
||||
}
|
||||
catch(KeyFileError err) {
|
||||
}
|
14
libfm.spec
14
libfm.spec
@ -9,7 +9,7 @@
|
||||
%global prerpmver %(echo "%{?prever}" | sed -e 's|-||g')
|
||||
|
||||
%global usegit 0
|
||||
%global mainrel 2
|
||||
%global mainrel 3
|
||||
%global githash ab583d7800bbc308f2852384f87c2357f49b01cd
|
||||
%global shorthash %(TMP=%githash ; echo ${TMP:0:10})
|
||||
%global gitdate Fri, 9 Dec 2016 01:44:54 +0200
|
||||
@ -45,6 +45,12 @@ Patch102: libfm-1.2.4-fix-use-after-free-cfgfile.patch
|
||||
# Firefox uses firefox.desktop for desktop name, drop
|
||||
#Patch0: libfm-0.1.9-pref-apps.patch
|
||||
|
||||
# Need reporting to the upstream
|
||||
# Fix crash when pasting large string when completion matches (bug 1437443)
|
||||
Patch103: libfm-1.2.5-gtk-completion-segv-fix-when-paste.patch
|
||||
# Build error fix with vala 0.36
|
||||
Patch104: libfm-1.2.5-vala-036.patch
|
||||
|
||||
# http://sourceforge.net/p/pcmanfm/feature-requests/385/
|
||||
Patch1000: http://sourceforge.net/p/pcmanfm/feature-requests/_discuss/thread/0a50a386/597e/attachment/libfm-1.2.3-moduledir-gtkspecific-v02.patch
|
||||
|
||||
@ -193,6 +199,8 @@ cp -a %{SOURCE1} .
|
||||
%endif
|
||||
|
||||
%patch102 -p1
|
||||
%patch103 -p1
|
||||
%patch104 -p1
|
||||
%if 0%{?fedora} >= 22
|
||||
%patch1000 -p1
|
||||
%endif
|
||||
@ -399,6 +407,10 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Apr 7 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.2.5-3
|
||||
- Fix crash when pasting large string when completion matches (bug 1437443)
|
||||
- Build error fix with vala 0.36
|
||||
|
||||
* Mon Feb 6 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.2.5-2
|
||||
- spec file fix for bootstrap mode on fedora (bug 1419338)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user