1.3.0.2 release

This commit is contained in:
Mamoru TASAKA 2018-04-29 22:07:36 +09:00
parent bfe1c3dda8
commit bae91adccb
7 changed files with 25 additions and 152 deletions

1
.gitignore vendored
View File

@ -39,3 +39,4 @@ libfm-0.1.12.tar.gz
/libfm-1.2.4-D20161209gitab583d7800bbc308f2852384f87c2357f49b01cd.tar.gz
/libfm-1.2.5.tar.xz
/libfm-20171230T1949.tar.gz
/libfm-1.3.0.2.tar.xz

View File

@ -1,27 +0,0 @@
--- libfm-2a537414def87ebd75024a74030e60582cd78c45/src/base/fm-config.c.orig 2016-06-27 17:41:36.000000000 +0900
+++ libfm-2a537414def87ebd75024a74030e60582cd78c45/src/base/fm-config.c 2016-08-28 15:23:42.557464377 +0900
@@ -339,14 +339,15 @@
{
const gchar * const *dirs, * const *dir;
char *path;
+ char *old_cfg_name;
GKeyFile* kf = g_key_file_new();
+ old_cfg_name = cfg->_cfg_name;
g_strfreev(cfg->modules_blacklist);
g_strfreev(cfg->system_modules_blacklist);
cfg->modules_blacklist = NULL;
cfg->system_modules_blacklist = NULL;
_cfg_monitor_free(cfg);
- g_free(cfg->_cfg_name);
if(G_LIKELY(!name))
name = "libfm/libfm.conf";
else
@@ -391,6 +392,7 @@
_out:
g_key_file_free(kf);
g_signal_emit(cfg, signals[CHANGED], 0);
+ g_free(old_cfg_name);
/* FIXME: compare and send individual changes instead */
}

View File

@ -1,28 +0,0 @@
From f5f3d488480495f3c4ec727dcdaef49b2295ac4e Mon Sep 17 00:00:00 2001
From: Mamoru TASAKA <mtasaka@fedoraproject.org>
Date: Sat, 8 Apr 2017 01:34:32 +0900
Subject: [PATCH] Fix segv on pasting large string when completion matches
On fm_path_entry_completion_render_func(), priv->typed_basename_len
can be larger than model_file_name_len when pasting string from
cripboard when completion matches.
---
src/gtk/fm-path-entry.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/gtk/fm-path-entry.c b/src/gtk/fm-path-entry.c
index 3d5905b9..661b908e 100644
--- a/src/gtk/fm-path-entry.c
+++ b/src/gtk/fm-path-entry.c
@@ -746,7 +746,7 @@ static void fm_path_entry_completion_render_func(GtkCellLayout *cell_layout,
gtk_tree_model_get(model, iter, COL_BASENAME, &model_file_name, -1);
model_file_name_len = strlen(model_file_name);
- if( priv->highlight_completion_match )
+ if( priv->highlight_completion_match && (model_file_name_len >= priv->typed_basename_len) )
{
int buf_len = model_file_name_len + 14 + 1;
gchar* markup = g_malloc(buf_len);
--
2.12.2

View File

@ -1,48 +0,0 @@
From 7a93547cb4a4640e58f0182540aee091aebb3ae9 Mon Sep 17 00:00:00 2001
From: Mamoru TASAKA <mtasaka@fedoraproject.org>
Date: Sat, 8 Apr 2017 01:21:06 +0900
Subject: [PATCH] Fix build error with vala 0.36.1
On Fedora 26 (using vala 0.36.1), rebuilding libfm causes
a error as:
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/valac --thread --vapidir=./../vapi --pkg gio-2.0 --pkg posix --pkg libfm --vapi ./../vapi/fm-actions.vapi --header fm-actions.h -C action.vala condition.vala profile.vala parameters.vala utils.vala
condition.vala:149.18-155.34: warning: unhandled error `GLib.Error'
condition.vala:192.8-193.40: warning: unhandled error `GLib.SpawnError'
action.vala:81.4-81.30: error: use `new' operator to create new objects
FileAction.from_keyfile(kf);
^^^^^^^^^^^^^^^^^^^^^^^^^^^
action.vala:144.4-144.34: error: use `new' operator to create new objects
FileActionMenu.from_keyfile(kf);
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Instead of using class name, "this" must be used here.
---
src/actions/action.vala | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/actions/action.vala b/src/actions/action.vala
index 53b512ec..18738589 100644
--- a/src/actions/action.vala
+++ b/src/actions/action.vala
@@ -78,7 +78,7 @@ public class FileAction : FileActionObject {
id = desktop_id;
try {
kf.load_from_file(desktop_id, 0);
- FileAction.from_keyfile(kf);
+ this.from_keyfile(kf);
}
catch(KeyFileError err) {
}
@@ -141,7 +141,7 @@ public class FileActionMenu : FileActionObject {
id = desktop_id;
try {
kf.load_from_file(desktop_id, 0);
- FileActionMenu.from_keyfile(kf);
+ this.from_keyfile(kf);
}
catch(KeyFileError err) {
}
--
2.12.2

View File

@ -1,5 +1,5 @@
--- libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/configure.ac.moduledir 2015-05-26 01:14:45.000000000 +0900
+++ libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/configure.ac 2015-06-01 16:59:15.758431997 +0900
--- libfm-1.3.0.2/configure.ac.moduledir 2018-04-29 05:06:53.000000000 +0900
+++ libfm-1.3.0.2/configure.ac 2018-04-29 17:54:40.014818903 +0900
@@ -117,12 +117,14 @@ if test x"$ac_with_gtk" != xno; then
LIBFM_GTK_LTLIBRARIES=libfm-gtk3.la
LIBFM_GTK_PC=libfm-gtk3.pc
@ -31,9 +31,9 @@
AM_CONDITIONAL([ENABLE_GTK], [test x$ac_with_gtk != xnone])
dnl pango_modules="pango >= 1.16.0"
--- libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/src/Makefile.am.moduledir 2015-05-26 01:14:45.000000000 +0900
+++ libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/src/Makefile.am 2015-06-01 16:59:15.759431997 +0900
@@ -313,6 +313,7 @@ libfm_gtk_la_CFLAGS = \
--- libfm-1.3.0.2/src/Makefile.am.moduledir 2018-04-29 04:15:18.000000000 +0900
+++ libfm-1.3.0.2/src/Makefile.am 2018-04-29 17:54:40.014818903 +0900
@@ -315,6 +315,7 @@ libfm_gtk_la_CFLAGS = \
-I$(srcdir)/gtk \
-DPACKAGE_UI_DIR=\""$(datadir)/libfm/ui"\" \
-DPACKAGE_THEME_DIR=\""$(datadir)/libfm/images"\" \
@ -41,8 +41,8 @@
$(GTK_CFLAGS) \
$(MENU_CACHE_CFLAGS) \
$(NULL)
--- libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/src/fm-gtk.c.moduledir 2015-06-01 17:04:33.951498868 +0900
+++ libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/src/fm-gtk.c 2015-06-01 17:04:59.933504328 +0900
--- libfm-1.3.0.2/src/fm-gtk.c.moduledir 2018-04-17 04:11:33.000000000 +0900
+++ libfm-1.3.0.2/src/fm-gtk.c 2018-04-29 17:54:40.014818903 +0900
@@ -57,6 +57,7 @@ gboolean fm_gtk_init(FmConfig* config)
if no theme was selected and GTK fallback isn't available then no icons
are shown - we should add folder and file icons as fallbacks theme */
@ -51,9 +51,9 @@
_fm_icon_pixbuf_init();
_fm_thumbnail_init();
_fm_file_properties_init();
--- libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/src/modules/Makefile.am.moduledir 2015-05-26 01:14:45.000000000 +0900
+++ libfm-8f38f90e04b648637509f2fa2d4208027ae59b5c/src/modules/Makefile.am 2015-06-01 16:59:15.759431997 +0900
@@ -18,6 +18,7 @@ LIBS += $(top_builddir)/src/libfm.la
--- libfm-1.3.0.2/src/modules/Makefile.am.moduledir 2018-04-29 05:00:55.000000000 +0900
+++ libfm-1.3.0.2/src/modules/Makefile.am 2018-04-29 17:57:06.097345230 +0900
@@ -19,6 +19,7 @@ LIBS += $(top_builddir)/src/libfm.la
# change default and put modules below usual place
pkglibdir = $(libdir)/@PACKAGE@/modules
@ -61,7 +61,7 @@
# modules to compile
pkglib_LTLIBRARIES = \
@@ -25,11 +26,14 @@ pkglib_LTLIBRARIES = \
@@ -26,8 +27,11 @@ pkglib_LTLIBRARIES = \
vfs-search.la \
$(NULL)
@ -69,16 +69,12 @@
+ $(NULL)
+
if ENABLE_GTK
if HAVE_ACTIONS
-pkglib_LTLIBRARIES += gtk-menu-actions.la
+pkggtklib_LTLIBRARIES += gtk-menu-actions.la
endif
-pkglib_LTLIBRARIES += \
+pkggtklib_LTLIBRARIES += \
gtk-fileprop-x-desktop.la \
gtk-fileprop-x-shortcut.la \
gtk-menu-trash.la \
@@ -39,10 +43,14 @@ endif
@@ -38,10 +42,14 @@ endif
# install only .so files, we don't need .la files
install-exec-hook:
rm -f $(DESTDIR)$(pkglibdir)/*.la

View File

@ -3,9 +3,9 @@
# Upstream git:
# git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/libfm
# add bootstrap, need to build menu-cache in epel7
%global userelease 0
%global userelease 1
%global usegit 0
%global usegitbare 1
%global usegitbare 0
%if 0%{?usegit} < 1
%if 0%{?usegitbare} < 1
@ -15,11 +15,11 @@
%endif
%global bootstrap 0
%global mainver 1.2.5
%global mainver 1.3.0.2
%undefine prever
%global prerpmver %(echo "%{?prever}" | sed -e 's|-||g')
%global mainrel 5
%global mainrel 1
%if 0%{?usegit} >= 1
%global githash ab583d7800bbc308f2852384f87c2357f49b01cd
@ -47,7 +47,7 @@
Name: libfm
Version: %{mainver}
Release: %{fedorarel}%{?dist}.1
Release: %{fedorarel}%{?dist}
Summary: GIO-based library for file manager-like programs
Group: System Environment/Libraries
@ -65,21 +65,9 @@ Source0: libfm-%{gitbaredate}T%{gitbaretime}.tar.gz
%endif
Source10: create-libfm-git-bare-tarball.sh
#
# https://github.com/lxde/libfm/pull/11
Patch102: libfm-1.2.4-fix-use-after-free-cfgfile.patch
# Fedora specific patches
# Firefox uses firefox.desktop for desktop name, drop
#Patch0: libfm-0.1.9-pref-apps.patch
# Fix crash when pasting large string when completion matches (bug 1437443)
# https://github.com/lxde/libfm/pull/23
Patch103: libfm-1.2.5-0103-Fix-segv-on-pasting-large-string-when-completion-mat.patch
# https://github.com/lxde/libfm/pull/22
Patch104: libfm-1.2.5-0104-Fix-build-error-with-vala-0.36.1.patch
# http://sourceforge.net/p/pcmanfm/feature-requests/385/
Patch1000: http://sourceforge.net/p/pcmanfm/feature-requests/_discuss/thread/0a50a386/597e/attachment/libfm-1.2.3-moduledir-gtkspecific-v02.patch
#Patch1000: http://sourceforge.net/p/pcmanfm/feature-requests/_discuss/thread/0a50a386/597e/attachment/libfm-1.2.3-moduledir-gtkspecific-v02.patch
Patch1000: libfm-1.3.0.2-moduledir-gtkspecific-v03.patch
BuildRequires: libexif-devel
BuildRequires: gtk3-devel
@ -231,9 +219,6 @@ cp -a %{SOURCE1} .
%endif
%if 0%{?usegitbare} < 1
%patch102 -p1
%patch103 -p1
%patch104 -p1
%endif
%if 0%{?usegitbare} >= 1
@ -245,17 +230,8 @@ cp -a [A-Z]* ..
git config user.name "libfm Fedora maintainer"
git config user.email "libfm-maintainer@fedoraproject.org"
git checkout -b 1.2.5-fedora 1.2.5
git checkout -b %{version}-fedora %{version}
cat > GITHASH <<EOF
5d03c2d8dc5570e31d5a65c3b8fac97d5755fd36 # Fix build error with vala 0.36.1
e5c73a74bda8291d8505baa6cc2fc02081a72ec9 # Fix crash on launching nonexistent link targets
b072ee0400432d72fdf86ba9fed74a7e0ec11ec1 # Enclose text in <programlisting> into <![CDATA[
b5d9766e075af84c1d69c927efcf25b64133dbfc # Added tooltips for attributes of copying files
7831e2990e8e945a2cafc7b7183a37cf85733a64 # Do not save thumbnails generated from the thumbnail cache directory
08e84d222fbec91a3d3993cece093a2d884e8ec9 # Fix segv on pasting large string when completion matches
569aa07ab01c057bf2d5bdaabd5bbfd9f4b7e15f # Prevent corrupted image thumbnails
b1ddf2a0c0d8746e35ed90ea89266fe80c06797a # Fix use after free error. See https://github.com/lxde/libfm/pull/11
7ef910dd9e4a94c25e9bb14b39e9f6fd003d8ca7 # Do not extract extension for directories
EOF
cat GITHASH | while read line
@ -515,6 +491,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%endif
%changelog
* Sun Apr 29 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.3.0.2-1
- 1.3.0.2 release
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.5-5.gitD20171230.1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (libfm-20171230T1949.tar.gz) = bd642e621093f9c29aaf5c535f83ed728d45c2f81c0e05ccaea15478044fcafc64e25e5949dd6dbab2406705629afef52f851f866d4bd97fd8d7a0e7da9e16dd
SHA512 (libfm-1.3.0.2.tar.xz) = 179cc0350509cb1a8a60b89f8145169857926c7cc3dadb9f61078d4dba79709b248b3d05862e78c11747f1fc4e45825ad6f4916d423ae5e346e5274d34197445