Merge remote-tracking branch 'origin/master' into f17

This commit is contained in:
Mamoru Tasaka 2012-11-04 02:34:48 +09:00
commit 792a65703b
5 changed files with 57 additions and 35 deletions

1
.gitignore vendored
View File

@ -11,3 +11,4 @@ libfm-0.1.12.tar.gz
/libfm-0.1.17.tar.gz
/libfm-1.0.tar.gz
/libfm-1.0.1.tar.gz
/libfm-1.1.0.tar.gz

View File

@ -1,11 +0,0 @@
--- libfm-0.1.14/configure.ac.debug 2010-10-04 04:17:16.000000000 +0900
+++ libfm-0.1.14/configure.ac 2010-10-13 05:28:54.000000000 +0900
@@ -43,7 +43,7 @@
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
-glib_modules="glib-2.0 >= 2.18.0"
+glib_modules="glib-2.0 >= 2.18.0 gobject-2.0"
PKG_CHECK_MODULES(GLIB, [$glib_modules])
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)

View File

@ -1,9 +0,0 @@
--- libfm-1.0.1/src/tests/Makefile.am.dso 2012-09-27 15:45:02.621895881 +0900
+++ libfm-1.0.1/src/tests/Makefile.am 2012-09-27 15:45:38.451173597 +0900
@@ -19,5 +19,6 @@
TEST_PROGS += fm-path
fm_path_SOURCES = test-fm-path.c
fm_path_LDADD= \
+ $(GIO_LIBS) \
../libfm.la \
$(NULL)

View File

@ -6,6 +6,11 @@
%global usegit 0
%global mainrel 1
%global usegtk3 0
%if 0%{?fedora} >= 18
%global usegtk3 1
%endif
%global githash d22b41fd2f738164c2cc89f6ae5d08c8bea6c65c
%global shorthash %(TMP=%githash ; echo ${TMP:0:10})
%global gitdate Sun Aug 7 19:27:20 2011 +0800
@ -17,10 +22,10 @@
%global fedorarel %{mainrel}
%endif
%global build_doc 1
%global build_doc 1
Name: libfm
Version: 1.0.1
Version: 1.1.0
Release: %{fedorarel}%{?dist}
Summary: GIO-based library for file manager-like programs
@ -34,11 +39,13 @@ Source0: http://downloads.sourceforge.net/pcmanfm/%{name}-%{version}.tar.
%endif
# Fedora specific patches
Patch0: libfm-0.1.9-pref-apps.patch
# Fix dso linkage
Patch1: libfm-1.0.1-dsolink-tests.patch
BuildRequires: libexif-devel
%if %{usegtk3}
BuildRequires: gtk3-devel
%else
BuildRequires: gtk2-devel >= 2.16.0
%endif
BuildRequires: menu-cache-devel >= 0.3.2
BuildRequires: gettext
@ -48,7 +55,9 @@ BuildRequires: desktop-file-utils
# Patch1
BuildRequires: automake
BuildRequires: libtool
BuildRequires: gtk-doc
BuildRequires: libxslt
%if 0%{?fedora} >= 18
BuildRequires: dbus-glib-devel
@ -121,8 +130,12 @@ This package containg development documentation files for %{name}.
%prep
%setup -q
%patch0 -p1 -b .orig
%patch1 -p1 -b .dso
# Patch1
%if %{usegtk3}
sed -i.gtk3 \
-e 's|libfm-gtk.la|libfm-gtk3.la|' \
docs/reference/libfm/Makefile.am
%endif
autoreconf -fi
# ???
@ -136,8 +149,12 @@ sed -i.libdir_syssearch \
%build
%configure \
--enable-gtk-doc \
%if 0%{?fedora} >= 18
--enable-udisks \
%endif
%if %{usegtk3}
--with-gtk=3 \
%endif
--disable-static
# To show translation status
@ -148,6 +165,12 @@ make %{?_smp_mflags} -k
%install
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
%if %{usegtk3}
rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libfm-gtk.pc
%else
rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libfm-gtk3.pc
%endif
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
desktop-file-validate %{buildroot}/%{_datadir}/applications/*.desktop
%find_lang %{name}
@ -155,21 +178,21 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/*.desktop
echo '%%defattr(-,root,root,-)' > base-header.files
echo '%%defattr(-,root,root,-)' > gtk-header.files
for f in $RPM_BUILD_ROOT%_includedir/%name/%name/*.h
for f in $RPM_BUILD_ROOT%_includedir/%name-1.0/*.h
do
bf=$(basename $f)
for dir in actions base job
do
if [ -f src/$dir/$bf ]
then
echo %_includedir/%name/%name/$bf >> base-header.files
echo %_includedir/%name-1.0/$bf >> base-header.files
fi
done
for dir in gtk
do
if [ -f src/$dir/$bf ]
then
echo %_includedir/%name/%name/$bf >> gtk-header.files
echo %_includedir/%name-1.0/$bf >> gtk-header.files
fi
done
done
@ -180,6 +203,12 @@ done
/sbin/ldconfig
update-mime-database %{_datadir}/mime &> /dev/null || :
%pre devel
# Directory -> symlink
if [ -d %{_includedir}/libfm ] ; then
rm -rf %{_includedir}/libfm
fi
%postun
/sbin/ldconfig
update-mime-database %{_datadir}/mime &> /dev/null || :
@ -204,8 +233,12 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%defattr(-,root,root,-)
%{_mandir}/man1/libfm-pref-apps.1.*
%{_bindir}/libfm-pref-apps
%if %{usegtk3}
%{_libdir}/%{name}-gtk3.so.3*
%else
%{_libdir}/%{name}-gtk.so.3*
#%%dir %{_libdir}/libfm/
%endif
#%%dir %%{_libdir}/libfm/
#%%{_libdir}/libfm/gnome-terminal
%{_datadir}/libfm/
%{_datadir}/applications/libfm-pref-apps.desktop
@ -214,17 +247,22 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%files devel -f base-header.files
%defattr(-,root,root,-)
%doc TODO
%dir %{_includedir}/libfm/
%dir %{_includedir}/libfm/libfm/
%{_includedir}/libfm/libfm/fm.h
%{_includedir}/libfm
%dir %{_includedir}/libfm-1.0/
%{_includedir}/libfm-1.0/fm.h
%{_libdir}/%{name}.so
%{_libdir}/pkgconfig/libfm.pc
%files gtk-devel -f gtk-header.files
%defattr(-,root,root,-)
%{_includedir}/libfm/libfm/fm-gtk.h
%{_includedir}/libfm-1.0/fm-gtk.h
%if %{usegtk3}
%{_libdir}/%{name}-gtk3.so
%{_libdir}/pkgconfig/libfm-gtk3.pc
%else
%{_libdir}/%{name}-gtk.so
%{_libdir}/pkgconfig/libfm-gtk.pc
%endif
%if 0%{?build_doc}
%files devel-docs
@ -235,6 +273,9 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
%endif
%changelog
* Sun Nov 4 2012 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.1.0-1
- 1.1.0
* Wed Sep 27 2012 Mamoru Tasaka <mtasaka@fedoraproject.org> - 1.0.1-1
- 1.0.1

View File

@ -1 +1 @@
7fb406f38f99c9171661f72fa6d4da7f libfm-1.0.1.tar.gz
a5bc8b8291cf810c659bfb3af378b5de libfm-1.1.0.tar.gz