Workaround for column collapse issue when double-clicking separator
This commit is contained in:
parent
a0b2590d63
commit
7427be9d13
12
libfm-1.1.2.2-bz3614948.patch
Normal file
12
libfm-1.1.2.2-bz3614948.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- libfm-1.1.2.2/src/gtk/fm-standard-view.c.bz3614948 2013-08-23 04:45:34.000000000 +0900
|
||||
+++ libfm-1.1.2.2/src/gtk/fm-standard-view.c 2013-08-30 11:05:20.913403060 +0900
|
||||
@@ -616,6 +616,9 @@
|
||||
gtk_tree_view_column_set_expand(col, TRUE);
|
||||
gtk_tree_view_column_set_sizing(col, GTK_TREE_VIEW_COLUMN_FIXED);
|
||||
gtk_tree_view_column_set_fixed_width(col, 200);
|
||||
+#if GTK_CHECK_VERSION(3, 0, 0)
|
||||
+ gtk_tree_view_column_set_min_width(col, 50);
|
||||
+#endif
|
||||
}
|
||||
else
|
||||
{
|
15
libfm.spec
15
libfm.spec
@ -4,7 +4,7 @@
|
||||
# git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/libfm
|
||||
|
||||
%global usegit 0
|
||||
%global mainrel 1
|
||||
%global mainrel 2
|
||||
|
||||
%global githash e2f4578bd5e89c7a12eae19abd8df7f9f599d115
|
||||
%global shorthash %(TMP=%githash ; echo ${TMP:0:10})
|
||||
@ -36,6 +36,11 @@ Source0: http://downloads.sourceforge.net/pcmanfm/%{name}-%{version}.tar.
|
||||
Source1: libfm-pref-apps.desktop.in
|
||||
# Fedora specific patches
|
||||
Patch0: libfm-0.1.9-pref-apps.patch
|
||||
# Workaround for sf bug 3614948 and 3614947
|
||||
# Clicking separator between Name and Description collapses Name
|
||||
# column completely and makes libfm abort.
|
||||
# ref: GNOME bugzilla 668779 and 698874
|
||||
Patch10: libfm-1.1.2.2-bz3614948.patch
|
||||
|
||||
BuildRequires: libexif-devel
|
||||
BuildRequires: gtk3-devel
|
||||
@ -119,6 +124,7 @@ This package containg development documentation files for %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .orig
|
||||
%patch10 -p1 -b .bz3614948
|
||||
|
||||
install -cpm 644 %{SOURCE1} data/
|
||||
|
||||
@ -136,7 +142,11 @@ sed -i.libdir_syssearch \
|
||||
--enable-gtk-doc \
|
||||
--enable-udisks \
|
||||
--with-gtk=3 \
|
||||
%if 0
|
||||
--enable-demo \
|
||||
%endif
|
||||
--disable-static
|
||||
|
||||
# To show translation status
|
||||
make -C po -j1 GMSGFMT="msgfmt --statistics"
|
||||
make %{?_smp_mflags} -k
|
||||
@ -243,6 +253,9 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Aug 30 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.1.2.2-2
|
||||
- Workaround for column collapse issue when double-clicking separator
|
||||
|
||||
* Wed Aug 21 2013 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.1.2.2-1
|
||||
- 1.1.2.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user