diff --git a/libffado-errno.patch b/libffado-errno.patch
new file mode 100644
index 0000000..de4275b
--- /dev/null
+++ b/libffado-errno.patch
@@ -0,0 +1,52 @@
+diff --git a/tests/test-enhanced-mixer.cpp b/tests/test-enhanced-mixer.cpp
+index 8ac00aa..d557daf 100644
+--- a/tests/test-enhanced-mixer.cpp
++++ b/tests/test-enhanced-mixer.cpp
+@@ -77,7 +77,7 @@ main(int argc, char **argv)
+         exit(0);
+     }
+ 
+-    int errno = 0;
++    errno = 0;
+     char* tail;
+     int node_id = strtol( argv[1], &tail, 0 );
+     int fb_id   = strtol( argv[2], &tail, 0 );
+diff --git a/tests/test-mixer.cpp b/tests/test-mixer.cpp
+index 807bd7b..5f426a7 100644
+--- a/tests/test-mixer.cpp
++++ b/tests/test-mixer.cpp
+@@ -227,7 +227,7 @@ main( int argc, char **argv )
+         exit(0);
+     }
+ 
+-    int errno = 0;
++    errno = 0;
+     char* tail;
+     int port = strtol( argv[1], &tail, 0 );
+     int node_id = strtol( argv[2], &tail, 0 );
+diff --git a/tests/test-pan.cpp b/tests/test-pan.cpp
+index 4b7b825..895c9cf 100644
+--- a/tests/test-pan.cpp
++++ b/tests/test-pan.cpp
+@@ -131,7 +131,7 @@ main(int argc, char **argv)
+         exit(0);
+     }
+ 
+-    int errno = 0;
++    errno = 0;
+     char* tail;
+     int node_id = strtol( argv[1], &tail, 0 );
+     int fb_id   = strtol( argv[2], &tail, 0 );
+diff --git a/tests/test-volume.cpp b/tests/test-volume.cpp
+index 65ccb8b..6810819 100644
+--- a/tests/test-volume.cpp
++++ b/tests/test-volume.cpp
+@@ -127,7 +127,7 @@ main(int argc, char **argv)
+         exit(0);
+     }
+ 
+-    int errno = 0;
++    errno = 0;
+     char* tail;
+     int node_id = strtol( argv[1], &tail, 0 );
+     int fb_id   = strtol( argv[2], &tail, 0 );
diff --git a/libffado.spec b/libffado.spec
index dc87c16..60d66bb 100644
--- a/libffado.spec
+++ b/libffado.spec
@@ -1,7 +1,7 @@
 Summary:        Free firewire audio driver library
 Name:           libffado
 Version:        2.2.1
-Release:        5%{?dist}
+Release:        6%{?dist}
 # src/libutil/float_cast.h is LGPLv2+.
 # The rest is (GPLv2 or GPLv3)
 License:        LGPLv2+ and (GPLv2 or GPLv3)
@@ -15,6 +15,8 @@ Source9:        libffado-snapshot.sh
 # We want the documentation for the library API only, not for the entire source:
 # http://subversion.ffado.org/ticket/293
 Patch0:         libffado-api-doc-only.patch
+Patch1:         libffado-errno.patch
+
 BuildRequires:  alsa-lib-devel
 BuildRequires:  dbus-c++-devel
 BuildRequires:  dbus-devel
@@ -68,13 +70,14 @@ Applications and utilities for use with libffado.
 %prep
 %setup -q
 %patch0 -p1 -b .api.doc.only
+%patch1 -p1 -b .errno
 
 # We don't want to install all tests
 sed -i '/Install/d' tests/{,*/}SConscript
 
 %build
 scons %{?_smp_mflags} \
-      COMPILE_FLAGS="%{optflags} -ffast-math" \
+      COMPILE_FLAGS="%{optflags} -ffast-math --std=gnu++11" \
       PREFIX=%{_prefix} \
       LIBDIR=%{_libdir} \
       MANDIR=%{_mandir} \
@@ -138,6 +141,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
 
 
 %changelog
+* Fri Jan 22 2016 Lubomir Rintel <lkundrak@v3.sk> - 2.2.1-6
+- Fix FTBFS
+
 * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-5
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild