Update to 3.15.1

- Drop flex, getopt, and include patches fixed upstream
This commit is contained in:
Orion Poplawski 2015-09-23 09:59:37 -06:00
parent 43eaef550c
commit c2f20b8f8d
7 changed files with 25 additions and 466 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@ libdap-3.10.2.tar.gz
/libdap-3.13.1.tar.gz
/libdap-3.13.3.tar.gz
/libdap-3.14.0.tar.gz
/libdap-3.15.1.tar.gz

View File

@ -1,48 +0,0 @@
diff -up libdap-3.14.0/d4_ce/lex.d4_ce.cc.flex libdap-3.14.0/d4_ce/lex.d4_ce.cc
--- libdap-3.14.0/d4_ce/lex.d4_ce.cc.flex 2015-04-07 00:45:50.000000000 -0600
+++ libdap-3.14.0/d4_ce/lex.d4_ce.cc 2015-04-16 11:12:38.074231518 -0600
@@ -1276,9 +1276,9 @@ void yyFlexLexer::switch_streams( std::i
}
#ifdef YY_INTERACTIVE
-size_t yyFlexLexer::LexerInput( char* buf, size_t /* max_size */ )
+int yyFlexLexer::LexerInput( char* buf, int /* max_size */ )
#else
-size_t yyFlexLexer::LexerInput( char* buf, size_t max_size )
+int yyFlexLexer::LexerInput( char* buf, int max_size )
#endif
{
if ( yyin->eof() || yyin->fail() )
@@ -1305,7 +1305,7 @@ size_t yyFlexLexer::LexerInput( char* bu
#endif
}
-void yyFlexLexer::LexerOutput( const char* buf, size_t size )
+void yyFlexLexer::LexerOutput( const char* buf, int size )
{
(void) yyout->write( buf, size );
}
diff -up libdap-3.14.0/d4_ce/lex.d4_function.cc.flex libdap-3.14.0/d4_ce/lex.d4_function.cc
--- libdap-3.14.0/d4_ce/lex.d4_function.cc.flex 2015-04-03 22:47:36.000000000 -0600
+++ libdap-3.14.0/d4_ce/lex.d4_function.cc 2015-04-16 11:12:52.096512693 -0600
@@ -1303,9 +1303,9 @@ void yyFlexLexer::switch_streams( std::i
}
#ifdef YY_INTERACTIVE
-size_t yyFlexLexer::LexerInput( char* buf, size_t /* max_size */ )
+int yyFlexLexer::LexerInput( char* buf, int /* max_size */ )
#else
-size_t yyFlexLexer::LexerInput( char* buf, size_t max_size )
+int yyFlexLexer::LexerInput( char* buf, int max_size )
#endif
{
if ( yyin->eof() || yyin->fail() )
@@ -1332,7 +1332,7 @@ size_t yyFlexLexer::LexerInput( char* bu
#endif
}
-void yyFlexLexer::LexerOutput( const char* buf, size_t size )
+void yyFlexLexer::LexerOutput( const char* buf, int size )
{
(void) yyout->write( buf, size );
}

View File

@ -1,352 +0,0 @@
diff -up libdap-3.14.0/DODSFilter.cc.getopt libdap-3.14.0/DODSFilter.cc
--- libdap-3.14.0/DODSFilter.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/DODSFilter.cc 2015-04-17 08:31:53.957194018 -0600
@@ -262,7 +262,7 @@ DODSFilter::process_options(int argc, ch
int option_char;
GetOpt getopt (argc, argv, "ce: v: d: f: r: l: o: u: t: ");
- while ((option_char = getopt()) != EOF) {
+ while ((option_char = getopt()) != -1) {
switch (option_char) {
case 'c': d_comp = true; break;
case 'e': set_ce(getopt.optarg); break;
diff -up libdap-3.14.0/getdap4.cc.getopt libdap-3.14.0/getdap4.cc
--- libdap-3.14.0/getdap4.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/getdap4.cc 2015-04-17 08:31:54.065195941 -0600
@@ -179,7 +179,7 @@ int main(int argc, char *argv[])
_setmode(_fileno(stdout), _O_BINARY);
#endif
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
get_dmr = true;
diff -up libdap-3.14.0/getdap.cc.getopt libdap-3.14.0/getdap.cc
--- libdap-3.14.0/getdap.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/getdap.cc 2015-04-17 08:31:54.089196369 -0600
@@ -159,7 +159,7 @@ int main(int argc, char *argv[])
_setmode(_fileno(stdout), _O_BINARY);
#endif
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
get_dds = true;
diff -up libdap-3.14.0/tests/das-test.cc.getopt libdap-3.14.0/tests/das-test.cc
--- libdap-3.14.0/tests/das-test.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/tests/das-test.cc 2015-04-17 08:31:53.998194748 -0600
@@ -89,7 +89,7 @@ int main(int argc, char *argv[])
bool code_test = false;
bool deref_alias = false;
bool as_xml = false;
- while ((option_char = getopt ()) != EOF)
+ while ((option_char = getopt ()) != -1)
switch (option_char)
{
case 'p':
diff -up libdap-3.14.0/tests/dds-test.cc.getopt libdap-3.14.0/tests/dds-test.cc
--- libdap-3.14.0/tests/dds-test.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/tests/dds-test.cc 2015-04-17 08:31:53.995194695 -0600
@@ -99,7 +99,7 @@ int main(int argc, char *argv[]) {
string name = "";
// process options
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
ddsdebug = 1;
diff -up libdap-3.14.0/tests/dmr-test.cc.getopt libdap-3.14.0/tests/dmr-test.cc
--- libdap-3.14.0/tests/dmr-test.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/tests/dmr-test.cc 2015-04-17 08:31:53.990194606 -0600
@@ -301,7 +301,7 @@ main(int argc, char *argv[])
// process options
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'p':
parse = true;
diff -up libdap-3.14.0/tests/expr-test.cc.getopt libdap-3.14.0/tests/expr-test.cc
--- libdap-3.14.0/tests/expr-test.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/tests/expr-test.cc 2015-04-17 08:31:54.001194802 -0600
@@ -170,7 +170,7 @@ int main(int argc, char *argv[])
// process options
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'b':
series_values = true;
diff -up libdap-3.14.0/unit-tests/AttrTableTest.cc.getopt libdap-3.14.0/unit-tests/AttrTableTest.cc
--- libdap-3.14.0/unit-tests/AttrTableTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/AttrTableTest.cc 2015-04-17 08:31:54.122196956 -0600
@@ -417,9 +417,9 @@ int
main(int argc, char *argv[])
{
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/chunked_iostream_test.cc.getopt libdap-3.14.0/unit-tests/chunked_iostream_test.cc
--- libdap-3.14.0/unit-tests/chunked_iostream_test.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/chunked_iostream_test.cc 2015-04-17 08:31:54.133197152 -0600
@@ -530,9 +530,9 @@ int
main(int argc, char *argv[])
{
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/D4AsyncDocTest.cc.getopt libdap-3.14.0/unit-tests/D4AsyncDocTest.cc
--- libdap-3.14.0/unit-tests/D4AsyncDocTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/D4AsyncDocTest.cc 2015-04-17 08:31:54.144197348 -0600
@@ -304,8 +304,8 @@ int main(int argc, char*argv[]) {
runner.addTest(CppUnit::TestFactoryRegistry::getRegistry().makeTest());
GetOpt getopt(argc, argv, "d");
- char option_char;
- while ((option_char = getopt()) != EOF)
+ int option_char;
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/D4DimensionsTest.cc.getopt libdap-3.14.0/unit-tests/D4DimensionsTest.cc
--- libdap-3.14.0/unit-tests/D4DimensionsTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/D4DimensionsTest.cc 2015-04-17 08:31:54.109196725 -0600
@@ -226,9 +226,9 @@ int main(int argc, char*argv[]) {
runner.addTest(CppUnit::TestFactoryRegistry::getRegistry().makeTest());
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/D4EnumTest.cc.getopt libdap-3.14.0/unit-tests/D4EnumTest.cc
--- libdap-3.14.0/unit-tests/D4EnumTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/D4EnumTest.cc 2015-04-17 08:31:54.149197437 -0600
@@ -222,8 +222,8 @@ int main(int argc, char*argv[]) {
runner.addTest(CppUnit::TestFactoryRegistry::getRegistry().makeTest());
GetOpt getopt(argc, argv, "d");
- char option_char;
- while ((option_char = getopt()) != EOF)
+ int option_char;
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/D4GroupTest.cc.getopt libdap-3.14.0/unit-tests/D4GroupTest.cc
--- libdap-3.14.0/unit-tests/D4GroupTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/D4GroupTest.cc 2015-04-17 08:31:54.111196760 -0600
@@ -348,9 +348,9 @@ int
main(int argc, char *argv[])
{
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/D4MarshallerTest.cc.getopt libdap-3.14.0/unit-tests/D4MarshallerTest.cc
--- libdap-3.14.0/unit-tests/D4MarshallerTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/D4MarshallerTest.cc 2015-04-17 08:31:54.150197455 -0600
@@ -350,9 +350,9 @@ int main(int argc, char*argv[]) {
runner.setOutputter(CppUnit::CompilerOutputter::defaultOutputter(&runner.result(), std::cerr));
GetOpt getopt(argc, argv, "dw");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = true; // debug is a static global
diff -up libdap-3.14.0/unit-tests/D4ParserSax2Test.cc.getopt libdap-3.14.0/unit-tests/D4ParserSax2Test.cc
--- libdap-3.14.0/unit-tests/D4ParserSax2Test.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/D4ParserSax2Test.cc 2015-04-17 08:31:54.147197401 -0600
@@ -344,9 +344,9 @@ int main(int argc, char*argv[]) {
runner.addTest(CppUnit::TestFactoryRegistry::getRegistry().makeTest());
GetOpt getopt(argc, argv, "dp");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/D4UnMarshallerTest.cc.getopt libdap-3.14.0/unit-tests/D4UnMarshallerTest.cc
--- libdap-3.14.0/unit-tests/D4UnMarshallerTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/D4UnMarshallerTest.cc 2015-04-17 08:31:54.142197312 -0600
@@ -330,9 +330,9 @@ int main(int argc, char*argv[]) {
runner.setOutputter(CppUnit::CompilerOutputter::defaultOutputter(&runner.result(), std::cerr));
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = true; // debug is a static global
diff -up libdap-3.14.0/unit-tests/DDSTest.cc.getopt libdap-3.14.0/unit-tests/DDSTest.cc
--- libdap-3.14.0/unit-tests/DDSTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/DDSTest.cc 2015-04-17 08:31:54.139197259 -0600
@@ -483,7 +483,7 @@ int main(int argc, char*argv[]) {
GetOpt getopt(argc, argv, "d");
int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/DDXParserTest.cc.getopt libdap-3.14.0/unit-tests/DDXParserTest.cc
--- libdap-3.14.0/unit-tests/DDXParserTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/DDXParserTest.cc 2015-04-17 08:31:54.107196689 -0600
@@ -700,7 +700,7 @@ int main(int argc, char*argv[]) {
GetOpt getopt(argc, argv, "d");
int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/DMRTest.cc.getopt libdap-3.14.0/unit-tests/DMRTest.cc
--- libdap-3.14.0/unit-tests/DMRTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/DMRTest.cc 2015-04-17 08:31:54.136197205 -0600
@@ -293,9 +293,9 @@ int main(int argc, char*argv[]) {
runner.addTest(CppUnit::TestFactoryRegistry::getRegistry().makeTest());
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/HTTPCacheTest.cc.getopt libdap-3.14.0/unit-tests/HTTPCacheTest.cc
--- libdap-3.14.0/unit-tests/HTTPCacheTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/HTTPCacheTest.cc 2015-04-17 08:31:54.114196814 -0600
@@ -901,9 +901,9 @@ int main(int argc, char*argv[])
runner.addTest(CppUnit::TestFactoryRegistry::getRegistry().makeTest());
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/HTTPConnectTest.cc.getopt libdap-3.14.0/unit-tests/HTTPConnectTest.cc
--- libdap-3.14.0/unit-tests/HTTPConnectTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/HTTPConnectTest.cc 2015-04-17 08:31:54.117196867 -0600
@@ -735,9 +735,9 @@ int main(int argc, char*argv[]) {
runner.addTest(CppUnit::TestFactoryRegistry::getRegistry().makeTest());
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/RCReaderTest.cc.getopt libdap-3.14.0/unit-tests/RCReaderTest.cc
--- libdap-3.14.0/unit-tests/RCReaderTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/RCReaderTest.cc 2015-04-17 08:31:54.135197188 -0600
@@ -374,9 +374,9 @@ int main(int argc, char*argv[]) {
runner.addTest(CppUnit::TestFactoryRegistry::getRegistry().makeTest());
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/SequenceTest.cc.getopt libdap-3.14.0/unit-tests/SequenceTest.cc
--- libdap-3.14.0/unit-tests/SequenceTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/SequenceTest.cc 2015-04-17 08:31:54.131197116 -0600
@@ -423,7 +423,7 @@ int main(int argc, char*argv[]) {
GetOpt getopt(argc, argv, "d");
int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/ServerFunctionsListUnitTest.cc.getopt libdap-3.14.0/unit-tests/ServerFunctionsListUnitTest.cc
--- libdap-3.14.0/unit-tests/ServerFunctionsListUnitTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/ServerFunctionsListUnitTest.cc 2015-04-17 08:31:54.108196707 -0600
@@ -184,7 +184,7 @@ int main(int argc, char*argv[]) {
GetOpt getopt(argc, argv, "d");
int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/unit-tests/SignalHandlerTest.cc.getopt libdap-3.14.0/unit-tests/SignalHandlerTest.cc
--- libdap-3.14.0/unit-tests/SignalHandlerTest.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/unit-tests/SignalHandlerTest.cc 2015-04-17 08:31:54.142197312 -0600
@@ -133,9 +133,9 @@ int main(int argc, char*argv[]) {
runner.addTest(CppUnit::TestFactoryRegistry::getRegistry().makeTest());
GetOpt getopt(argc, argv, "d");
- char option_char;
+ int option_char;
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
debug = 1; // debug is a static global
diff -up libdap-3.14.0/VCPP/sample/getdap.cc.getopt libdap-3.14.0/VCPP/sample/getdap.cc
--- libdap-3.14.0/VCPP/sample/getdap.cc.getopt 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/VCPP/sample/getdap.cc 2015-04-17 08:31:53.964194143 -0600
@@ -166,7 +166,7 @@ int main(int argc, char *argv[])
_setmode(_fileno(stdout), _O_BINARY);
#endif
- while ((option_char = getopt()) != EOF)
+ while ((option_char = getopt()) != -1)
switch (option_char) {
case 'd':
get_dds = true;

View File

@ -1,24 +0,0 @@
diff -up libdap-3.14.0/media_types.h.include libdap-3.14.0/media_types.h
--- libdap-3.14.0/media_types.h.include 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/media_types.h 2015-04-17 19:35:06.752767086 -0600
@@ -26,6 +26,8 @@
#ifndef MEDIA_TYPES_H_
#define MEDIA_TYPES_H_
+#include <string>
+
static std::string DAS1 = "dods_das";
static std::string DAS2 = "dods-das";
diff -up libdap-3.14.0/mime_util.h.include libdap-3.14.0/mime_util.h
--- libdap-3.14.0/mime_util.h.include 2015-02-12 20:16:20.000000000 -0700
+++ libdap-3.14.0/mime_util.h 2015-04-17 19:36:40.586900129 -0600
@@ -47,6 +47,8 @@
#include "EncodingType.h"
#endif
+#include <string>
+
namespace libdap
{

View File

@ -1,27 +1,18 @@
diff -up libdap-3.14.0/tests/Makefile.am.offline libdap-3.14.0/tests/Makefile.am
--- libdap-3.14.0/tests/Makefile.am.offline 2015-04-16 13:58:00.256001226 -0600
+++ libdap-3.14.0/tests/Makefile.am 2015-04-16 14:10:17.020831267 -0600
@@ -23,7 +23,7 @@ if DAP4_DEFINED
check_PROGRAMS += dmr-test
endif
diff -up libdap-3.15.1/tests/Makefile.am.offline libdap-3.15.1/tests/Makefile.am
--- libdap-3.15.1/tests/Makefile.am.offline 2015-09-23 09:22:30.878380060 -0600
+++ libdap-3.15.1/tests/Makefile.am 2015-09-23 09:24:10.341953855 -0600
@@ -112,7 +112,6 @@ $(EXPRTESTSUITE) $(DMRTESTSUITE) $(GETDA
$(SHELL) '$(DDSTESTSUITE)' $(TESTSUITEFLAGS)
$(SHELL) '$(EXPRTESTSUITE)' $(TESTSUITEFLAGS)
$(SHELL) '$(DMRTESTSUITE)' $(TESTSUITEFLAGS)
- $(SHELL) '$(GETDAPTESTSUITE)' $(TESTSUITEFLAGS)
-TESTS = DASTest DDSTest EXPRTest DMRTest getdapTest
+TESTS = DASTest DDSTest EXPRTest DMRTest
dist_check_SCRIPTS = DASTest DDSTest EXPRTest DMRTest getdapTest atconfig atlocal
diff -up libdap-3.14.0/unit-tests/Makefile.am.offline libdap-3.14.0/unit-tests/Makefile.am
--- libdap-3.14.0/unit-tests/Makefile.am.offline 2015-02-26 21:33:44.000000000 -0700
+++ libdap-3.14.0/unit-tests/Makefile.am 2015-04-16 13:58:00.260001279 -0600
@@ -10,7 +10,6 @@ AUTOMAKE_OPTIONS = foreign
AM_CPPFLAGS = -I$(top_srcdir)/GNU -I$(top_srcdir) -I$(top_srcdir)/tests $(CURL_CFLAGS) $(XML2_CFLAGS)
AM_LDADD =
AM_CXXFLAGS =
-CXXFLAGS =
if COMPILER_IS_GCC
AM_CXXFLAGS += -Wall -W -Wcast-align
@@ -66,9 +65,9 @@ D4-xml.tar.gz: D4-xml/DMR_*[0-9].xml
# Make sure there are no spaces after the DASTESTSUITE names. jhrg 3/16/15
# Delete the scripts here and not using CLEANFILES because this target is
diff -up libdap-3.15.1/unit-tests/Makefile.am.offline libdap-3.15.1/unit-tests/Makefile.am
--- libdap-3.15.1/unit-tests/Makefile.am.offline 2015-06-16 20:18:25.000000000 -0600
+++ libdap-3.15.1/unit-tests/Makefile.am 2015-09-23 09:22:30.879380056 -0600
@@ -67,9 +67,9 @@ D4-xml.tar.gz: D4-xml/DMR_*[0-9].xml
if CPPUNIT
UNIT_TESTS = marshT arrayT attrTableT structT sequenceT ddsT dasT \
RegexTest ArrayTest AttrTableTest ByteTest MIMEUtilTest ancT DASTest \

View File

@ -1,7 +1,7 @@
Name: libdap
Summary: The C++ DAP2 library from OPeNDAP
Version: 3.14.0
Release: 5%{?dist}
Version: 3.15.1
Release: 1%{?dist}
License: LGPLv2+
Group: Development/Libraries
@ -9,12 +9,6 @@ URL: http://www.opendap.org/
Source0: http://www.opendap.org/pub/source/libdap-%{version}.tar.gz
#Don't run HTTP tests - builders don't have network connections
Patch0: libdap-offline.patch
# Fix flex types
Patch1: libdap-flex.patch
# Fix getopt()
Patch2: libdap-getopt.patch
# Add needed includes
Patch3: libdap-include.patch
# For autoreconf
BuildRequires: libtool
@ -73,16 +67,9 @@ Documentation of the libdap library.
%prep
%setup -q
%patch0 -p1 -b .offline
%patch1 -p1 -b .flex
%patch2 -p1 -b .getopt
%patch3 -p1 -b .include
iconv -f latin1 -t utf8 < COPYRIGHT_W3C > COPYRIGHT_W3C.utf8
touch -r COPYRIGHT_W3C COPYRIGHT_W3C.utf8
mv COPYRIGHT_W3C.utf8 COPYRIGHT_W3C
# Cleanup shipped flex/bison files
rm -r d4_ce/gen_grammar_sources
# Fix flags
find -name Makefile.am | xargs sed -i -e '/^CXXFLAGS *=/d'
%build
@ -123,9 +110,9 @@ make check
%files
%{_bindir}/getdap
%{_bindir}/getdap4
%{_libdir}/libdap.so.*
%{_libdir}/libdapclient.so.*
%{_libdir}/libdapserver.so.*
%{_libdir}/libdap.so.17*
%{_libdir}/libdapclient.so.6*
%{_libdir}/libdapserver.so.7*
%{_mandir}/man1/getdap.1*
%{_mandir}/man1/getdap4.1*
%doc README NEWS COPYING COPYRIGHT_URI README.dodsrc
@ -148,6 +135,10 @@ make check
%changelog
* Wed Sep 23 2015 Orion Poplawski <orion@cora.nwra.com> - 3.15.1-1
- Update to 3.15.1
- Drop flex, getopt, and include patches fixed upstream
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.14.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

View File

@ -1 +1 @@
83ac4c6eb4aa8e485587de94b9757d01 libdap-3.14.0.tar.gz
31cd4939e5b894049cebccc321fd1b49 libdap-3.15.1.tar.gz