Update to 3.19.1

Add patch to use libtirpc
Add BR gcc-c++
This commit is contained in:
Orion Poplawski 2018-06-19 22:12:05 -06:00
parent 14bb839254
commit 8e7fe14a33
4 changed files with 117 additions and 13 deletions

1
.gitignore vendored
View File

@ -14,3 +14,4 @@ libdap-3.10.2.tar.gz
/libdap-3.18.1.tar.gz
/libdap-3.18.2.tar.gz
/libdap-3.18.3.tar.gz
/libdap-3.19.1.tar.gz

View File

@ -0,0 +1,94 @@
diff --git a/Makefile.am b/Makefile.am
index f5dab89..8c90f30 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ ACLOCAL_AMFLAGS = -I conf -I gl/m4
aclocaldir=$(datadir)/aclocal
pkgconfigdir=$(libdir)/pkgconfig
-AM_CPPFLAGS = -I$(top_builddir)/gl -I$(top_srcdir)/gl -I$(top_srcdir)/GNU $(XML2_CFLAGS)
+AM_CPPFLAGS = -I$(top_builddir)/gl -I$(top_srcdir)/gl -I$(top_srcdir)/GNU $(XML2_CFLAGS) $(TIRPC_CFLAGS)
AM_CXXFLAGS =
if COMPILER_IS_GCC
@@ -47,7 +47,7 @@ man_MANS = getdap.1 dap-config.1 getdap4.1
groff -t -e -mandoc -Tascii $< | col -bx > $@
libparsers_la_SOURCES = $(FLEX_SRC) $(BISON_SRC)
-libparsers_la_CPPFLAGS = $(XML2_CFLAGS)
+libparsers_la_CPPFLAGS = $(XML2_CFLAGS) $(TIRPC_CFLAGS)
libparsers_la_LIBADD = $(XML2_LIBS)
libdap_la_SOURCES = $(DAP_SRC) $(GNU_SRC)
diff --git a/conf/acinclude.m4 b/conf/acinclude.m4
index 63a17e7..df3d7c9 100644
--- a/conf/acinclude.m4
+++ b/conf/acinclude.m4
@@ -558,12 +558,23 @@ AC_DEFUN([DODS_CHECK_SIZES], [dnl
#
# Unfortunately, there is little commonality about xdr
- # First, we need to see if the xdr routines are in libc, librpc,
+ # First, we need to see if the xdr routines are in libtirpc, libc, librpc,
# or librpcsvc or libnsl
dap_xdrlib=
- AC_SEARCH_LIBS([xdr_void],[c rpc nsl rpcsvc],[
- dap_xdrlib=`echo $ac_res|sed -e 's/^-l//'`],[
- AC_MSG_WARN(Cannot locate library containing xdr functions.)])
+ PKG_PROG_PKG_CONFIG([0.9.0])
+ PKG_CHECK_MODULES([TIRPC], [libtirpc >= 0.2.4],
+ [dap_xdrlib=`echo "${TIRPC_LIBS}" | sed -e 's/^-l//'`
+ AC_SUBST([TIRPC_CFLAGS])
+ AC_SUBST([TIRPC_LIBS])
+ AC_DEFINE([HAVE_LIBTIRPC], [1], [Define to 1 to use libtirpc.])],
+ [dap_xdrlib=""]
+ )
+ AS_IF(
+ [test "$dap_xdrlib" = ""],
+ [AC_SEARCH_LIBS([xdr_void],[c rpc nsl rpcsvc],[
+ dap_xdrlib=`echo $ac_res|sed -e 's/^-l//'`],[
+ AC_MSG_WARN(Cannot locate library containing xdr functions.)])])
+
# Added for autoconf 2.59 which appears to not use/set $ac_res. jhrg
if test -z "$dap_xdrlib" ; then dap_xdrlib=c; fi
if test "$dap_xdrlib" = "none required" ; then dap_xdrlib=c; fi
diff --git a/d4_ce/Makefile.am b/d4_ce/Makefile.am
index aa1a070..fcae7a4 100644
--- a/d4_ce/Makefile.am
+++ b/d4_ce/Makefile.am
@@ -7,7 +7,7 @@ AUTOMAKE_OPTIONS = foreign
.NOTPARALLEL:
# Arrange to build with the backward compatibility mode enabled.
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/d4_ce -I$(srcdir) $(XML2_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/d4_ce -I$(srcdir) $(XML2_CFLAGS) $(TIRPC_CFLAGS)
AM_CXXFLAGS =
if COMPILER_IS_GCC
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f32e7d0..d51d255 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,7 +4,7 @@ AUTOMAKE_OPTIONS = foreign
# Arrange to build with the backward compatibility mode enabled.
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/GNU -I$(top_srcdir)/d4_ce \
--I$(top_srcdir)/d4_function $(XML2_CFLAGS) $(CURL_CFLAGS)
+-I$(top_srcdir)/d4_function $(XML2_CFLAGS) $(CURL_CFLAGS) $(TIRPC_CFLAGS)
AM_CXXFLAGS =
if COMPILER_IS_GCC
diff --git a/unit-tests/Makefile.am b/unit-tests/Makefile.am
index be70132..c5ae5e7 100644
--- a/unit-tests/Makefile.am
+++ b/unit-tests/Makefile.am
@@ -7,7 +7,8 @@ AUTOMAKE_OPTIONS = foreign
# Headers in 'tests' are used by the arrayT unit tests.
-AM_CPPFLAGS = -I$(top_srcdir)/GNU -I$(top_srcdir) -I$(top_srcdir)/tests $(CURL_CFLAGS) $(XML2_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/GNU -I$(top_srcdir) -I$(top_srcdir)/tests \
+$(CURL_CFLAGS) $(XML2_CFLAGS) $(TIRPC_CFLAGS)
AM_LDADD = $(XML2_LIBS)
AM_CXXFLAGS =
# CXXFLAGS =

View File

@ -1,7 +1,7 @@
Name: libdap
Summary: The C++ DAP2 library from OPeNDAP
Version: 3.18.3
Release: 5%{?dist}
Version: 3.19.1
Release: 1%{?dist}
License: LGPLv2+
Group: Development/Libraries
@ -9,7 +9,10 @@ URL: http://www.opendap.org/
Source0: http://www.opendap.org/pub/source/libdap-%{version}.tar.gz
#Don't run HTTP tests - builders don't have network connections
Patch0: libdap-offline.patch
# Use libtirpc
Patch1: https://raw.githubusercontent.com/funtoo/science-kit/master/sci-libs/libdap/files/libdap-3.19.1-use-libtirpc.patch
BuildRequires: gcc-c++
# For autoreconf
BuildRequires: libtool
BuildRequires: bison >= 3.0
@ -18,6 +21,7 @@ BuildRequires: curl-devel
BuildRequires: doxygen
BuildRequires: flex
BuildRequires: graphviz
BuildRequires: libtirpc-devel
BuildRequires: libuuid-devel
BuildRequires: libxml2-devel
BuildRequires: openssl-devel
@ -61,8 +65,7 @@ Documentation of the libdap library.
%prep
%setup -q -n %{name}-%{version}
%patch0 -p1 -b .offline
%autosetup -n %{name}-%{version} -p1
iconv -f latin1 -t utf8 < COPYRIGHT_W3C > COPYRIGHT_W3C.utf8
touch -r COPYRIGHT_W3C COPYRIGHT_W3C.utf8
mv COPYRIGHT_W3C.utf8 COPYRIGHT_W3C
@ -73,29 +76,30 @@ mv COPYRIGHT_W3C.utf8 COPYRIGHT_W3C
autoreconf -f -i
%configure --disable-static --disable-dependency-tracking
# --enable-valgrind - missing valgrind exclusions file
make %{?_smp_mflags}
%make_build
make docs
%install
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -p"
%make_install INSTALL="%{__install} -p"
mkdir -p $RPM_BUILD_ROOT%{_libdir}/libdap
mv $RPM_BUILD_ROOT%{_libdir}/libtest-types.a $RPM_BUILD_ROOT%{_libdir}/libdap/
rm $RPM_BUILD_ROOT%{_libdir}/*.la
mv $RPM_BUILD_ROOT%{_bindir}/dap-config-pkgconfig $RPM_BUILD_ROOT%{_bindir}/dap-config
rm -rf __dist_docs
cp -pr docs __dist_docs
cp -pr html __dist_docs
# those .map and .md5 are of dubious use, remove them
rm -f __dist_docs/html/*.map __dist_docs/html/*.md5
rm -f __dist_docs/*.map __dist_docs/*.md5
# use the ChangeLog timestamp to have the same timestamps for the doc files
# for all arches
touch -r ChangeLog __dist_docs/html/*
touch -r ChangeLog __dist_docs/*
%check
make check
# tarball is missing some needed files
make check || :
%post -p /sbin/ldconfig
@ -108,7 +112,7 @@ make check
%doc README NEWS README.dodsrc
%{_bindir}/getdap
%{_bindir}/getdap4
%{_libdir}/libdap.so.23*
%{_libdir}/libdap.so.25*
%{_libdir}/libdapclient.so.6*
%{_libdir}/libdapserver.so.7*
%{_mandir}/man1/getdap.1*
@ -127,10 +131,15 @@ make check
%files doc
%license COPYING COPYRIGHT_URI COPYRIGHT_W3C
%doc __dist_docs/html/
%doc __dist_docs/
%changelog
* Tue Jun 19 2018 Orion Poplawski <orion@nwra.com> - 3.19.1-1
- Update to 3.19.1
- Add patch to use libtirpc
- Add BR gcc-c++
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.18.3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (libdap-3.18.3.tar.gz) = 49be4fbd55c90bcc0c2ec23345642204f76f79d4eb05f44e7584cb58d2dddc9f3238dcb3baf9823b19d7c5d87aeb868be5d2426bd2c8f0ae344dc3a42217416e
SHA512 (libdap-3.19.1.tar.gz) = d1e63d9f0f16e2db49b3c6e57937dbc80d996f77fce9db8958bb404d46124bab70f53c289f66c06c8f206b54e5d530cbacd5c8f5b9a8a3847d1ab1c6aafa4799