Update to 3.20.3

This commit is contained in:
Orion Poplawski 2019-02-17 15:54:26 -07:00
parent fc5a3ff54f
commit 6bfee886a0
5 changed files with 19 additions and 111 deletions

1
.gitignore vendored
View File

@ -15,3 +15,4 @@ libdap-3.10.2.tar.gz
/libdap-3.18.2.tar.gz
/libdap-3.18.3.tar.gz
/libdap-3.19.1.tar.gz
/libdap-3.20.3.tar.gz

View File

@ -1,94 +0,0 @@
diff --git a/Makefile.am b/Makefile.am
index f5dab89..8c90f30 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ ACLOCAL_AMFLAGS = -I conf -I gl/m4
aclocaldir=$(datadir)/aclocal
pkgconfigdir=$(libdir)/pkgconfig
-AM_CPPFLAGS = -I$(top_builddir)/gl -I$(top_srcdir)/gl -I$(top_srcdir)/GNU $(XML2_CFLAGS)
+AM_CPPFLAGS = -I$(top_builddir)/gl -I$(top_srcdir)/gl -I$(top_srcdir)/GNU $(XML2_CFLAGS) $(TIRPC_CFLAGS)
AM_CXXFLAGS =
if COMPILER_IS_GCC
@@ -47,7 +47,7 @@ man_MANS = getdap.1 dap-config.1 getdap4.1
groff -t -e -mandoc -Tascii $< | col -bx > $@
libparsers_la_SOURCES = $(FLEX_SRC) $(BISON_SRC)
-libparsers_la_CPPFLAGS = $(XML2_CFLAGS)
+libparsers_la_CPPFLAGS = $(XML2_CFLAGS) $(TIRPC_CFLAGS)
libparsers_la_LIBADD = $(XML2_LIBS)
libdap_la_SOURCES = $(DAP_SRC) $(GNU_SRC)
diff --git a/conf/acinclude.m4 b/conf/acinclude.m4
index 63a17e7..df3d7c9 100644
--- a/conf/acinclude.m4
+++ b/conf/acinclude.m4
@@ -558,12 +558,23 @@ AC_DEFUN([DODS_CHECK_SIZES], [dnl
#
# Unfortunately, there is little commonality about xdr
- # First, we need to see if the xdr routines are in libc, librpc,
+ # First, we need to see if the xdr routines are in libtirpc, libc, librpc,
# or librpcsvc or libnsl
dap_xdrlib=
- AC_SEARCH_LIBS([xdr_void],[c rpc nsl rpcsvc],[
- dap_xdrlib=`echo $ac_res|sed -e 's/^-l//'`],[
- AC_MSG_WARN(Cannot locate library containing xdr functions.)])
+ PKG_PROG_PKG_CONFIG([0.9.0])
+ PKG_CHECK_MODULES([TIRPC], [libtirpc >= 0.2.4],
+ [dap_xdrlib=`echo "${TIRPC_LIBS}" | sed -e 's/^-l//'`
+ AC_SUBST([TIRPC_CFLAGS])
+ AC_SUBST([TIRPC_LIBS])
+ AC_DEFINE([HAVE_LIBTIRPC], [1], [Define to 1 to use libtirpc.])],
+ [dap_xdrlib=""]
+ )
+ AS_IF(
+ [test "$dap_xdrlib" = ""],
+ [AC_SEARCH_LIBS([xdr_void],[c rpc nsl rpcsvc],[
+ dap_xdrlib=`echo $ac_res|sed -e 's/^-l//'`],[
+ AC_MSG_WARN(Cannot locate library containing xdr functions.)])])
+
# Added for autoconf 2.59 which appears to not use/set $ac_res. jhrg
if test -z "$dap_xdrlib" ; then dap_xdrlib=c; fi
if test "$dap_xdrlib" = "none required" ; then dap_xdrlib=c; fi
diff --git a/d4_ce/Makefile.am b/d4_ce/Makefile.am
index aa1a070..fcae7a4 100644
--- a/d4_ce/Makefile.am
+++ b/d4_ce/Makefile.am
@@ -7,7 +7,7 @@ AUTOMAKE_OPTIONS = foreign
.NOTPARALLEL:
# Arrange to build with the backward compatibility mode enabled.
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/d4_ce -I$(srcdir) $(XML2_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/d4_ce -I$(srcdir) $(XML2_CFLAGS) $(TIRPC_CFLAGS)
AM_CXXFLAGS =
if COMPILER_IS_GCC
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f32e7d0..d51d255 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,7 +4,7 @@ AUTOMAKE_OPTIONS = foreign
# Arrange to build with the backward compatibility mode enabled.
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/GNU -I$(top_srcdir)/d4_ce \
--I$(top_srcdir)/d4_function $(XML2_CFLAGS) $(CURL_CFLAGS)
+-I$(top_srcdir)/d4_function $(XML2_CFLAGS) $(CURL_CFLAGS) $(TIRPC_CFLAGS)
AM_CXXFLAGS =
if COMPILER_IS_GCC
diff --git a/unit-tests/Makefile.am b/unit-tests/Makefile.am
index be70132..c5ae5e7 100644
--- a/unit-tests/Makefile.am
+++ b/unit-tests/Makefile.am
@@ -7,7 +7,8 @@ AUTOMAKE_OPTIONS = foreign
# Headers in 'tests' are used by the arrayT unit tests.
-AM_CPPFLAGS = -I$(top_srcdir)/GNU -I$(top_srcdir) -I$(top_srcdir)/tests $(CURL_CFLAGS) $(XML2_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/GNU -I$(top_srcdir) -I$(top_srcdir)/tests \
+$(CURL_CFLAGS) $(XML2_CFLAGS) $(TIRPC_CFLAGS)
AM_LDADD = $(XML2_LIBS)
AM_CXXFLAGS =
# CXXFLAGS =

View File

@ -1,7 +1,7 @@
diff -up libdap-3.18.1/tests/Makefile.am.offline libdap-3.18.1/tests/Makefile.am
--- libdap-3.18.1/tests/Makefile.am.offline 2015-10-19 16:03:35.000000000 -0600
+++ libdap-3.18.1/tests/Makefile.am 2016-08-12 09:33:37.767696856 -0600
@@ -112,7 +112,6 @@ $(EXPRTESTSUITE) $(DMRTESTSUITE) $(GETDA
diff -up libdap-3.20.3/tests/Makefile.am.orig libdap-3.20.3/tests/Makefile.am
--- libdap-3.20.3/tests/Makefile.am.orig 2019-02-14 10:13:49.000000000 -0700
+++ libdap-3.20.3/tests/Makefile.am 2019-02-17 15:27:32.426858748 -0700
@@ -120,7 +120,6 @@ $(EXPRTESTSUITE) $(DMRTESTSUITE) $(GETDA
$(SHELL) '$(DDSTESTSUITE)' $(TESTSUITEFLAGS)
$(SHELL) '$(EXPRTESTSUITE)' $(TESTSUITEFLAGS)
$(SHELL) '$(DMRTESTSUITE)' $(TESTSUITEFLAGS)
@ -9,18 +9,18 @@ diff -up libdap-3.18.1/tests/Makefile.am.offline libdap-3.18.1/tests/Makefile.am
# Make sure there are no spaces after the DASTESTSUITE names. jhrg 3/16/15
# Delete the scripts here and not using CLEANFILES because this target is
diff -up libdap-3.18.1/unit-tests/Makefile.am.offline libdap-3.18.1/unit-tests/Makefile.am
--- libdap-3.18.1/unit-tests/Makefile.am.offline 2016-08-12 09:33:37.768696852 -0600
+++ libdap-3.18.1/unit-tests/Makefile.am 2016-08-12 09:34:12.984547765 -0600
@@ -67,9 +67,9 @@ D4-xml.tar.gz: D4-xml/DMR_*[0-9].xml
diff -up libdap-3.20.3/unit-tests/Makefile.am.orig libdap-3.20.3/unit-tests/Makefile.am
--- libdap-3.20.3/unit-tests/Makefile.am.orig 2019-02-17 15:27:32.426858748 -0700
+++ libdap-3.20.3/unit-tests/Makefile.am 2019-02-17 15:28:10.725606175 -0700
@@ -78,9 +78,9 @@ D4-xml.tar.gz: D4-xml/DMR_*[0-9].xml
if CPPUNIT
UNIT_TESTS = marshT arrayT attrTableT structT sequenceT ddsT dasT \
RegexTest ArrayTest AttrTableTest ByteTest MIMEUtilTest ancT DASTest \
- DDSTest DDXParserTest generalUtilTest HTTPConnectTest parserUtilTest \
+ DDSTest DDXParserTest generalUtilTest parserUtilTest \
RCReaderTest SequenceTest SignalHandlerTest MarshallerTest \
- HTTPCacheTest ServerFunctionsListUnitTest
+ ServerFunctionsListUnitTest
- HTTPCacheTest ServerFunctionsListUnitTest Int8Test Int16Test UInt16Test \
+ ServerFunctionsListUnitTest Int8Test Int16Test UInt16Test \
Int32Test UInt32Test Int64Test UInt64Test Float32Test Float64Test \
D4BaseTypeFactoryTest BaseTypeFactoryTest
if DAP4_DEFINED
UNIT_TESTS += D4MarshallerTest D4UnMarshallerTest D4DimensionsTest \

View File

@ -1,15 +1,13 @@
Name: libdap
Summary: The C++ DAP2 library from OPeNDAP
Version: 3.19.1
Release: 3%{?dist}
Version: 3.20.3
Release: 1%{?dist}
License: LGPLv2+
URL: http://www.opendap.org/
Source0: http://www.opendap.org/pub/source/libdap-%{version}.tar.gz
#Don't run HTTP tests - builders don't have network connections
Patch0: libdap-offline.patch
# Use libtirpc
Patch1: https://raw.githubusercontent.com/funtoo/science-kit/master/sci-libs/libdap/files/libdap-3.19.1-use-libtirpc.patch
BuildRequires: gcc-c++
# For autoreconf
@ -130,6 +128,9 @@ make check || :
%changelog
* Sun Feb 17 2019 Orion Poplawski <orion@nwra.com> - 3.20.3-1
- Update to 3.20.3
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.19.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (libdap-3.19.1.tar.gz) = d1e63d9f0f16e2db49b3c6e57937dbc80d996f77fce9db8958bb404d46124bab70f53c289f66c06c8f206b54e5d530cbacd5c8f5b9a8a3847d1ab1c6aafa4799
SHA512 (libdap-3.20.3.tar.gz) = ba6575d875a7e293d4fc9d846dbc9eeacc16100d9d1f489f77dd4912f94d755c69101996213e4a5fce3da89c5a09a6176f025d4cc780e936ed0419a9474b7dfe