36 lines
1.2 KiB
Diff
36 lines
1.2 KiB
Diff
From 4462799ee3c9e29a2eb2396d065c1c3caf1a3d0e Mon Sep 17 00:00:00 2001
|
|
From: Tom Stellard <tstellar@redhat.com>
|
|
Date: Tue, 11 Aug 2020 08:27:41 -0700
|
|
Subject: [PATCH 2/2] libcxxabi: Remove monorepo requirement
|
|
|
|
---
|
|
libcxxabi/CMakeLists.txt | 6 ------
|
|
1 file changed, 6 deletions(-)
|
|
|
|
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
|
|
index 9fb35860d483..abbdbfe7efaa 100644
|
|
--- a/libcxxabi/CMakeLists.txt
|
|
+++ b/libcxxabi/CMakeLists.txt
|
|
@@ -1,9 +1,5 @@
|
|
# See www/CMake.html for instructions on how to build libcxxabi with CMake.
|
|
|
|
-if (NOT IS_DIRECTORY "${CMAKE_CURRENT_LIST_DIR}/../libcxx")
|
|
- message(FATAL_ERROR "libc++abi now requires being built in a monorepo layout with libcxx available")
|
|
-endif()
|
|
-
|
|
#===============================================================================
|
|
# Setup Project
|
|
#===============================================================================
|
|
@@ -40,8 +46,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXXABI_STANDALONE_B
|
|
include(GNUInstallDirs)
|
|
|
|
if (LIBCXXABI_STANDALONE_BUILD)
|
|
- # Find the LLVM sources and simulate LLVM CMake options.
|
|
- include(HandleOutOfTreeLLVM)
|
|
|
|
find_package(Python3 COMPONENTS Interpreter)
|
|
if(NOT Python3_Interpreter_FOUND)
|
|
--
|
|
2.27.0
|
|
|