libcxxabi/0001-libcxxabi-Remove-monor...

36 lines
1.2 KiB
Diff

From d19bf09163a54984160eda55a43b93703f8d46b5 Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 11 Aug 2020 08:27:41 -0700
Subject: [PATCH] libcxxabi: Remove monorepo requirement
---
libcxxabi/CMakeLists.txt | 6 ------
1 file changed, 6 deletions(-)
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
index 426c855288fc..8ad0475dc65e 100644
--- a/libcxxabi/CMakeLists.txt
+++ b/libcxxabi/CMakeLists.txt
@@ -1,9 +1,5 @@
# See www/CMake.html for instructions on how to build libcxxabi with CMake.
-if (NOT IS_DIRECTORY "${CMAKE_CURRENT_LIST_DIR}/../libcxx")
- message(FATAL_ERROR "libc++abi now requires being built in a monorepo layout with libcxx available")
-endif()
-
#===============================================================================
# Setup Project
#===============================================================================
@@ -42,8 +38,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXXABI_STANDALONE_B
set(LIBCXXABI_STANDALONE_BUILD 1)
set(LLVM_LIT_OUTPUT_DIR "${LIBCXXABI_BINARY_DIR}/bin")
- # Find the LLVM sources and simulate LLVM CMake options.
- include(HandleOutOfTreeLLVM)
endif()
if (LIBCXXABI_STANDALONE_BUILD)
--
2.27.0