Update to 14.0.0

This commit is contained in:
Timm Bäder 2022-03-24 08:39:40 +01:00
parent 0d35266211
commit e6352fb334
4 changed files with 78 additions and 28 deletions

View File

@ -1,26 +1,60 @@
From 2586ab946f1e22891345c86e7f673bb11989e427 Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Wed, 17 Feb 2021 12:50:08 -0800
Subject: [PATCH 1/2] Include refstring.h from system includedir
---
libcxxabi/src/stdlib_stdexcept.cpp | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/libcxxabi/src/stdlib_stdexcept.cpp b/libcxxabi/src/stdlib_stdexcept.cpp
index 0ca378dcde01..d2daf40173c0 100644
--- a/libcxxabi/src/stdlib_stdexcept.cpp
+++ b/libcxxabi/src/stdlib_stdexcept.cpp
@@ -13,8 +13,7 @@
diff -ruN a/libcxxabi-14.0.0rc2.src.orig/src/cxa_default_handlers.cpp a/libcxxabi-14.0.0rc2.src/src/cxa_default_handlers.cpp
--- a/libcxxabi-14.0.0rc2.src.orig/src/cxa_default_handlers.cpp 2022-03-02 01:46:37.000000000 +0100
+++ a/libcxxabi-14.0.0rc2.src/src/cxa_default_handlers.cpp 2022-03-03 15:13:26.573237421 +0100
@@ -16,7 +16,7 @@
#include "cxa_handlers.h"
#include "cxa_exception.h"
#include "private_typeinfo.h"
-#include "include/atomic_support.h" // from libc++
+#include <libcxx-internal/atomic_support.h>
#if !defined(LIBCXXABI_SILENT_TERMINATE)
diff -ruN a/libcxxabi-14.0.0rc2.src.orig/src/cxa_exception.cpp a/libcxxabi-14.0.0rc2.src/src/cxa_exception.cpp
--- a/libcxxabi-14.0.0rc2.src.orig/src/cxa_exception.cpp 2022-03-02 01:46:37.000000000 +0100
+++ a/libcxxabi-14.0.0rc2.src/src/cxa_exception.cpp 2022-03-03 15:13:54.560419466 +0100
@@ -17,7 +17,7 @@
#include "cxa_exception.h"
#include "cxa_handlers.h"
#include "fallback_malloc.h"
-#include "include/atomic_support.h" // from libc++
+#include <libcxx-internal/atomic_support.h>
#if __has_feature(address_sanitizer)
#include <sanitizer/asan_interface.h>
diff -ruN a/libcxxabi-14.0.0rc2.src.orig/src/cxa_guard_impl.h a/libcxxabi-14.0.0rc2.src/src/cxa_guard_impl.h
--- a/libcxxabi-14.0.0rc2.src.orig/src/cxa_guard_impl.h 2022-03-02 01:46:37.000000000 +0100
+++ a/libcxxabi-14.0.0rc2.src/src/cxa_guard_impl.h 2022-03-03 15:14:07.350502656 +0100
@@ -44,7 +44,7 @@
*/
#include "__cxxabi_config.h"
-#include "include/atomic_support.h" // from libc++
+#include <libcxx-internal/atomic_support.h>
#if defined(__has_include)
# if __has_include(<sys/syscall.h>)
# include <sys/syscall.h>
diff -ruN a/libcxxabi-14.0.0rc2.src.orig/src/cxa_handlers.cpp a/libcxxabi-14.0.0rc2.src/src/cxa_handlers.cpp
--- a/libcxxabi-14.0.0rc2.src.orig/src/cxa_handlers.cpp 2022-03-02 01:46:37.000000000 +0100
+++ a/libcxxabi-14.0.0rc2.src/src/cxa_handlers.cpp 2022-03-03 15:13:43.419346996 +0100
@@ -17,7 +17,7 @@
#include "cxa_handlers.h"
#include "cxa_exception.h"
#include "private_typeinfo.h"
-#include "include/atomic_support.h" // from libc++
+#include <libcxx-internal/atomic_support.h>
namespace std
{
diff -ruN a/libcxxabi-14.0.0rc2.src.orig/src/stdlib_stdexcept.cpp a/libcxxabi-14.0.0rc2.src/src/stdlib_stdexcept.cpp
--- a/libcxxabi-14.0.0rc2.src.orig/src/stdlib_stdexcept.cpp 2022-03-02 01:46:37.000000000 +0100
+++ a/libcxxabi-14.0.0rc2.src/src/stdlib_stdexcept.cpp 2022-03-03 14:36:19.052773915 +0100
@@ -12,7 +12,7 @@
#include <cstring>
#include <cstdint>
#include <cstddef>
-// This includes an implementation file from libc++.
-#include "src/include/refstring.h"
-#include "include/refstring.h" // from libc++
+#include <libcxx-internal/refstring.h>
static_assert(sizeof(std::__libcpp_refstring) == sizeof(const char *), "");
--
2.27.0

View File

@ -21,15 +21,15 @@ index 9fb35860d483..abbdbfe7efaa 100644
#===============================================================================
# Setup Project
#===============================================================================
@@ -42,8 +38,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXXABI_STANDALONE_B
set(LIBCXXABI_STANDALONE_BUILD 1)
set(LLVM_LIT_OUTPUT_DIR "${LIBCXXABI_BINARY_DIR}/bin")
- # Find the LLVM sources and simulate LLVM CMake options.
- include(HandleOutOfTreeLLVM)
endif()
@@ -40,8 +46,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXXABI_STANDALONE_B
include(GNUInstallDirs)
if (LIBCXXABI_STANDALONE_BUILD)
- # Find the LLVM sources and simulate LLVM CMake options.
- include(HandleOutOfTreeLLVM)
find_package(Python3 COMPONENTS Interpreter)
if(NOT Python3_Interpreter_FOUND)
--
2.27.0

View File

@ -0,0 +1,11 @@
diff -ruN libcxxabi-14.0.0.src.orig/CMakeLists.txt libcxxabi-14.0.0.src/CMakeLists.txt
--- a/libcxxabi-14.0.0.src.orig/CMakeLists.txt 2022-03-24 08:12:22.531338455 +0100
+++ a/libcxxabi-14.0.0.src/CMakeLists.txt 2022-03-24 08:13:21.947731822 +0100
@@ -46,6 +46,7 @@
include(GNUInstallDirs)
if (LIBCXXABI_STANDALONE_BUILD)
+ find_package(LLVM REQUIRED HINTS "${LLVM_CMAKE_DIR}")
find_package(Python3 COMPONENTS Interpreter)
if(NOT Python3_Interpreter_FOUND)

View File

@ -1,6 +1,6 @@
%global toolchain clang
%global libcxxabi_version 14.0.0
#global rc_ver 2
%global libcxxabi_version 13.0.1
%global libcxxabi_srcdir libcxxabi-%{libcxxabi_version}%{?rc_ver:rc%{rc_ver}}.src
@ -16,8 +16,10 @@ Source2: tstellar-gpg-key.asc
Patch0: 0001-PATCH-libcxxabi-Include-refstring.h-from-system-incl.patch
Patch1: 0002-PATCH-libcxxabi-Remove-monorepo-requirement.patch
Patch2: add-llvm-cmake-package.patch
BuildRequires: clang llvm-devel cmake llvm-static ninja-build
BuildRequires: llvm-cmake-devel
BuildRequires: libcxx-devel >= %{version}
%if 0%{?rhel}
# libcxx-devel has this, so we need to as well.
@ -101,6 +103,9 @@ cp -a include/* %{buildroot}%{_includedir}
%{_libdir}/libc++abi.a
%changelog
* Thu Mar 24 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
- Update to 14.0.0
* Thu Feb 03 2022 Nikita Popov <npopov@redhat.com> - 13.0.1-1
- Update to LLVM 13.0.1 final