11.0.0-rc1 Release

This commit is contained in:
Tom Stellard 2020-08-11 15:29:34 +00:00
parent 2a5d4737cc
commit 8c8c7497b4
4 changed files with 42 additions and 9 deletions

2
.gitignore vendored
View File

@ -30,3 +30,5 @@
/libcxxabi-10.0.0rc6.src.tar.xz.sig
/libcxxabi-10.0.0.src.tar.xz
/libcxxabi-10.0.0.src.tar.xz.sig
/libcxxabi-11.0.0rc1.src.tar.xz
/libcxxabi-11.0.0rc1.src.tar.xz.sig

View File

@ -0,0 +1,26 @@
From ba3084240c5dc08557734be0ed81bfa52be81bce Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 11 Aug 2020 08:27:41 -0700
Subject: [PATCH] libcxxabi: Remove monorepo requirement
---
libcxxabi/CMakeLists.txt | 4 ----
1 file changed, 4 deletions(-)
diff --git a/libcxxabi/CMakeLists.txt b/libcxxabi/CMakeLists.txt
index 6cb139b311c..f124c09fcac 100644
--- a/libcxxabi/CMakeLists.txt
+++ b/libcxxabi/CMakeLists.txt
@@ -1,9 +1,5 @@
# See www/CMake.html for instructions on how to build libcxxabi with CMake.
-if (NOT IS_DIRECTORY "${CMAKE_CURRENT_LIST_DIR}/../libcxx")
- message(FATAL_ERROR "libc++abi now requires being built in a monorepo layout with libcxx available")
-endif()
-
#===============================================================================
# Setup Project
#===============================================================================
--
2.18.1

View File

@ -1,11 +1,11 @@
%global toolchain clang
#%%global rc_ver 6
%global baserelease 5
%global rc_ver 1
%global baserelease 0.1
%global libcxxabi_srcdir libcxxabi-%{version}%{?rc_ver:rc%{rc_ver}}.src
Name: libcxxabi
Version: 10.0.0
Version: 11.0.0
Release: %{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
Summary: Low level support for a standard C++ library
License: MIT or NCSA
@ -19,6 +19,8 @@ Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{versio
%endif
Source2: https://prereleases.llvm.org/%{version}/hans-gpg-key.asc
Patch0: 0001-libcxxabi-Remove-monorepo-requirement.patch
BuildRequires: clang llvm-devel cmake llvm-static ninja-build
BuildRequires: libcxx-devel >= %{version}
%if 0%{?rhel}
@ -47,12 +49,15 @@ Summary: Static libraries for libcxxabi
%prep
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
%autosetup -n %{libcxxabi_srcdir}
%autosetup -n %{libcxxabi_srcdir} -p2
sed -i 's|${LLVM_BINARY_DIR}/share/llvm/cmake|%{_libdir}/cmake/llvm|g' CMakeLists.txt
%build
%ifarch armv7hl
# Disable LTO on ARM. bfd crashes during some of the CMake compiler checks with:
# /usr/bin/ld: BFD version 2.35-10.fc33 internal error, aborting at elfcode.h:224 in bfd_elf32_swap_symbol_out
%global _lto_cflags %{nil}
# disable ARM exception handling
sed -i 's|#define _LIBCXXABI_ARM_EHABI||g' include/__cxxabi_config.h
%endif
@ -65,9 +70,6 @@ sed -i 's|#define _LIBCXXABI_ARM_EHABI||g' include/__cxxabi_config.h
%endif
%endif
# Filter out cflags not supported by clang.
%global optflags %(echo %{optflags} | sed -e 's/-mcet//g' -e 's/-fcf-protection//g' -e 's/-fstack-clash-protection//g')
%cmake -GNinja \
-DCMAKE_C_COMPILER=/usr/bin/clang \
-DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
@ -103,6 +105,9 @@ cp -a include/* %{buildroot}%{_includedir}
%{_libdir}/libc++abi.a
%changelog
* Tue Aug 11 2020 Tom Stellard <tstellar@redhat.com> - 11.0.0-0.1.rc1
- 11.0.0-rc1 Release
* Thu Aug 06 2020 Jeff Law <law@redhat.com> - 10.0.0-5
- Set toolchain to clang

View File

@ -1,2 +1,2 @@
SHA512 (libcxxabi-10.0.0.src.tar.xz) = e58be156f924b0e613a69872c1d42190a4123e9c7a4de973e3f735a23992487df91549756c8acee81a35f9575f5b3001e748f8b01439f233660a18f4a45b0f32
SHA512 (libcxxabi-10.0.0.src.tar.xz.sig) = 11630d9383213306881ff2cca4ae29b05ea48d265daa60f2e671d1ae4dafcc2900ea1b2a123ec3cd924fd17e1360812622632a6d928dd3bfd85c0b66d4d3326a
SHA512 (libcxxabi-11.0.0rc1.src.tar.xz) = ad30a6d09463d045124e63bbd11fbe16b0450961debf8f7c761c5aaea277bb802f7a60d27592caff0932e55c846df5c7a1b40c52af11388efe0ca7f9dd766a7c
SHA512 (libcxxabi-11.0.0rc1.src.tar.xz.sig) = 4ebd018d8764410595bc84ce1e1bad26386e5fcd0d9932bec2cc6cede868a54ad01fc995cf46b908dd63a811f44f64e79d811deafdfbf35dc928351c2a5cbe59