12.0.0-rc1 Release

This commit is contained in:
Tom Stellard 2021-02-17 19:51:55 +00:00
parent b0b569fdf7
commit 7b4ed51d92
4 changed files with 21 additions and 11 deletions

2
.gitignore vendored
View File

@ -55,3 +55,5 @@
/libcxx-11.1.0rc1.src.tar.xz.sig
/libcxx-11.1.0rc2.src.tar.xz
/libcxx-11.1.0rc2.src.tar.xz.sig
/libcxx-12.0.0rc1.src.tar.xz
/libcxx-12.0.0rc1.src.tar.xz.sig

View File

@ -1,4 +1,4 @@
From 796bd4b1417f8799418f0109f9fec5a9755a5681 Mon Sep 17 00:00:00 2001
From 00f6e1b066782e492753c76f8756e017445b2510 Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 11 Aug 2020 07:55:18 -0700
Subject: [PATCH] libcxx: Remove monorepo requirement
@ -8,7 +8,7 @@ Subject: [PATCH] libcxx: Remove monorepo requirement
1 file changed, 9 deletions(-)
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index f37d729a8a1..a6ea8e09d8c 100644
index 9bf1a02f0908..5348a15ec273 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -1,10 +1,3 @@
@ -22,9 +22,9 @@ index f37d729a8a1..a6ea8e09d8c 100644
#===============================================================================
# Setup Project
#===============================================================================
@@ -36,8 +29,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXX_STANDALONE_BUIL
set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org")
@@ -39,8 +32,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXX_STANDALONE_BUIL
set(LIBCXX_STANDALONE_BUILD 1)
set(LLVM_LIT_OUTPUT_DIR "${LIBCXX_BINARY_DIR}/bin")
- # Find the LLVM sources and simulate LLVM CMake options.
- include(HandleOutOfTreeLLVM)
@ -32,5 +32,5 @@ index f37d729a8a1..a6ea8e09d8c 100644
if (LIBCXX_STANDALONE_BUILD)
--
2.18.1
2.27.0

View File

@ -1,13 +1,13 @@
# If you need to bootstrap this, turn this on.
# Otherwise, you have a loop with libcxxabi
%global bootstrap 0
%global rc_ver 2
%global baserelease 3
%global rc_ver 1
%global baserelease 1
%global libcxx_srcdir libcxx-%{version}%{?rc_ver:rc%{rc_ver}}.src
Name: libcxx
Version: 11.1.0
Version: 12.0.0
Release: %{?rc_ver:0.}%{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
Summary: C++ standard library targeting C++11
License: MIT or NCSA
@ -89,12 +89,17 @@ pathfix.py -i %{__python3} -pn \
%ldconfig_scriptlets
# Install header files that libcxxabi needs
mkdir -p %{buildroot}%{_includedir}/libcxx-internal/
install -m 0644 src/include/* %{buildroot}%{_includedir}/libcxx-internal/
%files
%license LICENSE.TXT
%doc CREDITS.TXT TODO.TXT
%{_libdir}/libc++.so.*
%files devel
%{_includedir}/libcxx-internal/
%{_includedir}/c++/
%{_libdir}/libc++.so
@ -104,6 +109,9 @@ pathfix.py -i %{__python3} -pn \
%changelog
* Wed Feb 17 2021 Tom Stellard <tstellar@redhat.com> - 12.0.0-0.1.rc1
- 12.0.0-rc1 Release
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 11.1.0-0.3.rc2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

View File

@ -1,2 +1,2 @@
SHA512 (libcxx-11.1.0rc2.src.tar.xz) = 27cfa7bdb7a0d164aec9a397e12591f0e41d85ac540df6f78e131822fb0e0af202a5ef905b87081f8c6af2703288e6fc86e28a94883def8c1134e23ef58462f2
SHA512 (libcxx-11.1.0rc2.src.tar.xz.sig) = f358402f0eedc507ffe27dd61691dd701426e69d84abc6f255b4e3a47181e5706cf7d6658486e9cb6200f23027216be268dd81755fa3992b213e60bfcb32def1
SHA512 (libcxx-12.0.0rc1.src.tar.xz.sig) = a67db3a7dbb99693b5f8969d48e1b76ee9962f1d973127153127975a00b7ce3b7400b6c367cca18ecd71d3fb503d075ce42ea0c4f150edbd2aa2f9b70d52c672
SHA512 (libcxx-12.0.0rc1.src.tar.xz) = 2fd00eb9f2f933097147c36b4a1ecc4c38d0debca38c4dcf048c9059327efe5792e8674349c9d67aca2d304b60a65616587f434bcb74dd36f6094af4442dc34f