11.0.0-rc1 Release

This commit is contained in:
Tom Stellard 2020-08-11 15:23:08 +00:00
parent f1bfe5f55f
commit 41db51f393
4 changed files with 57 additions and 7 deletions

2
.gitignore vendored
View File

@ -33,3 +33,5 @@
/libcxx-10.0.0rc6.src.tar.xz.sig
/libcxx-10.0.0.src.tar.xz
/libcxx-10.0.0.src.tar.xz.sig
/libcxx-11.0.0rc1.src.tar.xz
/libcxx-11.0.0rc1.src.tar.xz.sig

View File

@ -0,0 +1,36 @@
From 796bd4b1417f8799418f0109f9fec5a9755a5681 Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 11 Aug 2020 07:55:18 -0700
Subject: [PATCH] libcxx: Remove monorepo requirement
---
libcxx/CMakeLists.txt | 9 ---------
1 file changed, 9 deletions(-)
diff --git a/libcxx/CMakeLists.txt b/libcxx/CMakeLists.txt
index f37d729a8a1..a6ea8e09d8c 100644
--- a/libcxx/CMakeLists.txt
+++ b/libcxx/CMakeLists.txt
@@ -1,10 +1,3 @@
-# See https://libcxx.llvm.org/docs/BuildingLibcxx.html for instructions on how
-# to build libcxx with CMake.
-
-if (NOT IS_DIRECTORY "${CMAKE_CURRENT_LIST_DIR}/../libcxxabi")
- message(FATAL_ERROR "libc++ now requires being built in a monorepo layout with libcxxabi available")
-endif()
-
#===============================================================================
# Setup Project
#===============================================================================
@@ -36,8 +29,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR OR LIBCXX_STANDALONE_BUIL
set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
set(PACKAGE_BUGREPORT "llvm-bugs@lists.llvm.org")
- # Find the LLVM sources and simulate LLVM CMake options.
- include(HandleOutOfTreeLLVM)
endif()
if (LIBCXX_STANDALONE_BUILD)
--
2.18.1

View File

@ -1,13 +1,13 @@
# If you need to bootstrap this, turn this on.
# Otherwise, you have a loop with libcxxabi
%global bootstrap 0
#%%global rc_ver 6
%global baserelease 3
%global rc_ver 1
%global baserelease 0.1
%global libcxx_srcdir libcxx-%{version}%{?rc_ver:rc%{rc_ver}}.src
Name: libcxx
Version: 10.0.0
Version: 11.0.0
Release: %{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
Summary: C++ standard library targeting C++11
License: MIT or NCSA
@ -21,12 +21,18 @@ Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{versio
%endif
Source2: https://prereleases.llvm.org/%{version}/hans-gpg-key.asc
Patch0: 0001-libcxx-Remove-monorepo-requirement.patch
BuildRequires: gcc-c++ llvm-devel cmake llvm-static ninja-build
# We need python3-devel for pathfix.py.
BuildRequires: python3-devel
%if %{bootstrap} < 1
BuildRequires: libcxxabi-devel
BuildRequires: python3
%endif
# For origin certification
BuildRequires: gnupg2
@ -58,12 +64,15 @@ Summary: Static libraries for libcxx
%prep
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
%autosetup -n %{libcxx_srcdir}
%autosetup -n %{libcxx_srcdir} -p2
pathfix.py -i %{__python3} -pn \
utils/*.py
%build
%cmake -GNinja \
-DLLVM_CONFIG=%{_bindir}/llvm-config \
-DLIBCXX_STANDALONE_BUILD=ON \
%if %{bootstrap} < 1
-DLIBCXX_CXX_ABI=libcxxabi \
-DLIBCXX_CXX_ABI_INCLUDE_PATHS=%{_includedir} \
@ -100,6 +109,9 @@ Summary: Static libraries for libcxx
%changelog
* Tue Aug 11 2020 Tom Stellard <tstellar@redhat.com> - 11.0.0-0.1.rc1
- 11.0.0-rc1 Release
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 10.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

View File

@ -1,2 +1,2 @@
SHA512 (libcxx-10.0.0.src.tar.xz) = 8cbcbea23c50f0d7020386d11af5b736b8b43291146c11ccc543118ed1877a88adc381be2573594236e97bcf75c47408f986e5e9644a4fce57758cde47e5b641
SHA512 (libcxx-10.0.0.src.tar.xz.sig) = e67b0a090d409445738a232087c9097153318d6dd69dba11097b7f2f2b6dc79f3c555dca849d3b816b493e8bd33b4804bb7bd4e1742335d820de7fd980477ee0
SHA512 (libcxx-11.0.0rc1.src.tar.xz) = a39867c20268570df35b9bacdee099a9165a990134809d29141910c27086f68ce41ffad0ddbb622452006eef52f156acd21af2604787df409cc53fdfd0ff3855
SHA512 (libcxx-11.0.0rc1.src.tar.xz.sig) = 9e56d47b88961d7626e3f95774b2ed9ee86baa6aafdf697fc3161c62ba28592e78c59a1931fed211d770dc3b901ab464c98eb27b4c7db847bd8044ff48a51c00