0eb7206aa7
Fri Jul 19 2002 Jakub Jelinek <jakub@redhat.com> 1.10-12 - CFLAGS was using COPTFLAG variable, not COPTFLAGS - build with -fpic - apply the IA-64 patch everywhere, use capget/capset from glibc, not directly as _syscall (as it is broken on IA-32 with -fpic) - reenable alpha
18 lines
800 B
Diff
18 lines
800 B
Diff
--- libcap-1.11/libcap/Makefile.shared 1999-04-17 18:16:31.000000000 -0400
|
|
+++ libcap-1.11/libcap/Makefile 2002-07-19 06:24:23.000000000 -0400
|
|
@@ -56,12 +56,12 @@ cap_names.sed: Makefile /usr/include/lin
|
|
# @sed -ne '/^#define[ \t]CAP[_A-Z]\+[ \t]\+[0-9]\+/{s/^#define CAP_\([^ \t]*\)[ \t]*\([^ \t]*\)/ \{ \2, \"\1\" \},/;y/ABCDEFGHIJKLMNOPQRSTUVWXYZ/abcdefghijklmnopqrstuvwxyz/;p;}' < /usr/include/linux/capability.h | fgrep -v 0x > cap_names.sed
|
|
|
|
$(MINLIBNAME): $(OBJS)
|
|
- $(LD) -soname $(MAJLIBNAME) -x -shared -o $@ $(OBJS)
|
|
+ $(CC) -Wl,-soname,$(MAJLIBNAME) -Wl,-x -shared -o $@ $(OBJS)
|
|
ln -sf $(MINLIBNAME) $(MAJLIBNAME)
|
|
ln -sf $(MAJLIBNAME) $(LIBNAME)
|
|
|
|
%.o: %.c $(INCLS)
|
|
- $(CC) $(CFLAGS) -c $< -o $@
|
|
+ $(CC) $(CFLAGS) -fpic -c $< -o $@
|
|
|
|
install: all
|
|
mkdir -p -m 0755 $(INCDIR)/sys
|