Update to version 0.0.2

Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
This commit is contained in:
Javier Martinez Canillas 2022-12-01 20:56:15 +01:00
parent 672af88390
commit 31244b945e
No known key found for this signature in database
GPG Key ID: C751E590D63F3D69
4 changed files with 13 additions and 79 deletions

View File

@ -1,36 +0,0 @@
From 9bc21e4d22191dbd0757f4044c1e73844d4835c6 Mon Sep 17 00:00:00 2001
From: Javier Martinez Canillas <javierm@redhat.com>
Date: Thu, 23 Jun 2022 13:59:27 +0200
Subject: [PATCH 1/2] meson: options: Disable pycamera by default
The libcamera Python bindings is still experimental and it relies on some
features in pybind11 that are not yet upstreamed, so a special branch has
to be downloaded as a subproject.
This conflicts with the build process used by most Linux distributions,
since there is expected that all the dependencies will be fulfilled by
-devel packages present in the build root.
To allow libcamera to be built by distros, let's disable the pycamera by
default. This can still be enabled with `meson build -Dpycamera=enabled`.
Suggested-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com>
Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
---
meson_options.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson_options.txt b/meson_options.txt
index ca00c78e8134..7a9aecfc60f5 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -61,5 +61,5 @@ option('v4l2',
option('pycamera',
type : 'feature',
- value : 'auto',
+ value : 'disabled',
description : 'Enable libcamera Python bindings (experimental)')
--
2.36.1

View File

@ -1,30 +0,0 @@
From f1982fdbcab7ae76c643d295ed3f3a06e208fd4a Mon Sep 17 00:00:00 2001
From: Javier Martinez Canillas <javierm@redhat.com>
Date: Thu, 23 Jun 2022 14:21:11 +0200
Subject: [PATCH 2/2] py: Honour the pycamera meson option
The libcamera Python bindings are attempted to be built unconditionally,
even when there is a meson feature option to disable it. Make the meson
build file in the sub-dir to exit earlier if pycamera has been disabled.
Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>
---
src/py/libcamera/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/py/libcamera/meson.build b/src/py/libcamera/meson.build
index eb8845388692..5efae1baec8c 100644
--- a/src/py/libcamera/meson.build
+++ b/src/py/libcamera/meson.build
@@ -2,7 +2,7 @@
py3_dep = dependency('python3', required : get_option('pycamera'))
-if not py3_dep.found()
+if get_option('pycamera').disabled() or not py3_dep.found()
pycamera_enabled = false
subdir_done()
endif
--
2.36.1

View File

@ -1,21 +1,18 @@
%global commit 68683d3811a803aa087c38a2063cf64c8d084d49
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global commitdate 20220831
Name: libcamera
Version: 0.0.0~git.%{commitdate}.%{shortcommit}
Release: 5%{?dist}
Version: 0.0.2
Release: 1%{?dist}
Summary: A library to support complex camera ISPs
# Library is LGPLv2.1+ and the cam tool is GPLv2
License: LGPLv2+ and GPLv2
URL: http://libcamera.org/
# Upstream is still under development so they are not tagging releases
# yet (https://git.linuxtv.org/libcamera.git). Use the following to do
# a rebase to a new snapshot:
# Upstream is still under development and does not release tarballs,
# but they do tag releases (https://git.linuxtv.org/libcamera.git).
#
# git archive --format=tar --prefix=%%{name}-%%{shortcommit}/ %%{shortcommit} | xz > %%{name}-%%{shortcommit}.tar.xz
Source0: %{name}-%{shortcommit}.tar.xz
# For use the following to do generate a tarball from a git tag:
#
# git archive --format=tar --prefix=%%{name}-%%{version}/ %%{version} | xz > %%{name}-%%{version}.tar.xz
Source0: %{name}-%{version}.tar.xz
Source1: qcam.desktop
Source2: qcam.metainfo.xml
@ -98,7 +95,7 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
GSTreamer plugins for %{name}
%prep
%autosetup -p1 -n %{name}-%{shortcommit}
%autosetup -p1 -n %{name}-%{version}
%build
# cam/qcam crash with LTO
@ -166,6 +163,9 @@ rm -rf ${RPM_BUILD_ROOT}/%{_docdir}/%{name}-*/html/.doctrees
%{_bindir}/lc-compliance
%changelog
* Thu Dec 01 2022 Javier Martinez Canillas <javierm@redhat.com> - 0.0.2-1
- Update to version 0.0.2
* Wed Aug 31 2022 Javier Martinez Canillas <javierm@redhat.com> - 0.0.0~git.20220831.68683d3-1
- Update to snapshot 68683d3

View File

@ -1 +1 @@
SHA512 (libcamera-68683d3.tar.xz) = 1b681a42360bbd532cd2a85b8f269f9d483fd63e176a6de703a8b76a625f0500e8f4a90b6c12d8ac91a8c6622f9f437145159924d03f50e9192a1ef8eb41232a
SHA512 (libcamera-0.0.2.tar.xz) = f8376c85980e55e3d1cf18eb38945208fa12adcd06b1d6c9b99059da17f386e2e0a97d934d4d0008a57daaedd002abc93e9f4a4e9b853916074e964313ffa80d