36 lines
1.6 KiB
Diff
36 lines
1.6 KiB
Diff
diff -Naupr libcaca-0.99.beta16.orig/caca/driver/gl.c libcaca-0.99.beta16/caca/driver/gl.c
|
|
--- libcaca-0.99.beta16.orig/caca/driver/gl.c 2008-09-27 17:58:05.000000000 +0200
|
|
+++ libcaca-0.99.beta16/caca/driver/gl.c 2009-06-11 12:40:36.197533250 +0200
|
|
@@ -27,6 +27,7 @@
|
|
# include <GLUT/glut.h>
|
|
#else
|
|
# include <GL/gl.h>
|
|
+# include <GL/glu.h>
|
|
# include <GL/glut.h>
|
|
# include <GL/freeglut_ext.h>
|
|
#endif
|
|
diff -Naupr libcaca-0.99.beta16.orig/configure libcaca-0.99.beta16/configure
|
|
--- libcaca-0.99.beta16.orig/configure 2008-10-18 14:55:15.000000000 +0200
|
|
+++ libcaca-0.99.beta16/configure 2009-06-11 12:42:07.426595175 +0200
|
|
@@ -23859,7 +23859,7 @@ cat >>confdefs.h <<\_ACEOF
|
|
#define USE_GL 1
|
|
_ACEOF
|
|
|
|
- GL_LIBS="${GL_LIBS} -lGL -lglut"
|
|
+ GL_LIBS="${GL_LIBS} -lGL -lGLU -lglut"
|
|
CACA_DRIVERS="${CACA_DRIVERS} gl"
|
|
elif test "${enable_gl}" = "yes"; then
|
|
{ { echo "$as_me:$LINENO: error: cannot find OpenGL+FreeGLUT development files" >&5
|
|
diff -Naupr libcaca-0.99.beta16.orig/configure.ac libcaca-0.99.beta16/configure.ac
|
|
--- libcaca-0.99.beta16.orig/configure.ac 2008-10-18 14:54:11.000000000 +0200
|
|
+++ libcaca-0.99.beta16/configure.ac 2009-06-11 12:41:42.885595337 +0200
|
|
@@ -223,7 +223,7 @@ if test "${enable_gl}" != "no"; then
|
|
break])
|
|
if test "${ac_cv_my_have_gl}" = "yes"; then
|
|
AC_DEFINE(USE_GL, 1, Define to 1 to activate the OpenGL backend driver)
|
|
- GL_LIBS="${GL_LIBS} -lGL -lglut"
|
|
+ GL_LIBS="${GL_LIBS} -lGL -lGLU -lglut"
|
|
CACA_DRIVERS="${CACA_DRIVERS} gl"
|
|
elif test "${enable_gl}" = "yes"; then
|
|
AC_MSG_ERROR([cannot find OpenGL+FreeGLUT development files])
|