Update to 0.99.beta11.
This commit is contained in:
parent
231c2c40d5
commit
cefa1bc77d
@ -1 +1 @@
|
||||
libcaca-0.9.tar.bz2
|
||||
libcaca-0.99.beta11.tar.gz
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -Naupr libcaca-0.9.orig/doc/Makefile.am libcaca-0.9/doc/Makefile.am
|
||||
--- libcaca-0.9.orig/doc/Makefile.am 2004-02-02 04:00:20.000000000 +0100
|
||||
+++ libcaca-0.9/doc/Makefile.am 2004-11-03 13:54:17.583171192 +0100
|
||||
@@ -44,8 +44,6 @@ if BUILD_DOCUMENTATION
|
||||
$(mkinstalldirs) $(DESTDIR)$(datadir)/doc/libcaca-dev/html
|
||||
cp `find html -name '*.html' -o -name '*.gif' -o -name '*.png'` \
|
||||
$(DESTDIR)$(datadir)/doc/libcaca-dev/html
|
||||
- $(mkinstalldirs) $(DESTDIR)$(mandir)/man3
|
||||
- cp man/man3/*.3caca $(DESTDIR)$(mandir)/man3
|
||||
$(mkinstalldirs) $(DESTDIR)$(mandir)/man1
|
||||
rm -f $(DESTDIR)$(mandir)/man1/cacaball.1
|
||||
ln -s cacademo.1 $(DESTDIR)$(mandir)/man1/cacaball.1
|
||||
diff -Naupr libcaca-0.9.orig/doc/Makefile.in libcaca-0.9/doc/Makefile.in
|
||||
--- libcaca-0.9.orig/doc/Makefile.in 2004-02-02 04:00:44.000000000 +0100
|
||||
+++ libcaca-0.9/doc/Makefile.in 2004-11-03 13:54:10.763207984 +0100
|
||||
@@ -404,8 +404,6 @@ install-data-local:
|
||||
@BUILD_DOCUMENTATION_TRUE@ $(mkinstalldirs) $(DESTDIR)$(datadir)/doc/libcaca-dev/html
|
||||
@BUILD_DOCUMENTATION_TRUE@ cp `find html -name '*.html' -o -name '*.gif' -o -name '*.png'` \
|
||||
@BUILD_DOCUMENTATION_TRUE@ $(DESTDIR)$(datadir)/doc/libcaca-dev/html
|
||||
-@BUILD_DOCUMENTATION_TRUE@ $(mkinstalldirs) $(DESTDIR)$(mandir)/man3
|
||||
-@BUILD_DOCUMENTATION_TRUE@ cp man/man3/*.3caca $(DESTDIR)$(mandir)/man3
|
||||
@BUILD_DOCUMENTATION_TRUE@ $(mkinstalldirs) $(DESTDIR)$(mandir)/man1
|
||||
@BUILD_DOCUMENTATION_TRUE@ rm -f $(DESTDIR)$(mandir)/man1/cacaball.1
|
||||
@BUILD_DOCUMENTATION_TRUE@ ln -s cacademo.1 $(DESTDIR)$(mandir)/man1/cacaball.1
|
96
libcaca.spec
96
libcaca.spec
@ -1,15 +1,24 @@
|
||||
%define beta beta11
|
||||
|
||||
Summary: Library for Colour AsCii Art, text mode graphics
|
||||
Name: libcaca
|
||||
Version: 0.9
|
||||
Release: 11%{?dist}
|
||||
Version: 0.99
|
||||
Release: 0.1.%{beta}%{?dist}
|
||||
License: LGPL
|
||||
Group: System Environment/Libraries
|
||||
URL: http://sam.zoy.org/projects/libcaca/
|
||||
Source: http://sam.zoy.org/projects/libcaca/libcaca-%{version}.tar.bz2
|
||||
Patch: libcaca-0.9-man3.patch
|
||||
URL: http://libcaca.zoy.org/
|
||||
Source: http://libcaca.zoy.org/files/libcaca-%{version}.%{beta}.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
Buildrequires: libX11-devel, libXt-devel, ncurses-devel >= 5, slang-devel
|
||||
Buildrequires: imlib2-devel, zlib-devel, doxygen, tetex-latex, tetex-dvips
|
||||
BuildRequires: slang-devel
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: glut-devel
|
||||
BuildRequires: imlib2-devel
|
||||
BuildRequires: pango-devel
|
||||
# For the docs
|
||||
Buildrequires: doxygen
|
||||
Buildrequires: tetex-latex
|
||||
Buildrequires: tetex-dvips
|
||||
|
||||
%description
|
||||
libcaca is the Colour AsCii Art library. It provides high level functions
|
||||
@ -20,7 +29,13 @@ drawing, as well as powerful image to text conversion routines.
|
||||
%package devel
|
||||
Summary: Development files for libcaca, the library for Colour AsCii Art
|
||||
Group: Development/Libraries
|
||||
Requires: libX11-devel, ncurses-devel >= 5, slang-devel
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: slang-devel
|
||||
Requires: ncurses-devel
|
||||
Requires: libX11-devel
|
||||
Requires: glut-devel
|
||||
Requires: imlib2-devel
|
||||
Requires: pango-devel
|
||||
|
||||
%description devel
|
||||
libcaca is the Colour AsCii Art library. It provides high level functions
|
||||
@ -52,60 +67,77 @@ sprite blitting.
|
||||
|
||||
|
||||
%prep
|
||||
%setup
|
||||
%patch -p1 -b .man3
|
||||
%setup -q -n libcaca-%{version}.%{beta}
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--x-includes=%{_includedir} \
|
||||
--x-libraries=%{_libdir} \
|
||||
--enable-slang \
|
||||
--enable-ncurses \
|
||||
--enable-x11 \
|
||||
--enable-imlib2
|
||||
%configure --disable-rpath
|
||||
# Remove useless rpath
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
%{__make} %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
%{__rm} -rf %{buildroot}
|
||||
%{__rm} -rf %{buildroot} libcucul-dev-docs
|
||||
%makeinstall
|
||||
# We want to include the docs ourselves from the source directory
|
||||
%{__mv} %{buildroot}%{_docdir}/%{name}-dev %{name}-devel-docs
|
||||
%{__mv} %{buildroot}%{_docdir}/libcucul-dev libcucul-dev-docs
|
||||
|
||||
|
||||
%clean
|
||||
%{__rm} -rf %{buildroot}
|
||||
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root, 0755)
|
||||
%doc COPYING %{name}-devel-docs/*
|
||||
%{_libdir}/*.a
|
||||
%defattr(-,root,root,-)
|
||||
%doc ChangeLog libcucul-dev-docs/*
|
||||
%{_bindir}/caca-config
|
||||
%{_includedir}/*
|
||||
%{_includedir}/*.h
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%{_libdir}/*.a
|
||||
%exclude %{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_mandir}/man1/caca-config.1*
|
||||
#{_mandir}/man3/*
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%files -n caca-utils
|
||||
%defattr(-, root, root, 0755)
|
||||
%doc AUTHORS BUGS COPYING NEWS NOTES README THANKS TODO
|
||||
%{_bindir}/cacaball
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS COPYING* NEWS NOTES README THANKS TODO
|
||||
%{_bindir}/cacademo
|
||||
%{_bindir}/cacafire
|
||||
%{_bindir}/cacamoir
|
||||
%{_bindir}/cacaplas
|
||||
%{_bindir}/cacaplay
|
||||
%{_bindir}/cacaserver
|
||||
%{_bindir}/cacaview
|
||||
%{_bindir}/img2irc
|
||||
%{_datadir}/libcaca/
|
||||
%{_mandir}/man1/cacaball.1*
|
||||
%{_mandir}/man1/cacademo.1*
|
||||
%{_mandir}/man1/cacafire.1*
|
||||
%{_mandir}/man1/cacamoir.1*
|
||||
%{_mandir}/man1/cacaplas.1*
|
||||
%{_mandir}/man1/cacaplay.1*
|
||||
%{_mandir}/man1/cacaserver.1*
|
||||
%{_mandir}/man1/cacaview.1*
|
||||
%{_mandir}/man1/img2irc.1*
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Mar 29 2007 Matthias Saou <http://freshrpms.net/> 0.99-0.1.beta11
|
||||
- Update to 0.99beta11.
|
||||
- We now have a main libcaca package with just the shared lib (built by default
|
||||
now), so make the devel sub-package require it too. Leave static lib for now.
|
||||
- Enable opengl and pango support.
|
||||
- Remove useless rpath.
|
||||
- Remove no longer needed man3 patch.
|
||||
- Remove all configure options, they're autodetected.
|
||||
|
||||
* Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 0.9-11
|
||||
- FC6 rebuild.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user