Update to 0.99.beta19
This commit is contained in:
parent
6e8f62265b
commit
068244b832
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/libcaca-0.99.beta17.tar.gz
|
||||
/libcaca-0.99.beta18.tar.gz
|
||||
/libcaca-0.99.beta19.tar.gz
|
||||
|
@ -1,111 +0,0 @@
|
||||
--- ruby/caca-canvas.c.orig 2009-12-14 18:38:56.000000000 +0100
|
||||
+++ ruby/caca-canvas.c 2012-02-29 12:11:26.911741071 +0100
|
||||
@@ -274,7 +274,7 @@
|
||||
int error = 0;
|
||||
VALUE v, x, y;
|
||||
|
||||
- n = RARRAY(points)->len;
|
||||
+ n = RARRAY_LEN(points);
|
||||
|
||||
ax = (int*)malloc(n*sizeof(int));
|
||||
if(!ax)
|
||||
@@ -290,7 +290,7 @@
|
||||
for(i=0; i<n; i++)
|
||||
{
|
||||
v = rb_ary_entry(points, i);
|
||||
- if((TYPE(v) == T_ARRAY) && (RARRAY(v)->len == 2))
|
||||
+ if((TYPE(v) == T_ARRAY) && (RARRAY_LEN(v) == 2))
|
||||
{
|
||||
x = rb_ary_entry(v,0);
|
||||
y = rb_ary_entry(v,1);
|
||||
@@ -336,7 +336,7 @@
|
||||
int error = 0;
|
||||
VALUE v, x, y;
|
||||
|
||||
- n = RARRAY(points)->len;
|
||||
+ n = RARRAY_LEN(points);
|
||||
|
||||
ax = (int*)malloc(n*sizeof(int));
|
||||
if(!ax)
|
||||
@@ -352,7 +352,7 @@
|
||||
for(i=0; i<n; i++)
|
||||
{
|
||||
v = rb_ary_entry(points, i);
|
||||
- if((TYPE(v) == T_ARRAY) && (RARRAY(v)->len == 2))
|
||||
+ if((TYPE(v) == T_ARRAY) && (RARRAY_LEN(v) == 2))
|
||||
{
|
||||
x = rb_ary_entry(v,0);
|
||||
y = rb_ary_entry(v,1);
|
||||
@@ -459,7 +459,7 @@
|
||||
float cuv[6];
|
||||
VALUE v;
|
||||
|
||||
- l = RARRAY(coords)->len;
|
||||
+ l = RARRAY_LEN(coords);
|
||||
if(l != 6 && l != 3)
|
||||
{
|
||||
rb_raise(rb_eArgError, "invalid coords list");
|
||||
@@ -471,14 +471,14 @@
|
||||
ccoords[i] = NUM2INT(v);
|
||||
else
|
||||
{
|
||||
- if((TYPE(v) != T_ARRAY) || (RARRAY(v)->len != 2))
|
||||
+ if((TYPE(v) != T_ARRAY) || (RARRAY_LEN(v) != 2))
|
||||
rb_raise(rb_eArgError, "invalid coords list");
|
||||
ccoords[2*i] = NUM2INT(rb_ary_entry(v, 0));
|
||||
ccoords[2*i+1] = NUM2INT(rb_ary_entry(v, 1));
|
||||
}
|
||||
}
|
||||
|
||||
- l = RARRAY(uv)->len;
|
||||
+ l = RARRAY_LEN(uv);
|
||||
if(l != 6 && l != 3)
|
||||
{
|
||||
rb_raise(rb_eArgError, "invalid uv list");
|
||||
@@ -490,7 +490,7 @@
|
||||
cuv[i] = NUM2DBL(v);
|
||||
else
|
||||
{
|
||||
- if((TYPE(v) != T_ARRAY) || (RARRAY(v)->len != 2))
|
||||
+ if((TYPE(v) != T_ARRAY) || (RARRAY_LEN(v) != 2))
|
||||
rb_raise(rb_eArgError, "invalid uv list");
|
||||
ccoords[2*i] = NUM2DBL(rb_ary_entry(v, 0));
|
||||
ccoords[2*i+1] = NUM2DBL(rb_ary_entry(v, 1));
|
||||
@@ -600,7 +600,7 @@
|
||||
static VALUE import_from_memory(VALUE self, VALUE data, VALUE format)
|
||||
{
|
||||
long int bytes;
|
||||
- bytes = caca_import_canvas_from_memory (_SELF, StringValuePtr(data), RSTRING(StringValue(data))->len, StringValuePtr(format));
|
||||
+ bytes = caca_import_canvas_from_memory (_SELF, StringValuePtr(data), RSTRING_LEN(StringValue(data)), StringValuePtr(format));
|
||||
if(bytes <= 0)
|
||||
rb_raise(rb_eRuntimeError, strerror(errno));
|
||||
|
||||
@@ -610,7 +610,7 @@
|
||||
static VALUE import_area_from_memory(VALUE self, VALUE x, VALUE y, VALUE data, VALUE format)
|
||||
{
|
||||
long int bytes;
|
||||
- bytes = caca_import_area_from_memory (_SELF, NUM2INT(x), NUM2INT(y), StringValuePtr(data), RSTRING(StringValue(data))->len, StringValuePtr(format));
|
||||
+ bytes = caca_import_area_from_memory (_SELF, NUM2INT(x), NUM2INT(y), StringValuePtr(data), RSTRING_LEN(StringValue(data)), StringValuePtr(format));
|
||||
if(bytes <= 0)
|
||||
rb_raise(rb_eRuntimeError, strerror(errno));
|
||||
|
||||
--- ruby/caca-dither.c.orig 2009-11-17 16:58:37.000000000 +0100
|
||||
+++ ruby/caca-dither.c 2012-02-29 12:11:57.090640623 +0100
|
||||
@@ -48,7 +48,7 @@
|
||||
VALUE v, r, g, b, a;
|
||||
int error = 0;
|
||||
|
||||
- if(RARRAY(palette)->len != 256)
|
||||
+ if(RARRAY_LEN(palette) != 256)
|
||||
{
|
||||
rb_raise(rb_eArgError, "Palette must contain 256 elements");
|
||||
}
|
||||
@@ -84,7 +84,7 @@
|
||||
for(i=0; i<256; i++)
|
||||
{
|
||||
v = rb_ary_entry(palette, i);
|
||||
- if((TYPE(v) == T_ARRAY) && (RARRAY(v)->len == 4))
|
||||
+ if((TYPE(v) == T_ARRAY) && (RARRAY_LEN(v) == 4))
|
||||
{
|
||||
r = rb_ary_entry(v,0);
|
||||
g = rb_ary_entry(v,1);
|
15
libcaca.spec
15
libcaca.spec
@ -7,19 +7,17 @@
|
||||
%{!?ruby_vendorlibdir: %global ruby_vendorlibdir %(ruby -r rbconfig -e 'print RbConfig::CONFIG["vendorlibdir"]')}
|
||||
%{!?ruby_vendorarchdir: %global ruby_vendorarchdir %(ruby -r rbconfig -e 'print RbConfig::CONFIG["vendorarchdir"]')}
|
||||
|
||||
%define beta beta18
|
||||
%define beta beta19
|
||||
|
||||
Summary: Library for Colour AsCii Art, text mode graphics
|
||||
Name: libcaca
|
||||
Version: 0.99
|
||||
Release: 0.25.%{beta}%{?dist}
|
||||
Release: 0.26.%{beta}%{?dist}
|
||||
License: WTFPL
|
||||
Group: System Environment/Libraries
|
||||
URL: http://caca.zoy.org/wiki/libcaca
|
||||
Source: http://caca.zoy.org/files/libcaca/libcaca-%{version}.%{beta}.tar.gz
|
||||
Patch0: libcaca-0.99.beta16-multilib.patch
|
||||
# http://caca.zoy.org/ticket/99
|
||||
Patch1: libcaca-ruby-1.9.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: slang-devel
|
||||
BuildRequires: ncurses-devel
|
||||
@ -103,7 +101,6 @@ This package contains the ruby bindings for using libcaca from ruby.
|
||||
%prep
|
||||
%setup -q -n libcaca-%{version}.%{beta}
|
||||
%patch0 -p1 -b .multilib
|
||||
%patch1 -p0
|
||||
|
||||
|
||||
%build
|
||||
@ -187,6 +184,10 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 9 2015 Matthias Saou <matthias@saou.eu> 0.99-0.26.beta19
|
||||
- Update to 0.99.beta19.
|
||||
- Remove upstreamed ruby patch, fixed in November 2012 (commit 36990e1).
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99-0.25.beta18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
@ -317,10 +318,10 @@ rm -rf %{buildroot}
|
||||
* Fri Jan 9 2004 Matthias Saou <http://freshrpms.net/> 0.7-1
|
||||
- Spec file cleanup for Fedora Core 1.
|
||||
|
||||
* Sat Jan 7 2004 Sam Hocevar (RPM packages) <sam+rpm@zoy.org> 0.7-1
|
||||
* Wed Jan 7 2004 Sam Hocevar (RPM packages) <sam+rpm@zoy.org> 0.7-1
|
||||
- new release
|
||||
|
||||
* Sat Jan 4 2004 Sam Hocevar (RPM packages) <sam+rpm@zoy.org> 0.6-2
|
||||
* Sun Jan 4 2004 Sam Hocevar (RPM packages) <sam+rpm@zoy.org> 0.6-2
|
||||
- install documentation into {doc}/package-version instead of {doc}/package
|
||||
- added tetex-dvips to the build dependencies
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user