Update to 1.0.3

This commit is contained in:
František Zatloukal 2024-01-23 10:58:43 +01:00
parent 89808a2632
commit bba906907a
4 changed files with 4 additions and 41 deletions

1
.gitignore vendored
View File

@ -12,3 +12,4 @@
/libavif-0.9.3.tar.gz
/libavif-0.10.1.tar.gz
/libavif-0.11.1.tar.gz
/libavif-1.0.3.tar.gz

View File

@ -1,37 +0,0 @@
From e279707a001c8f95f8a2bc51c0d19bf35bfc79ab Mon Sep 17 00:00:00 2001
From: Wan-Teh Chang <wtc@google.com>
Date: Fri, 11 Nov 2022 14:08:33 -0800
Subject: [PATCH] Build aviftest_helpers for are_images_equal.cc
If are_images_equal.cc is built, enable CXX and build the
aviftest_helpers library.
Fix the build failure when -DAVIF_BUILD_APPS=ON -DAVIF_BUILD_TESTS=ON
-DAVIF_ENABLE_GTEST=OFF is passed to the cmake command.
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 5af7ea560..632ba7a71 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -39,15 +39,17 @@ foreach(AVIFYUV_MODE limited rgb) # Modes drift and premultiply take more than 2
add_test(NAME avifyuv_${AVIFYUV_MODE} COMMAND avifyuv -m ${AVIFYUV_MODE})
endforeach()
-################################################################################
-# GoogleTest
-
-if(AVIF_ENABLE_GTEST)
+if(AVIF_ENABLE_GTEST OR AVIF_BUILD_APPS)
enable_language(CXX)
set(CMAKE_CXX_STANDARD 11)
add_library(aviftest_helpers OBJECT gtest/aviftest_helpers.cc)
target_link_libraries(aviftest_helpers avif_apps)
+endif()
+################################################################################
+# GoogleTest
+
+if(AVIF_ENABLE_GTEST)
if(AVIF_LOCAL_GTEST)
set(GTEST_INCLUDE_DIRS ${CMAKE_SOURCE_DIR}/ext/googletest/googletest/include)
set(GTEST_LIBRARIES

View File

@ -15,14 +15,13 @@
%bcond_without check
Name: libavif
Version: 0.11.1
Version: 1.0.3
Release: %autorelease
Summary: Library for encoding and decoding .avif files
License: BSD-2-Clause
URL: https://github.com/AOMediaCodec/libavif
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
Patch0: libavif-0.11.1-build_tests_fix.patch
BuildRequires: cmake
BuildRequires: gcc-c++
@ -96,7 +95,7 @@ Avif-pixbuf-loader contains a plugin to load AVIF images in GTK+ applications.
%files
%license LICENSE
# Do not glob the soname
%{_libdir}/libavif.so.15*
%{_libdir}/libavif.so.16*
%{_datadir}/thumbnailers/avif.thumbnailer
%files devel

View File

@ -1 +1 @@
SHA512 (libavif-0.11.1.tar.gz) = 4a9e2711fccddf35c477db6e2fa2f76c0648aafaa98b4e3f34df62c0fbd02ddcd57762f1f8149822da4f1bc3757ee75ec1d9ced5e56a54dbe9d0b43265aacd4c
SHA512 (libavif-1.0.3.tar.gz) = b713f35fd3e54e105e16f46012becdada86f522b4ed8ab7097a93fd437524b4f2c997c42d6f06828f93b53253b1d90302417afdb0bd8e09d176f64f19c7a0faa