ledger/ledger-3.1-0009-Some-minor-changes.patch
2014-11-06 16:26:11 +00:00

76 lines
2.5 KiB
Diff

From 62e1354e0bb9bef2efaed14e3543199880026491 Mon Sep 17 00:00:00 2001
From: John Wiegley <johnw@newartisans.com>
Date: Tue, 4 Nov 2014 00:08:21 -0600
Subject: [PATCH 9/9] Some minor changes
---
acprep | 9 +++------
default.nix | 10 +++++++---
2 files changed, 10 insertions(+), 9 deletions(-)
diff --git a/acprep b/acprep
index a6cadc7..b0af210 100755
--- a/acprep
+++ b/acprep
@@ -1,10 +1,7 @@
#!/usr/bin/env python
-# acprep, version 3.0
+# acprep, version 3.1
#
-# This script configures my ledger source tree on my Mac OS/X machine. This
-# is not necessary, however, since I keep all the files necessary for building
-# checked in to the source tree. Users can just type './configure && make'.
# This script simply sets up the compiler and linker flags for all the various
# build permutations I use for testing and profiling.
@@ -802,7 +799,7 @@ class PrepareBuild(CommandLineApp):
conf_args.append('-DCMAKE_CXX_FLAGS=%s' %
self.envvars[var])
elif var == 'LDFLAGS':
- conf_args.append('-DCMAKE_EXE_LINKER_FLAGS=%s' %
+ conf_args.append('-DCMAKE_EXE_LINKER_FLAGS=%s' %
self.envvars[var])
if self.options.boost_root:
@@ -895,7 +892,7 @@ class PrepareBuild(CommandLineApp):
self.log.debug('Changing directory to ' + build_dir)
os.chdir(build_dir)
- self.execute(*(['ninja' if self.options.use_ninja else 'make'] +
+ self.execute(*(['ninja' if self.options.use_ninja else 'make'] +
make_args))
finally:
os.chdir(self.source_dir)
diff --git a/default.nix b/default.nix
index d54621d..4885c98 100644
--- a/default.nix
+++ b/default.nix
@@ -7,8 +7,7 @@ in
stdenv.mkDerivation {
name = "ledger-3.1.0.${rev}";
-
- src = ./.;
+ src = builtins.filterSource (path: type: type != "unknown") ./.;
buildInputs = [ cmake boost gmp mpfr libedit python texinfo gnused ];
@@ -18,7 +17,12 @@ stdenv.mkDerivation {
# broken in ledger...
postInstall = ''
mkdir -p $out/share/emacs/site-lisp/
- cp -v $src/lisp/*.el $out/share/emacs/site-lisp/
+ cp -v "$src/lisp/"*.el $out/share/emacs/site-lisp/
+ '' + stdenv.lib.optionalString stdenv.isDarwin ''
+ for i in date_time filesystem system iostreams regex unit_test_framework; do
+ boostlib=libboost_''$i.dylib
+ install_name_tool -change ''$boostlib ${boost}/lib/''$boostlib $out/bin/ledger
+ done
'';
meta = {
--
1.9.3