Patched and rebuilt for Boost 1.76
This commit is contained in:
parent
4de4dc9f80
commit
cde9b372ec
41
ledger-boost176.patch
Normal file
41
ledger-boost176.patch
Normal file
@ -0,0 +1,41 @@
|
||||
From e60717ccd78077fe4635315cb2657d1a7f539fca Mon Sep 17 00:00:00 2001
|
||||
From: Sam James <sam@gentoo.org>
|
||||
Date: Mon, 14 Jun 2021 12:37:58 +0000
|
||||
Subject: [PATCH] Fix compilation with Boost 1.76
|
||||
|
||||
We were previously relying on an indirect include within Boost headers. We're
|
||||
using scoped_ptr which is defined in <boost/smart_ptr/scoped_ptr.hpp>.
|
||||
|
||||
Bug: https://bugs.gentoo.org/790176
|
||||
Closes: https://github.com/ledger/ledger/issues/2030
|
||||
---
|
||||
src/expr.cc | 2 ++
|
||||
src/format.h | 2 ++
|
||||
2 files changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/expr.cc b/src/expr.cc
|
||||
index c8945d3da..c19bba98a 100644
|
||||
--- a/src/expr.cc
|
||||
+++ b/src/expr.cc
|
||||
@@ -35,6 +35,8 @@
|
||||
#include "parser.h"
|
||||
#include "scope.h"
|
||||
|
||||
+#include <boost/smart_ptr/scoped_ptr.hpp>
|
||||
+
|
||||
namespace ledger {
|
||||
|
||||
expr_t::expr_t() : base_type()
|
||||
diff --git a/src/format.h b/src/format.h
|
||||
index 15431cf11..48c690bec 100644
|
||||
--- a/src/format.h
|
||||
+++ b/src/format.h
|
||||
@@ -45,6 +45,8 @@
|
||||
#include "expr.h"
|
||||
#include "unistring.h"
|
||||
|
||||
+#include <boost/smart_ptr/scoped_ptr.hpp>
|
||||
+
|
||||
namespace ledger {
|
||||
|
||||
class unistring;
|
10
ledger.spec
10
ledger.spec
@ -2,11 +2,13 @@
|
||||
|
||||
Name: ledger
|
||||
Version: 3.2.1
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
Summary: A powerful command-line double-entry accounting system
|
||||
License: BSD
|
||||
URL: http://ledger-cli.org/
|
||||
Source0: https://github.com/ledger/ledger/archive/v%{version}.tar.gz
|
||||
# https://github.com/ledger/ledger/pull/2036
|
||||
Patch0: ledger-boost176.patch
|
||||
|
||||
BuildRequires: boost-devel
|
||||
BuildRequires: cmake
|
||||
@ -44,7 +46,7 @@ Requires: %{name} = %{version}-%{release}
|
||||
Libraries and header files for %{name} development.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{name}-%{version}
|
||||
%autosetup -n %{name}-%{version} -p 1
|
||||
# Avoid texinfo errors on EL7.
|
||||
%if 0%{?rhel} == 7
|
||||
sed -i -e 's#FIXME:UNDOCUMENTED#FIXMEUNDOCUMENTED#g' doc/ledger3.texi
|
||||
@ -116,8 +118,8 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Aug 06 2021 Jonathan Wakely <jwakely@redhat.com> - 3.2.1-6
|
||||
- Rebuilt for Boost 1.76
|
||||
* Mon Aug 09 2021 Jonathan Wakely <jwakely@redhat.com> - 3.2.1-7
|
||||
- Patched and rebuilt for Boost 1.76
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
Loading…
x
Reference in New Issue
Block a user