Link libraries to libboost_nowide.so

This commit is contained in:
Jonathan Wakely 2020-06-03 10:37:34 +01:00
parent ee701e9d46
commit d32134d9f5
2 changed files with 54 additions and 6 deletions

View File

@ -1,6 +1,6 @@
Name: leatherman
Version: 1.12.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Collection of C++ and CMake utility libraries
# leatherman is ASL 2.0
@ -72,6 +72,9 @@ sed -i -e "s/\s*-Werror\s*//g" cmake/cflags.cmake
%{_libdir}/cmake/%{name}/
%changelog
* Wed Jun 03 2020 Jonathan Wakely <jwakely@redhat.com> - 1.12.0-2
- Link libraries to libboost_nowide.so
* Wed Jun 03 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.12.0-1
- Update to 1.12.0

View File

@ -10,14 +10,45 @@ index ff9dba6..5d1b9ce 100644
if(WIN32)
add_leatherman_library(../vendor/nowide/src/iostream.cpp)
endif()
--- leatherman-1.10.0/logging/CMakeLists.txt~ 2020-06-02 23:25:07.073023981 +0100
+++ leatherman-1.10.0/logging/CMakeLists.txt 2020-06-02 23:25:14.889027402 +0100
--- leatherman-1.10.0/execution/CMakeLists.txt~ 2020-06-03 10:30:05.027479897 +0100
+++ leatherman-1.10.0/execution/CMakeLists.txt 2020-06-03 10:30:18.871483297 +0100
@@ -1,4 +1,4 @@
-find_package(Boost 1.54 REQUIRED COMPONENTS log log_setup thread date_time filesystem system chrono regex)
+find_package(Boost 1.73 REQUIRED COMPONENTS log log_setup thread date_time filesystem system chrono regex nowide)
find_package(Threads)
-find_package(Boost 1.54 REQUIRED COMPONENTS regex filesystem system)
+find_package(Boost 1.73 REQUIRED COMPONENTS regex filesystem system nowide)
add_leatherman_deps("${Boost_LIBRARIES}")
if ("${CMAKE_SYSTEM_NAME}" MATCHES "SunOS")
@@ -10,7 +10,6 @@
add_leatherman_includes("${Boost_INCLUDE_DIRS}")
leatherman_dependency(util)
-leatherman_dependency(nowide)
leatherman_dependency(locale)
leatherman_dependency(logging)
leatherman_dependency(file_util)
--- leatherman-1.10.0/file_util/CMakeLists.txt~ 2020-06-03 10:30:05.031479898 +0100
+++ leatherman-1.10.0/file_util/CMakeLists.txt 2020-06-03 10:31:04.550494516 +0100
@@ -1,9 +1,8 @@
-find_package(Boost 1.54 REQUIRED COMPONENTS regex filesystem system)
+find_package(Boost 1.73 REQUIRED COMPONENTS regex filesystem system nowide)
add_leatherman_deps("${Boost_LIBRARIES}")
add_leatherman_includes("${Boost_INCLUDE_DIRS}")
-leatherman_dependency(nowide)
leatherman_dependency(locale)
leatherman_dependency(logging)
leatherman_dependency(util)
--- leatherman-1.10.0/logging/CMakeLists.txt~ 2020-06-03 10:30:05.035479898 +0100
+++ leatherman-1.10.0/logging/CMakeLists.txt 2020-06-03 10:30:19.092483352 +0100
@@ -4,7 +4,6 @@
add_leatherman_deps(${Boost_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
add_leatherman_includes("${Boost_INCLUDE_DIRS}")
-leatherman_dependency(nowide)
leatherman_dependency(locale)
if (CMAKE_SYSTEM_NAME MATCHES "Linux" OR CMAKE_SYSTEM_NAME MATCHES "SunOS")
--- leatherman-1.10.0/tests/CMakeLists.txt~ 2020-06-02 23:24:17.146002133 +0100
+++ leatherman-1.10.0/tests/CMakeLists.txt 2020-06-02 23:26:17.780054923 +0100
@@ -1,8 +1,8 @@
@ -31,6 +62,20 @@ index ff9dba6..5d1b9ce 100644
include_directories(BEFORE ${LEATHERMAN_CATCH_INCLUDE} ${LEATHERMAN_INCLUDE_DIRS})
add_executable(leatherman_test main.cc ${LEATHERMAN_TEST_SRCS})
--- leatherman-1.10.0/util/CMakeLists.txt~ 2020-06-03 10:05:44.277172451 +0100
+++ leatherman-1.10.0/util/CMakeLists.txt 2020-06-03 10:06:52.969185017 +0100
@@ -1,10 +1,8 @@
-find_package(Boost 1.54 REQUIRED date_time chrono system)
+find_package(Boost 1.73 REQUIRED date_time chrono system nowide)
add_leatherman_deps(${Boost_LIBRARIES})
add_leatherman_includes("${Boost_INCLUDE_DIRS}")
-leatherman_dependency(nowide)
-
if(WIN32)
set(PLATFORM_SRCS "src/windows/time.cc" "src/windows/environment.cc" "src/windows/scoped_handle.cc")
set(PLATFORM_TESTS "tests/windows/environment.cc")
--- leatherman-1.10.0/file_util/src/file.cc~ 2019-12-14 20:46:29.000000000 +0000
+++ leatherman-1.10.0/file_util/src/file.cc 2020-06-02 22:42:45.100963441 +0100
@@ -1,6 +1,6 @@