Link leatherman_util against boost_nowide.

This commit is contained in:
Gwyn Ciesla 2021-03-18 09:49:38 -05:00
parent 83882dc510
commit 9961c45e61
2 changed files with 14 additions and 1 deletions

View File

@ -89,3 +89,13 @@
using namespace std;
using namespace leatherman::util;
--- a/util/CMakeLists.txt~ 2020-12-09 04:17:13.000000000 -0600
+++ b/util/CMakeLists.txt 2021-03-18 09:40:55.004699613 -0500
@@ -1,6 +1,6 @@
find_package(Boost 1.54 REQUIRED date_time chrono system)
-add_leatherman_deps(${Boost_LIBRARIES})
+add_leatherman_deps(${Boost_LIBRARIES} -lboost_nowide)
add_leatherman_includes("${Boost_INCLUDE_DIRS}")
leatherman_dependency(nowide)

View File

@ -1,6 +1,6 @@
Name: leatherman
Version: 1.12.4
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Collection of C++ and CMake utility libraries
# leatherman is ASL 2.0
@ -74,6 +74,9 @@ sed -i -e "s/\s*-Werror\s*//g" cmake/cflags.cmake
%{_libdir}/cmake/%{name}/
%changelog
* Thu Mar 18 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.12.4-2
- Link leatherman_util against boost_nowide.
* Tue Mar 09 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.12.4-1
- 1.12.4