kokkos/3308.patch

37 lines
2.4 KiB
Diff

From 766a82445380c8a36ad90c51f48f110a6624a176 Mon Sep 17 00:00:00 2001
From: Christoph Junghans <junghans@lanl.gov>
Date: Tue, 25 Aug 2020 14:07:28 -0600
Subject: [PATCH] cmake: rename libprinter-tool
---
core/unit_test/CMakeLists.txt | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/core/unit_test/CMakeLists.txt b/core/unit_test/CMakeLists.txt
index 8ce6ca3d3..f241c5bf1 100644
--- a/core/unit_test/CMakeLists.txt
+++ b/core/unit_test/CMakeLists.txt
@@ -417,10 +417,12 @@ KOKKOS_ADD_ADVANCED_TEST( UnitTest_PushFinalizeHook_terminate
if(KOKKOS_ENABLE_LIBDL)
KOKKOS_ADD_LIBRARY(
- printer-tool SHARED
+ kokkosprinter-tool SHARED
SOURCES tools/printing-tool.cpp
)
+ SET_TARGET_PROPERTIES(kokkosprinter-tool PROPERTIES VERSION ${Kokkos_VERSION})
+
KOKKOS_ADD_TEST_EXECUTABLE(
ProfilingAllCalls
tools/TestAllCalls.cpp
@@ -433,7 +435,7 @@ KOKKOS_ADD_ADVANCED_TEST( UnitTest_PushFinalizeHook_terminate
KOKKOS_ADD_TEST( NAME ProfilingTestLibraryLoad
EXE ProfilingAllCalls
- TOOL printer-tool
+ TOOL kokkosprinter-tool
PASS_REGULAR_EXPRESSION "kokkosp_init_library::kokkosp_allocate_data:${MEMSPACE_REGEX}:source:${ADDRESS_REGEX}:40::kokkosp_begin_parallel_for:Kokkos::View::initialization [[]source]:0:0::kokkosp_end_parallel_for:0::kokkosp_allocate_data:${MEMSPACE_REGEX}:destination:${ADDRESS_REGEX}:40::kokkosp_begin_parallel_for:Kokkos::View::initialization [[]destination]:0:0::kokkosp_end_parallel_for:0::kokkosp_begin_deep_copy:${MEMSPACE_REGEX}:destination:${ADDRESS_REGEX}:${MEMSPACE_REGEX}:source:${ADDRESS_REGEX}:40::kokkosp_end_deep_copy::kokkosp_begin_parallel_for:parallel_for:${SIZE_REGEX}:0::kokkosp_end_parallel_for:0::kokkosp_begin_parallel_reduce:parallel_reduce:0:1${SKIP_SCRATCH_INITIALIZATION_REGEX}::kokkosp_end_parallel_reduce:1::kokkosp_begin_parallel_scan:parallel_scan:${SIZE_REGEX}:2::kokkosp_end_parallel_scan:2::kokkosp_push_profile_region:push_region::kokkosp_pop_profile_region::kokkosp_create_profile_section:created_section:3::kokkosp_start_profile_section:3::kokkosp_stop_profile_section:3::kokkosp_destroy_profile_section:3::kokkosp_profile_event:profiling_event::kokkosp_deallocate_data:${MEMSPACE_REGEX}:destination:${ADDRESS_REGEX}:40::kokkosp_deallocate_data:${MEMSPACE_REGEX}:source:${ADDRESS_REGEX}:40::kokkosp_finalize_library::"
)
endif() #KOKKOS_ENABLE_LIBDL