Version bump to v3.1.01
This commit is contained in:
parent
71f3d624a7
commit
a5d7582563
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/kokkos-e79d6b7311fb91c81477a7fc458ca5408e0c19d2.tar.gz
|
||||
/kokkos-3.0.00.tar.gz
|
||||
/kokkos-3.1.00.tar.gz
|
||||
/kokkos-3.1.01.tar.gz
|
||||
|
22
2961.patch
22
2961.patch
@ -1,22 +0,0 @@
|
||||
From b3cf3bca09e68f9c2076998d25179635e40e2d09 Mon Sep 17 00:00:00 2001
|
||||
From: Christoph Junghans <junghans@lanl.gov>
|
||||
Date: Fri, 17 Apr 2020 09:14:14 -0600
|
||||
Subject: [PATCH] fix typo in KOKKOS_SET_EXE_PROPERTY()
|
||||
|
||||
---
|
||||
cmake/kokkos_tribits.cmake | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/cmake/kokkos_tribits.cmake b/cmake/kokkos_tribits.cmake
|
||||
index 1c3b704ad..6ee1409aa 100644
|
||||
--- a/cmake/kokkos_tribits.cmake
|
||||
+++ b/cmake/kokkos_tribits.cmake
|
||||
@@ -170,7 +170,7 @@ FUNCTION(KOKKOS_SET_EXE_PROPERTY ROOT_NAME)
|
||||
IF (NOT TARGET ${TARGET_NAME})
|
||||
MESSAGE(SEND_ERROR "No target ${TARGET_NAME} exists - cannot set target properties")
|
||||
ENDIF()
|
||||
- SET_PROPERTY(TARGET ${TARGET_PROPERTY} PROPERTY ${ARGN})
|
||||
+ SET_PROPERTY(TARGET ${TARGET_NAME} PROPERTY ${ARGN})
|
||||
ENDFUNCTION()
|
||||
|
||||
MACRO(KOKKOS_SETUP_BUILD_ENVIRONMENT)
|
10
kokkos.spec
10
kokkos.spec
@ -1,5 +1,5 @@
|
||||
Name: kokkos
|
||||
Version: 3.1.00
|
||||
Version: 3.1.01
|
||||
%global sover 3.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Kokkos C++ Performance Portability Programming
|
||||
@ -9,8 +9,6 @@ ExcludeArch: i686 armv7hl
|
||||
License: BSD
|
||||
URL: https://github.com/kokkos/kokkos
|
||||
Source0: https://github.com/kokkos/kokkos/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
Patch0: https://github.com/kokkos/kokkos/pull/2961.patch
|
||||
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake3 >= 3.0
|
||||
@ -38,11 +36,11 @@ This package contains the development files of %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
mkdir build
|
||||
pushd build
|
||||
|
||||
%{cmake3} \
|
||||
-DKokkos_ENABLE_TESTS=On \
|
||||
-DCMAKE_INSTALL_INCLUDEDIR=include/kokkos \
|
||||
@ -73,6 +71,10 @@ make -C build test CTEST_OUTPUT_ON_FAILURE=1 %{?testargs}
|
||||
%{_bindir}/nvcc_wrapper
|
||||
|
||||
%changelog
|
||||
* Wed May 06 2020 Christoph Junghans <junghans@votca.org> - 3.1.01-1
|
||||
- Version bump to v3.1.01
|
||||
- drop 2961.patch - merge upstream
|
||||
|
||||
* Thu Apr 16 2020 Christoph Junghans <junghans@votca.org> - 3.1.00-1
|
||||
- Version bump to v3.1.00 (bug #1824998)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (kokkos-3.1.00.tar.gz) = 7933542c24e137052d630a503d707912295022863f2d47c89c4a35a9c8a70514763d89e321c66a3878575e661461ede45ac44d74cf45eca2470e7f57840d5c0c
|
||||
SHA512 (kokkos-3.1.01.tar.gz) = 4fa428ec33ec207147b3fcc5e0d297bcff4ed772ba6baa24ccaf56b691b72b70c69bd48fdf134f4e78234bf755377fe01a31611a41539c2d211ba9caed24b1f2
|
||||
|
Loading…
x
Reference in New Issue
Block a user