Fix cmake targets

This commit is contained in:
Christoph Junghans 2020-08-25 17:47:50 -06:00
parent 575de12f71
commit a24954c602
2 changed files with 42 additions and 2 deletions

36
3308.patch Normal file
View File

@ -0,0 +1,36 @@
From 766a82445380c8a36ad90c51f48f110a6624a176 Mon Sep 17 00:00:00 2001
From: Christoph Junghans <junghans@lanl.gov>
Date: Tue, 25 Aug 2020 14:07:28 -0600
Subject: [PATCH] cmake: rename libprinter-tool
---
core/unit_test/CMakeLists.txt | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/core/unit_test/CMakeLists.txt b/core/unit_test/CMakeLists.txt
index 8ce6ca3d3..f241c5bf1 100644
--- a/core/unit_test/CMakeLists.txt
+++ b/core/unit_test/CMakeLists.txt
@@ -417,10 +417,12 @@ KOKKOS_ADD_ADVANCED_TEST( UnitTest_PushFinalizeHook_terminate
if(KOKKOS_ENABLE_LIBDL)
KOKKOS_ADD_LIBRARY(
- printer-tool SHARED
+ kokkosprinter-tool SHARED
SOURCES tools/printing-tool.cpp
)
+ SET_TARGET_PROPERTIES(kokkosprinter-tool PROPERTIES VERSION ${Kokkos_VERSION})
+
KOKKOS_ADD_TEST_EXECUTABLE(
ProfilingAllCalls
tools/TestAllCalls.cpp
@@ -433,7 +435,7 @@ KOKKOS_ADD_ADVANCED_TEST( UnitTest_PushFinalizeHook_terminate
KOKKOS_ADD_TEST( NAME ProfilingTestLibraryLoad
EXE ProfilingAllCalls
- TOOL printer-tool
+ TOOL kokkosprinter-tool
PASS_REGULAR_EXPRESSION "kokkosp_init_library::kokkosp_allocate_data:${MEMSPACE_REGEX}:source:${ADDRESS_REGEX}:40::kokkosp_begin_parallel_for:Kokkos::View::initialization [[]source]:0:0::kokkosp_end_parallel_for:0::kokkosp_allocate_data:${MEMSPACE_REGEX}:destination:${ADDRESS_REGEX}:40::kokkosp_begin_parallel_for:Kokkos::View::initialization [[]destination]:0:0::kokkosp_end_parallel_for:0::kokkosp_begin_deep_copy:${MEMSPACE_REGEX}:destination:${ADDRESS_REGEX}:${MEMSPACE_REGEX}:source:${ADDRESS_REGEX}:40::kokkosp_end_deep_copy::kokkosp_begin_parallel_for:parallel_for:${SIZE_REGEX}:0::kokkosp_end_parallel_for:0::kokkosp_begin_parallel_reduce:parallel_reduce:0:1${SKIP_SCRATCH_INITIALIZATION_REGEX}::kokkosp_end_parallel_reduce:1::kokkosp_begin_parallel_scan:parallel_scan:${SIZE_REGEX}:2::kokkosp_end_parallel_scan:2::kokkosp_push_profile_region:push_region::kokkosp_pop_profile_region::kokkosp_create_profile_section:created_section:3::kokkosp_start_profile_section:3::kokkosp_stop_profile_section:3::kokkosp_destroy_profile_section:3::kokkosp_profile_event:profiling_event::kokkosp_deallocate_data:${MEMSPACE_REGEX}:destination:${ADDRESS_REGEX}:40::kokkosp_deallocate_data:${MEMSPACE_REGEX}:source:${ADDRESS_REGEX}:40::kokkosp_finalize_library::"
)
endif() #KOKKOS_ENABLE_LIBDL

View File

@ -1,7 +1,7 @@
Name: kokkos
Version: 3.2.00
%global sover 3.2.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Kokkos C++ Performance Portability Programming
# no support for 32-bit archs https://github.com/kokkos/kokkos/issues/2312
ExcludeArch: i686 armv7hl
@ -9,6 +9,7 @@ ExcludeArch: i686 armv7hl
License: BSD
URL: https://github.com/kokkos/kokkos
Source0: https://github.com/kokkos/kokkos/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
Patch0: https://github.com/kokkos/kokkos/pull/3308.patch
BuildRequires: gcc-c++
BuildRequires: cmake3 >= 3.0
@ -36,6 +37,7 @@ This package contains the development files of %{name}.
%prep
%setup -q
%patch0 -p1
%build
%{cmake3} \
@ -51,7 +53,6 @@ This package contains the development files of %{name}.
%install
%cmake3_install
rm %{buildroot}%{_libdir}/libprinter-tool.so
%check
# https://github.com/kokkos/kokkos/issues/2959 - unstable test
@ -72,6 +73,9 @@ rm %{buildroot}%{_libdir}/libprinter-tool.so
%{_bindir}/nvcc_wrapper
%changelog
* Tue Aug 25 2020 Christoph Junghans <junghans@votca.org> - 3.2.00-2
- Fix cmake targets
* Tue Aug 25 2020 Christoph Junghans <junghans@votca.org> - 3.2.00-1
- Version bump to v3.2.00 (bug #1872456)