Version bump to v3.1.00 (bug #1824998)
This commit is contained in:
parent
06e5d34cdb
commit
71f3d624a7
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
||||
/kokkos-cb90e9484286b8728d821bb5b1c23e74373bc47b.tar.gz
|
||||
/kokkos-e79d6b7311fb91c81477a7fc458ca5408e0c19d2.tar.gz
|
||||
/kokkos-3.0.00.tar.gz
|
||||
/kokkos-3.1.00.tar.gz
|
||||
|
22
2961.patch
Normal file
22
2961.patch
Normal file
@ -0,0 +1,22 @@
|
||||
From b3cf3bca09e68f9c2076998d25179635e40e2d09 Mon Sep 17 00:00:00 2001
|
||||
From: Christoph Junghans <junghans@lanl.gov>
|
||||
Date: Fri, 17 Apr 2020 09:14:14 -0600
|
||||
Subject: [PATCH] fix typo in KOKKOS_SET_EXE_PROPERTY()
|
||||
|
||||
---
|
||||
cmake/kokkos_tribits.cmake | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/cmake/kokkos_tribits.cmake b/cmake/kokkos_tribits.cmake
|
||||
index 1c3b704ad..6ee1409aa 100644
|
||||
--- a/cmake/kokkos_tribits.cmake
|
||||
+++ b/cmake/kokkos_tribits.cmake
|
||||
@@ -170,7 +170,7 @@ FUNCTION(KOKKOS_SET_EXE_PROPERTY ROOT_NAME)
|
||||
IF (NOT TARGET ${TARGET_NAME})
|
||||
MESSAGE(SEND_ERROR "No target ${TARGET_NAME} exists - cannot set target properties")
|
||||
ENDIF()
|
||||
- SET_PROPERTY(TARGET ${TARGET_PROPERTY} PROPERTY ${ARGN})
|
||||
+ SET_PROPERTY(TARGET ${TARGET_NAME} PROPERTY ${ARGN})
|
||||
ENDFUNCTION()
|
||||
|
||||
MACRO(KOKKOS_SETUP_BUILD_ENVIRONMENT)
|
10
kokkos.spec
10
kokkos.spec
@ -1,6 +1,6 @@
|
||||
Name: kokkos
|
||||
Version: 3.0.00
|
||||
%global sover 3.0.0
|
||||
Version: 3.1.00
|
||||
%global sover 3.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Kokkos C++ Performance Portability Programming
|
||||
#no support for 32-bit archs https://github.com/kokkos/kokkos/issues/2312
|
||||
@ -9,6 +9,7 @@ ExcludeArch: i686 armv7hl
|
||||
License: BSD
|
||||
URL: https://github.com/kokkos/kokkos
|
||||
Source0: https://github.com/kokkos/kokkos/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
Patch0: https://github.com/kokkos/kokkos/pull/2961.patch
|
||||
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
@ -37,6 +38,7 @@ This package contains the development files of %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
mkdir build
|
||||
@ -66,12 +68,14 @@ make -C build test CTEST_OUTPUT_ON_FAILURE=1 %{?testargs}
|
||||
|
||||
%files devel
|
||||
%{_libdir}/libkokkos*.so
|
||||
%{_libdir}/pkgconfig/
|
||||
%{_libdir}/cmake/Kokkos
|
||||
%{_includedir}/kokkos
|
||||
%{_bindir}/nvcc_wrapper
|
||||
|
||||
%changelog
|
||||
* Thu Apr 16 2020 Christoph Junghans <junghans@votca.org> - 3.1.00-1
|
||||
- Version bump to v3.1.00 (bug #1824998)
|
||||
|
||||
* Thu Feb 27 2020 Christoph Junghans <junghans@votca.org> - 3.0.00-1
|
||||
- Version bump to 3.0.00
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (kokkos-3.0.00.tar.gz) = f98feaedfb3b5759fdab35f68ca5b6bd3eacdb658ff0a7b91a33839fa266a8533c76213ebba6445ff7f2430bcdec8d05d7e4c023b63532515ba30223a27f3ebb
|
||||
SHA512 (kokkos-3.1.00.tar.gz) = 7933542c24e137052d630a503d707912295022863f2d47c89c4a35a9c8a70514763d89e321c66a3878575e661461ede45ac44d74cf45eca2470e7f57840d5c0c
|
||||
|
Loading…
Reference in New Issue
Block a user