603 lines
19 KiB
RPMSpec
603 lines
19 KiB
RPMSpec
%global framework kio
|
|
|
|
Name: kf5-%{framework}
|
|
Version: 5.47.0
|
|
Release: 2%{?dist}
|
|
Summary: KDE Frameworks 5 Tier 3 solution for filesystem abstraction
|
|
|
|
License: GPLv2+ and MIT and BSD
|
|
URL: https://cgit.kde.org/%{framework}.git
|
|
|
|
%global majmin %(echo %{version} | cut -d. -f1-2)
|
|
%global revision %(echo %{version} | cut -d. -f3)
|
|
%if %{revision} >= 50
|
|
%global stable unstable
|
|
%else
|
|
%global stable stable
|
|
%endif
|
|
Source0: http://download.kde.org/%{stable}/frameworks/%{majmin}/%{framework}-%{version}.tar.xz
|
|
|
|
## upstream patches
|
|
|
|
## upstreamable patches
|
|
# revert part of https://cgit.kde.org/kio.git/commit/src/core/slave.cpp?id=e2a4517f099d809bd53c6a10769ebfddc0f28a8b
|
|
# can cause kio to try to use 'kioslave' binary from kdelibs3,
|
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1512418#c16
|
|
# https://bugs.kde.org/show_bug.cgi?id=386859
|
|
# https://phabricator.kde.org/D8810
|
|
Patch100: kio-slave_path.patch
|
|
|
|
# filter plugin provides
|
|
%global __provides_exclude_from ^(%{_kf5_qtplugindir}/.*\\.so)$
|
|
|
|
BuildRequires: extra-cmake-modules >= %{majmin}
|
|
BuildRequires: kf5-rpm-macros
|
|
# core
|
|
BuildRequires: kf5-karchive-devel >= %{majmin}
|
|
BuildRequires: kf5-kconfig-devel >= %{majmin}
|
|
BuildRequires: kf5-kcoreaddons-devel >= %{majmin}
|
|
BuildRequires: kf5-kdoctools-devel >= %{majmin}
|
|
BuildRequires: kf5-kdbusaddons-devel >= %{majmin}
|
|
BuildRequires: kf5-ki18n-devel >= %{majmin}
|
|
BuildRequires: kf5-kservice-devel >= %{majmin}
|
|
BuildRequires: kf5-solid-devel >= %{majmin}
|
|
# extras
|
|
BuildRequires: kf5-kbookmarks-devel >= %{majmin}
|
|
BuildRequires: kf5-kcompletion-devel >= %{majmin}
|
|
BuildRequires: kf5-kconfigwidgets-devel >= %{majmin}
|
|
BuildRequires: kf5-kiconthemes-devel >= %{majmin}
|
|
BuildRequires: kf5-kitemviews-devel >= %{majmin}
|
|
BuildRequires: kf5-kjobwidgets-devel >= %{majmin}
|
|
BuildRequires: kf5-kwindowsystem-devel >= %{majmin}
|
|
# others
|
|
BuildRequires: kf5-knotifications-devel >= %{majmin}
|
|
BuildRequires: kf5-ktextwidgets-devel >= %{majmin}
|
|
BuildRequires: kf5-kwallet-devel >= %{majmin}
|
|
BuildRequires: kf5-kwidgetsaddons-devel >= %{majmin}
|
|
BuildRequires: kf5-kxmlgui-devel >= %{majmin}
|
|
|
|
BuildRequires: krb5-devel
|
|
BuildRequires: libacl-devel
|
|
BuildRequires: libxml2-devel
|
|
BuildRequires: libxslt-devel
|
|
BuildRequires: qt5-qtbase-devel
|
|
BuildRequires: qt5-qtscript-devel
|
|
BuildRequires: qt5-qtx11extras-devel
|
|
BuildRequires: zlib-devel
|
|
|
|
%if ! 0%{?bootstrap}
|
|
# (apparently?) requires org.kde.klauncher5 service provided by kf5-kinit -- rex
|
|
# not versioned to allow update without bootstrap
|
|
# <skip!>
|
|
BuildRequires: kf5-kinit-devel
|
|
%endif
|
|
|
|
Requires: %{name}-core%{?_isa} = %{version}-%{release}
|
|
Requires: %{name}-widgets%{?_isa} = %{version}-%{release}
|
|
Requires: %{name}-file-widgets%{?_isa} = %{version}-%{release}
|
|
Requires: %{name}-ntlm%{?_isa} = %{version}-%{release}
|
|
Requires: %{name}-gui%{?_isa} = %{version}-%{release}
|
|
|
|
%if 0%{?fedora} || 0%{?rhel} > 7
|
|
%global _with_html --with-html
|
|
%endif
|
|
|
|
%description
|
|
KDE Frameworks 5 Tier 3 solution for filesystem abstraction
|
|
|
|
%package devel
|
|
Summary: Development files for %{name}
|
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
|
Requires: kf5-kbookmarks-devel >= %{majmin}
|
|
Requires: kf5-kcompletion-devel >= %{majmin}
|
|
Requires: kf5-kconfig-devel >= %{majmin}
|
|
Requires: kf5-kcoreaddons-devel >= %{majmin}
|
|
Requires: kf5-kitemviews-devel >= %{majmin}
|
|
Requires: kf5-kjobwidgets-devel >= %{majmin}
|
|
Requires: kf5-kservice-devel >= %{majmin}
|
|
Requires: kf5-solid-devel >= %{majmin}
|
|
Requires: kf5-kxmlgui-devel >= %{majmin}
|
|
Requires: qt5-qtbase-devel
|
|
%description devel
|
|
The %{name}-devel package contains libraries and header files for
|
|
developing applications that use %{name}.
|
|
|
|
%package doc
|
|
Summary: Documentation files for %{name}
|
|
Requires: %{name}-core = %{version}-%{release}
|
|
Obsoletes: kf5-kio-doc < 5.11.0-3
|
|
BuildArch: noarch
|
|
%description doc
|
|
Documentation for %{name}.
|
|
|
|
%package core
|
|
Summary: Core components of the KIO Framework
|
|
## org.kde.klauncher5 service referenced from : src/core/slave.cpp
|
|
%{?kf5_kinit_requires}
|
|
Requires: %{name}-core-libs%{?_isa} = %{version}-%{release}
|
|
Requires: %{name}-doc = %{version}-%{release}
|
|
%description core
|
|
KIOCore library provides core non-GUI components for working with KIO.
|
|
|
|
%package core-libs
|
|
Summary: Runtime libraries for KIO Core
|
|
Requires: %{name}-core = %{version}-%{release}
|
|
%description core-libs
|
|
%{summary}.
|
|
|
|
%package widgets
|
|
Summary: Widgets for KIO Framework
|
|
## org.kde.klauncher5 service referenced from : widgets/krun.cpp
|
|
## included here for completeness, even those -core already has a dependency.
|
|
%{?kf5_kinit_requires}
|
|
Requires: %{name}-core%{?_isa} = %{version}-%{release}
|
|
%description widgets
|
|
KIOWidgets contains classes that provide generic job control, progress
|
|
reporting, etc.
|
|
|
|
%package widgets-libs
|
|
Summary: Runtime libraries for KIO Widgets library
|
|
Requires: %{name}-widgets = %{version}-%{release}
|
|
%description widgets-libs
|
|
%{summary}.
|
|
|
|
%package file-widgets
|
|
Summary: Widgets for file-handling for KIO Framework
|
|
Requires: %{name}-widgets%{?_isa} = %{version}-%{release}
|
|
%description file-widgets
|
|
The KIOFileWidgets library provides the file selection dialog and
|
|
its components.
|
|
|
|
%package gui
|
|
Summary: Gui components for the KIO Framework
|
|
Requires: %{name}-core%{?_isa} = %{version}-%{release}
|
|
%description gui
|
|
%{summary}.
|
|
|
|
%package ntlm
|
|
Summary: NTLM support for KIO Framework
|
|
%description ntlm
|
|
KIONTLM provides support for NTLM authentication mechanism in KIO
|
|
|
|
|
|
%prep
|
|
%autosetup -n %{framework}-%{version} -p1
|
|
|
|
|
|
%build
|
|
mkdir %{_target_platform}
|
|
pushd %{_target_platform}
|
|
%{cmake_kf5} ..
|
|
popd
|
|
|
|
%make_build -C %{_target_platform}
|
|
|
|
|
|
%install
|
|
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
|
|
|
|
%find_lang %{name} --all-name --with-man %{?with_html}
|
|
|
|
|
|
%files
|
|
%license COPYING.LIB
|
|
%doc README.md
|
|
|
|
|
|
%if 0%{?fedora} < 26
|
|
%posttrans core
|
|
/usr/bin/update-desktop-database -q &> /dev/null ||:
|
|
|
|
%postun core
|
|
if [ $1 -eq 0 ] ; then
|
|
/usr/bin/update-desktop-database -q &> /dev/null ||:
|
|
fi
|
|
%endif
|
|
|
|
%files core
|
|
%config %{_kf5_sysconfdir}/xdg/accept-languages.codes
|
|
%{_kf5_libexecdir}/kio_http_cache_cleaner
|
|
%{_kf5_libexecdir}/kpac_dhcp_helper
|
|
%{_kf5_libexecdir}/kioexec
|
|
%{_kf5_libexecdir}/kioslave
|
|
%{_kf5_libexecdir}/kiod5
|
|
%{_kf5_bindir}/ktelnetservice5
|
|
%{_kf5_bindir}/kcookiejar5
|
|
%{_kf5_bindir}/ktrash5
|
|
%{_kf5_plugindir}/kio/
|
|
%{_kf5_plugindir}/kded/
|
|
%{_kf5_qtplugindir}/kcm_kio.so
|
|
%{_kf5_qtplugindir}/kcm_trash.so
|
|
%{_kf5_plugindir}/kiod/
|
|
%{_kf5_datadir}/kservices5/cache.desktop
|
|
%{_kf5_datadir}/kservices5/cookies.desktop
|
|
%{_kf5_datadir}/kservices5/netpref.desktop
|
|
%{_kf5_datadir}/kservices5/proxy.desktop
|
|
%{_kf5_datadir}/kservices5/smb.desktop
|
|
%{_kf5_datadir}/kservices5/useragent.desktop
|
|
%{_kf5_datadir}/kservices5/*.protocol
|
|
%{_kf5_datadir}/kservices5/http_cache_cleaner.desktop
|
|
%{_kf5_datadir}/kservices5/kcmtrash.desktop
|
|
%{_kf5_datadir}/kservices5/useragentstrings
|
|
%{_kf5_datadir}/knotifications5/proxyscout.*
|
|
%{_kf5_datadir}/kf5/kcookiejar/domain_info
|
|
%{_kf5_datadir}/applications/*.desktop
|
|
%{_kf5_datadir}/kconf_update/*
|
|
%{_datadir}/dbus-1/services/org.kde.*.service
|
|
|
|
## omitted since 5.45, security concerns? -- rex
|
|
%if 0
|
|
# file_helper
|
|
%{_kf5_sysconfdir}/dbus-1/system.d/org.kde.kio.file.conf
|
|
%{_kf5_libexecdir}/kauth/file_helper
|
|
%{_kf5_datadir}/dbus-1/system-services/org.kde.kio.file.service
|
|
%{_kf5_datadir}/polkit-1/actions/org.kde.kio.file.policy
|
|
%endif
|
|
|
|
%ldconfig_scriptlets core-libs
|
|
|
|
%files core-libs
|
|
%{_kf5_libdir}/libKF5KIOCore.so.*
|
|
|
|
%files doc -f %{name}.lang
|
|
%{_kf5_mandir}/man8/kcookiejar5.8*
|
|
%if !0%{?_with_html}
|
|
%{_kf5_docdir}/HTML/*/*
|
|
%endif
|
|
|
|
%ldconfig_scriptlets gui
|
|
|
|
%files gui
|
|
%{_kf5_libdir}/libKF5KIOGui.so.*
|
|
|
|
%files widgets
|
|
%config %{_kf5_sysconfdir}/xdg/kshorturifilterrc
|
|
%{_kf5_qtplugindir}/kcm_webshortcuts.so
|
|
%dir %{_kf5_plugindir}/urifilters/
|
|
%{_kf5_plugindir}/urifilters/*.so
|
|
#{_kf5_datadir}/kservices5/fixhosturifilter.desktop
|
|
#{_kf5_datadir}/kservices5/kshorturifilter.desktop
|
|
#{_kf5_datadir}/kservices5/kuriikwsfilter.desktop
|
|
#{_kf5_datadir}/kservices5/kurisearchfilter.desktop
|
|
#{_kf5_datadir}/kservices5/localdomainurifilter.desktop
|
|
%{_kf5_datadir}/kservices5/webshortcuts.desktop
|
|
%{_kf5_datadir}/kservices5/searchproviders
|
|
%{_kf5_datadir}/kservicetypes5/*.desktop
|
|
|
|
%ldconfig_scriptlets widgets-libs
|
|
|
|
%files widgets-libs
|
|
%{_kf5_libdir}/libKF5KIOWidgets.so.*
|
|
|
|
%ldconfig_scriptlets file-widgets
|
|
|
|
%files file-widgets
|
|
%{_kf5_libdir}/libKF5KIOFileWidgets.so.*
|
|
|
|
%ldconfig_scriptlets ntlm
|
|
|
|
%files ntlm
|
|
%{_kf5_libdir}/libKF5KIONTLM.so.*
|
|
|
|
%files devel
|
|
%{_kf5_includedir}/*
|
|
%{_kf5_libdir}/*.so
|
|
%{_kf5_libdir}/cmake/KF5KIO/
|
|
%{_kf5_archdatadir}/mkspecs/modules/qt_KIOCore.pri
|
|
%{_kf5_archdatadir}/mkspecs/modules/qt_KIOFileWidgets.pri
|
|
%{_kf5_archdatadir}/mkspecs/modules/qt_KNTLM.pri
|
|
%{_kf5_archdatadir}/mkspecs/modules/qt_KIOWidgets.pri
|
|
%{_kf5_archdatadir}/mkspecs/modules/qt_KIOGui.pri
|
|
%{_datadir}/dbus-1/interfaces/*.xml
|
|
%{_kf5_bindir}/protocoltojson
|
|
|
|
|
|
%changelog
|
|
* Wed Jun 06 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.47.0-2
|
|
- respin
|
|
|
|
* Sat Jun 02 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.47.0-1
|
|
- 5.47.0
|
|
|
|
* Sun May 06 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.46.0-2
|
|
- respin
|
|
|
|
* Sat May 05 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.46.0-1
|
|
- 5.46.0
|
|
|
|
* Sun Apr 08 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.45.0-1
|
|
- 5.45.0
|
|
|
|
* Sun Mar 04 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.44.0-2
|
|
- use %%make_build %%ldconfig_scriptlets
|
|
- tarball respin
|
|
|
|
* Sat Mar 03 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.44.0-1
|
|
- 5.44.0
|
|
|
|
* Thu Feb 08 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.43.0-3
|
|
- respin
|
|
|
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.43.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Wed Feb 07 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.43.0-1
|
|
- 5.43.0
|
|
|
|
* Mon Jan 08 2018 Rex Dieter <rdieter@fedoraproject.org> - 5.42.0-1
|
|
- 5.42.0
|
|
|
|
* Tue Dec 19 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.41.0-3
|
|
- backport upstream fix: forwardsocket errors (D9249)
|
|
|
|
* Thu Dec 07 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.41.0-2
|
|
- cleanup
|
|
|
|
* Mon Dec 04 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.41.0-1
|
|
- 5.41.0
|
|
|
|
* Tue Nov 28 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.40.0-3
|
|
- pull in upstream fixes for Qt 5.9.3/5.10-beta changes
|
|
|
|
* Mon Nov 13 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.40.0-2
|
|
- kf5-kio runs wrong kioslave binary (#1512418)
|
|
|
|
* Fri Nov 10 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.40.0-1
|
|
- 5.40.0
|
|
|
|
* Sun Oct 08 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.39.0-1
|
|
- 5.39.0
|
|
|
|
* Mon Sep 11 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.38.0-1
|
|
- 5.38.0
|
|
|
|
* Fri Aug 25 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.37.0-1
|
|
- 5.37.0
|
|
|
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.36.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
|
|
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.36.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Mon Jul 03 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.36.0-1
|
|
- 5.36.0
|
|
|
|
* Sun Jun 04 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.35.0-1
|
|
- 5.35.0
|
|
|
|
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.34.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild
|
|
|
|
* Mon May 15 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.34.0-1
|
|
- 5.34.0
|
|
|
|
* Mon Apr 03 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.33.0-1
|
|
- 5.33.0
|
|
|
|
* Sat Mar 04 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.32.0-1
|
|
- 5.32.0
|
|
|
|
* Thu Mar 02 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.31.0-2
|
|
- CVE-2017-6410 (#1427808)
|
|
- .spec cosmetics, update URL
|
|
|
|
* Mon Feb 06 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.31.0-1
|
|
- 5.31.0
|
|
|
|
* Mon Jan 02 2017 Rex Dieter <rdieter@fedoraproject.org> - 5.29.0-2
|
|
- filter plugin provides, own plugindir/urifilters
|
|
|
|
* Fri Dec 16 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.29.0-1
|
|
- 5.29.0
|
|
|
|
* Tue Oct 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.27.0-1
|
|
- 5.27.0
|
|
|
|
* Fri Sep 30 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.26.0-3
|
|
- more upstream fixes (nfsv4 detection, ktcpsocket::secureprotocols)
|
|
|
|
* Sat Sep 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.26.0-2
|
|
- Fix launching terminal .desktop files with konsole (#1376981,kde#368949)
|
|
|
|
* Wed Sep 07 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.26.0-1
|
|
- KDE Frameworks 5.26.0
|
|
|
|
* Mon Aug 08 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.25.0-1
|
|
- KDE Frameworks 5.25.0
|
|
|
|
* Thu Jul 28 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.24.0-2
|
|
- -core/-widgets: +%%{?kf5_kinit_requires}
|
|
|
|
* Wed Jul 06 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.24.0-1
|
|
- KDE Frameworks 5.24.0
|
|
|
|
* Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.23.0-2
|
|
- BR: kf5-kinit-devel (provider of %%{?kf5_kinit_requires} macro)
|
|
|
|
* Tue Jun 07 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.23.0-1
|
|
- KDE Frameworks 5.23.0
|
|
|
|
* Tue Jun 07 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.22.0-2
|
|
- update URL
|
|
|
|
* Mon May 16 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.22.0-1
|
|
- KDE Frameworks 5.22.0
|
|
|
|
* Mon Apr 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.21.0-1
|
|
- KDE Frameworks 5.21.0
|
|
|
|
* Thu Mar 31 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.20.0-3
|
|
- backport crash fix (kde#360488)
|
|
|
|
* Sat Mar 26 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.20.0-2
|
|
- -core: move Requires: -doc here (from empty main pkg)
|
|
|
|
* Mon Mar 14 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.20.0-1
|
|
- KDE Frameworks 5.20.0
|
|
|
|
* Thu Feb 11 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.19.0-1
|
|
- KDE Frameworks 5.19.0
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.18.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Thu Jan 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.18.0-2
|
|
- -BR: cmake
|
|
|
|
* Sun Jan 03 2016 Daniel Vrátil <dvratil@fedoraproject.org> - 5.18.0-1
|
|
- KDE Frameworks 5.18.0
|
|
|
|
* Tue Dec 22 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.17.0-3
|
|
- use %%_kf5_kinit_requires macro
|
|
- -core: own plugindir/{kio,kded,kiod}
|
|
|
|
* Tue Dec 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.17.0-1
|
|
- KDE Frameworks 5.17.0
|
|
|
|
* Tue Nov 10 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.16.0-2
|
|
- kf5-kinit dep must be unversioned (my silly script ignored that)
|
|
|
|
* Sun Nov 08 2015 Daniel Vrátil <dvratil@fedoraproject.org> - 5.16.0-1
|
|
- KDE Frameworks 5.16.0
|
|
|
|
* Mon Nov 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.15.0-2
|
|
- .spec cleanup/cosmetics, update URL, (noarch) -doc subpkg
|
|
|
|
* Thu Oct 08 2015 Daniel Vrátil <dvratil@redhat.com> - 5.15.0-1
|
|
- KDE Frameworks 5.15.0
|
|
|
|
* Thu Sep 17 2015 Daniel Vrátil <dvratil@redhat.com> - 5.14.0-2
|
|
- kf5-kinit dependency must be unversioned
|
|
|
|
* Wed Sep 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.14.0-1
|
|
- KDE Frameworks 5.14.0
|
|
|
|
* Thu Aug 20 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-2
|
|
- Make kf5-kinit dependency unversioned to allow non-bootstrapped update
|
|
|
|
* Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
|
|
- KDE Frameworks 5.13.0
|
|
|
|
* Wed Aug 19 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-1
|
|
- KDE Frameworks 5.13.0
|
|
|
|
* Tue Aug 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.13.0-0.1
|
|
- KDE Frameworks 5.13
|
|
|
|
* Fri Jul 10 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.12.0-1
|
|
- 5.12.0
|
|
|
|
* Thu Jul 02 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.11.0-3
|
|
- .spec cleanup, cleanup Conflicts
|
|
- use %%license
|
|
- drop -doc subpkg
|
|
- Requires: kf5-kinit (kio apparently needs org.kde.klauncher5 service provided by kinit)
|
|
|
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.11.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Wed Jun 10 2015 Daniel Vrátil <dvratil@redhat.com> - 5.11.0-1
|
|
- KDE Frameworks 5.11.0
|
|
|
|
* Mon May 11 2015 Daniel Vrátil <dvratil@redhat.com> - 5.10.0-1
|
|
- KDE Frameworks 5.10.0
|
|
|
|
* Fri May 01 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.9.0-3
|
|
- Added folders to left panel "Places" disappear (kde#345174)
|
|
- optimize scriptlets
|
|
- .spec cosmetics
|
|
|
|
* Thu Apr 30 2015 Rex Dieter <rdieter@fedoraproject.org> 5.9.0-2
|
|
- BR: krb5-devel libacl-devel
|
|
|
|
* Tue Apr 07 2015 Daniel Vrátil <dvratil@redhat.com> - 5.9.0-1
|
|
- KDE Frameworks 5.9.0
|
|
|
|
* Fri Apr 03 2015 Rex Dieter <rdieter@fedoraproject.org> 5.8.0-2
|
|
- -core: own %%{_kf5_datadir}/kservices5/kded/
|
|
|
|
* Mon Mar 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.8.0-1
|
|
- KDE Frameworks 5.8.0
|
|
|
|
* Fri Feb 27 2015 Daniel Vrátil <dvratil@redhat.com> - 5.7.0-2
|
|
- Rebuild (GCC 5)
|
|
|
|
* Mon Feb 16 2015 Daniel Vrátil <dvratil@redhat.com> - 5.7.0-1
|
|
- KDE Frameworks 5.7.0
|
|
|
|
* Mon Feb 09 2015 Daniel Vrátil <dvratil@redhat.com> - 5.7.0-1
|
|
- KDE Frameworks 5.7.0
|
|
|
|
* Thu Jan 08 2015 Daniel Vrátil <dvratil@redhat.com> - 5.6.0-1
|
|
- KDE Frameworks 5.6.0
|
|
|
|
* Mon Dec 08 2014 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-1
|
|
- KDE Frameworks 5.5.0
|
|
|
|
* Mon Nov 03 2014 Daniel Vrátil <dvratil@redhat.com> - 5.4.0-1
|
|
- KDE Frameworks 5.4.0
|
|
|
|
* Thu Oct 30 2014 Daniel Vrátil <dvratil@redhat.com> - 5.3.0-3
|
|
- Fix typo in deps
|
|
|
|
* Wed Oct 29 2014 Daniel Vrátil <dvratil@redhat.com> - 5.3.0-2
|
|
- Split into subpackages
|
|
|
|
* Tue Oct 07 2014 Daniel Vrátil <dvratil@redhat.com> - 5.3.0-1
|
|
- KDE Frameworks 5.3.0
|
|
|
|
* Mon Sep 15 2014 Daniel Vrátil <dvratil@redhat.com> - 5.2.0-1
|
|
- KDE Frameworks 5.2.0
|
|
|
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
|
|
|
* Wed Aug 06 2014 Daniel Vrátil <dvratil@redhat.com> - 5.1.0-1
|
|
- KDE Frameworks 5.1.0
|
|
|
|
* Mon Jul 14 2014 Daniel Vrátil <dvratil@redhat.com> - 5.0.0-2
|
|
- Fix plugin install path
|
|
|
|
* Wed Jul 09 2014 Daniel Vrátil <dvratil@redhat.com> - 5.0.0-1
|
|
- KDE Frameworks 5.0.0
|
|
|
|
* Sat Jun 28 2014 Daniel Vrátil <dvratil@redhat.com> - 4.100.0-2
|
|
- fixed licenses
|
|
- added %%config
|
|
- added update-desktop-database
|
|
|
|
* Tue Jun 03 2014 Daniel Vrátil <dvratil@redhat.com> - 4.100.0-1
|
|
- KDE Frameworks 4.100.0
|
|
|
|
* Mon May 05 2014 Daniel Vrátil <dvratil@redhat.com> - 4.99.0
|
|
- KDE Frameworks 4.99.0
|
|
|
|
* Wed Apr 02 2014 Daniel Vrátil <dvratil@redhat.com> 4.98.0-2
|
|
- Fix conflict of kf5-kio-doc with kdelibs4
|
|
|
|
* Mon Mar 31 2014 Jan Grulich <jgrulich@redhat.com> 4.98.0-1
|
|
- Update to KDE Frameworks 5 Beta 1 (4.98.0)
|
|
|
|
* Tue Mar 11 2014 Jan Grulich <jgrulich@redhat.com> 4.97.0-2
|
|
- remove public dependencies
|
|
|
|
* Wed Mar 05 2014 Jan Grulich <jgrulich@redhat.com> 4.97.0-1
|
|
- Update to KDE Frameworks 5 Alpha 1 (4.97.0)
|
|
|
|
* Wed Feb 12 2014 Daniel Vrátil <dvratil@redhat.com> 4.96.0-1
|
|
- Update to KDE Frameworks 5 Alpha 1 (4.96.0)
|
|
|
|
* Wed Feb 05 2014 Daniel Vrátil <dvratil@redhat.com> 4.96.0-0.1.20140205git
|
|
- Update to pre-relase snapshot of 4.96.0
|
|
|
|
* Mon Jan 20 2014 Daniel Vrátil <dvratil@redhat.com> 4.95.0-2
|
|
- rebuild against new kf5-filesystem
|
|
|
|
* Thu Jan 09 2014 Daniel Vrátil <dvratil@redhat.com> 4.95.0-1
|
|
- Update to KDE Frameworks 5 TP1 (4.95.0)
|
|
|
|
* Sat Jan 4 2014 Daniel Vrátil <dvratil@redhat.com>
|
|
- initial version
|
|
|