5.27.0
This commit is contained in:
parent
25b5dee0c4
commit
c83b8c29fe
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/kio-5.26.0.tar.xz
|
/kio-5.26.0.tar.xz
|
||||||
|
/kio-5.27.0.tar.xz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 44cc561b21301a855adb0ea909e1ad0ea0bb0ee9 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Christoph Cullmann <cullmann@kde.org>
|
|
||||||
Date: Wed, 7 Sep 2016 11:01:34 +0200
|
|
||||||
Subject: [PATCH 02/20] KMountPoint::probablySlow() => fixes for current NFS
|
|
||||||
version + FUSE mounts
|
|
||||||
|
|
||||||
CHANGELOG: classify fuse + nfs4 mounts as probablySlow, like nfs/cifs/...
|
|
||||||
|
|
||||||
REVIEW: 128788
|
|
||||||
---
|
|
||||||
src/core/kmountpoint.cpp | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/core/kmountpoint.cpp b/src/core/kmountpoint.cpp
|
|
||||||
index 69d4c8c..9d46868 100644
|
|
||||||
--- a/src/core/kmountpoint.cpp
|
|
||||||
+++ b/src/core/kmountpoint.cpp
|
|
||||||
@@ -535,9 +535,11 @@ KMountPoint::Ptr KMountPoint::List::findByDevice(const QString &device) const
|
|
||||||
bool KMountPoint::probablySlow() const
|
|
||||||
{
|
|
||||||
return d->mountType == QLatin1String("nfs")
|
|
||||||
+ || d->mountType == QLatin1String("nfs4")
|
|
||||||
|| d->mountType == QLatin1String("cifs")
|
|
||||||
|| d->mountType == QLatin1String("autofs")
|
|
||||||
- || d->mountType == QLatin1String("subfs");
|
|
||||||
+ || d->mountType == QLatin1String("subfs")
|
|
||||||
+ || d->mountType == QLatin1String("fuse");
|
|
||||||
}
|
|
||||||
|
|
||||||
bool KMountPoint::testFileSystemFlag(FileSystemFlag flag) const
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -1,30 +0,0 @@
|
|||||||
From d5224eef14c32e40265c6bd690662474717a69a5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Christoph Cullmann <cullmann@kde.org>
|
|
||||||
Date: Thu, 8 Sep 2016 13:42:47 +0200
|
|
||||||
Subject: [PATCH 04/20] KMountPoint::probablySlow() => fixes for current NFS
|
|
||||||
version and revert the dection of FUSE mounts
|
|
||||||
|
|
||||||
CHANGELOG: classify nfs4 mounts as probablySlow, like nfs/cifs/...
|
|
||||||
|
|
||||||
REVIEW: 128788
|
|
||||||
---
|
|
||||||
src/core/kmountpoint.cpp | 3 +--
|
|
||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/core/kmountpoint.cpp b/src/core/kmountpoint.cpp
|
|
||||||
index 9d46868..e87585f 100644
|
|
||||||
--- a/src/core/kmountpoint.cpp
|
|
||||||
+++ b/src/core/kmountpoint.cpp
|
|
||||||
@@ -538,8 +538,7 @@ bool KMountPoint::probablySlow() const
|
|
||||||
|| d->mountType == QLatin1String("nfs4")
|
|
||||||
|| d->mountType == QLatin1String("cifs")
|
|
||||||
|| d->mountType == QLatin1String("autofs")
|
|
||||||
- || d->mountType == QLatin1String("subfs")
|
|
||||||
- || d->mountType == QLatin1String("fuse");
|
|
||||||
+ || d->mountType == QLatin1String("subfs");
|
|
||||||
}
|
|
||||||
|
|
||||||
bool KMountPoint::testFileSystemFlag(FileSystemFlag flag) const
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -1,29 +0,0 @@
|
|||||||
From c784a879eaba0babc6274bc32e761772add3d4f8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Antonio Rojas <arojas@archlinux.org>
|
|
||||||
Date: Sun, 11 Sep 2016 00:14:56 +0200
|
|
||||||
Subject: [PATCH 09/20] Fix launching terminal .desktop files with konsole
|
|
||||||
|
|
||||||
Launching .desktop files which have Terminal=true currently fails, because kio adds to the konsole command the obsolete KDE4 command line options,
|
|
||||||
which are not recognized by the KF5 konsole.
|
|
||||||
|
|
||||||
REVIEW: 128882
|
|
||||||
---
|
|
||||||
src/core/desktopexecparser.cpp | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/core/desktopexecparser.cpp b/src/core/desktopexecparser.cpp
|
|
||||||
index c526da7..5162905 100644
|
|
||||||
--- a/src/core/desktopexecparser.cpp
|
|
||||||
+++ b/src/core/desktopexecparser.cpp
|
|
||||||
@@ -363,7 +363,7 @@ QStringList KIO::DesktopExecParser::resultingArguments() const
|
|
||||||
if (!d->service.path().isEmpty()) {
|
|
||||||
terminal += " --workdir " + KShell::quoteArg(d->service.path());
|
|
||||||
}
|
|
||||||
- terminal += QLatin1String(" -caption=%c %i %m");
|
|
||||||
+ terminal += QLatin1String(" -qwindowtitle '%c' %i");
|
|
||||||
}
|
|
||||||
terminal += ' ';
|
|
||||||
terminal += d->service.terminalOptions();
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
@ -1,29 +0,0 @@
|
|||||||
From 8196a735bebc6fd5eaf9d293bd565c00ef98516b Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Andrius=20=C5=A0tikonas?= <andrius@stikonas.eu>
|
|
||||||
Date: Mon, 26 Sep 2016 18:15:02 +0100
|
|
||||||
Subject: [PATCH 20/20] Fix kio using only tls1.0.
|
|
||||||
|
|
||||||
Now kio should use QSsl::SslProtocol::SecureProtocols which will deprecate
|
|
||||||
unsafe TLS versions when they are no longer safe.
|
|
||||||
|
|
||||||
REVIEW: 129031
|
|
||||||
---
|
|
||||||
src/core/tcpslavebase.cpp | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/core/tcpslavebase.cpp b/src/core/tcpslavebase.cpp
|
|
||||||
index b9be69d..27fe3d0 100644
|
|
||||||
--- a/src/core/tcpslavebase.cpp
|
|
||||||
+++ b/src/core/tcpslavebase.cpp
|
|
||||||
@@ -492,7 +492,7 @@ bool TCPSlaveBase::startSsl()
|
|
||||||
if (d->usingSSL) {
|
|
||||||
return false;
|
|
||||||
}
|
|
||||||
- return d->startTLSInternal(KTcpSocket::TlsV1) & ResultOk;
|
|
||||||
+ return d->startTLSInternal(KTcpSocket::SecureProtocols) & ResultOk;
|
|
||||||
}
|
|
||||||
|
|
||||||
TCPSlaveBase::SslResult TCPSlaveBase::TcpSlaveBasePrivate::startTLSInternal(KTcpSocket::SslVersion version,
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
13
kf5-kio.spec
13
kf5-kio.spec
@ -1,8 +1,8 @@
|
|||||||
%global framework kio
|
%global framework kio
|
||||||
|
|
||||||
Name: kf5-%{framework}
|
Name: kf5-%{framework}
|
||||||
Version: 5.26.0
|
Version: 5.27.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: KDE Frameworks 5 Tier 3 solution for filesystem abstraction
|
Summary: KDE Frameworks 5 Tier 3 solution for filesystem abstraction
|
||||||
|
|
||||||
License: GPLv2+ and MIT and BSD
|
License: GPLv2+ and MIT and BSD
|
||||||
@ -17,12 +17,6 @@ URL: https://quickgit.kde.org/?p=%{framework}.git
|
|||||||
%endif
|
%endif
|
||||||
Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz
|
Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz
|
||||||
|
|
||||||
## upstream patches
|
|
||||||
Patch2: 0002-KMountPoint-probablySlow-fixes-for-current-NFS-versi.patch
|
|
||||||
Patch4: 0004-KMountPoint-probablySlow-fixes-for-current-NFS-versi.patch
|
|
||||||
Patch9: 0009-Fix-launching-terminal-.desktop-files-with-konsole.patch
|
|
||||||
Patch20: 0020-Fix-kio-using-only-tls1.0.patch
|
|
||||||
|
|
||||||
BuildRequires: extra-cmake-modules >= %{version}
|
BuildRequires: extra-cmake-modules >= %{version}
|
||||||
BuildRequires: kf5-karchive-devel >= %{version}
|
BuildRequires: kf5-karchive-devel >= %{version}
|
||||||
BuildRequires: kf5-kbookmarks-devel >= %{version}
|
BuildRequires: kf5-kbookmarks-devel >= %{version}
|
||||||
@ -266,6 +260,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 04 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.27.0-1
|
||||||
|
- 5.27.0
|
||||||
|
|
||||||
* Fri Sep 30 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.26.0-3
|
* Fri Sep 30 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.26.0-3
|
||||||
- more upstream fixes (nfsv4 detection, ktcpsocket::secureprotocols)
|
- more upstream fixes (nfsv4 detection, ktcpsocket::secureprotocols)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user