2fc7312546
Backport the patches required to make the hardening build flags work with kexec-tools and makedumpfile, and enabld hardening flags in spec file. This will make the pacakge pass all warnings for kexec and makedumpfile reported by annocheck. Didn't find any issue with basic tests with kexec and makedumpfile. Signed-off-by: Kairui Song <kasong@redhat.com> Acked-by: Dave Young <dyoung@redhat.com>
35 lines
1.2 KiB
Diff
35 lines
1.2 KiB
Diff
From c493af72ac796e8ab3f3f4299205bd402dcee861 Mon Sep 17 00:00:00 2001
|
|
From: Kairui Song <kasong@redhat.com>
|
|
Date: Mon, 28 Jan 2019 18:50:40 +0800
|
|
Subject: [PATCH] purgatory: Use standalond CFLAGS
|
|
|
|
There has been a lot of workarounds for purgatory disabling many
|
|
specified CFLAGS that will break purgatory. It will be better to not
|
|
let the CFLAGS used to compile purgatory honor the CFLAGS from
|
|
environment variables. So we will have stable CFLAGS for purgatory.
|
|
|
|
If anyone still wants to change purgatory CFLAGS, PURGATORY_EXTRA_CFLAGS
|
|
is still honored.
|
|
|
|
Signed-off-by: Simon Horman <horms@verge.net.au>
|
|
---
|
|
purgatory/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/purgatory/Makefile b/purgatory/Makefile
|
|
index 49ce80a..2dd6c47 100644
|
|
--- a/purgatory/Makefile
|
|
+++ b/purgatory/Makefile
|
|
@@ -45,7 +45,7 @@ purgatory/sha256.o: $(srcdir)/util_lib/sha256.c
|
|
$(COMPILE.c) -o $@ $^
|
|
|
|
$(PURGATORY): CC=$(TARGET_CC)
|
|
-$(PURGATORY): CFLAGS+=$(PURGATORY_EXTRA_CFLAGS) \
|
|
+$(PURGATORY): CFLAGS=$(PURGATORY_EXTRA_CFLAGS) \
|
|
$($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
|
|
-Os -fno-builtin -ffreestanding \
|
|
-fno-zero-initialized-in-bss \
|
|
--
|
|
2.20.1
|
|
|