fixing up 390 build break
This commit is contained in:
parent
23e884a4b0
commit
8e13f5b5d3
20
kexec-tools-1.101-s390-fixup.patch
Normal file
20
kexec-tools-1.101-s390-fixup.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- kexec-tools-1.101/kexec/arch/s390/kexec-s390.c.orig 2006-07-05 16:01:46.000000000 -0400
|
||||
+++ kexec-tools-1.101/kexec/arch/s390/kexec-s390.c 2006-07-05 16:02:48.000000000 -0400
|
||||
@@ -36,7 +36,7 @@ static struct memory_range memory_range[
|
||||
* - (-1) if something went wrong.
|
||||
*/
|
||||
|
||||
-int get_memory_ranges(struct memory_range **range, int *ranges)
|
||||
+int get_memory_ranges(struct memory_range **range, int *ranges, unsigned long kexec_flags)
|
||||
{
|
||||
char sys_ram[] = "System RAM\n";
|
||||
char iomem[] = "/proc/iomem";
|
||||
@@ -94,7 +94,7 @@ int arch_process_options(int argc, char
|
||||
return 0;
|
||||
}
|
||||
|
||||
-int arch_compat_trampoline(struct kexec_info *info, unsigned long *flags)
|
||||
+int arch_compat_trampoline(struct kexec_info *info)
|
||||
{
|
||||
return 0;
|
||||
}
|
@ -1,6 +1,6 @@
|
||||
Name: kexec-tools
|
||||
Version: 1.101
|
||||
Release: 25%{dist}
|
||||
Release: 27%{dist}
|
||||
License: GPL
|
||||
Group: Applications/System
|
||||
Summary: The kexec/kdump userspace component.
|
||||
@ -31,6 +31,11 @@ Patch201: kexec-tools-1.101-ia64-fixup.patch
|
||||
#
|
||||
Patch301: kexec-ppc64-ingnore-args-linux.patch
|
||||
|
||||
#
|
||||
# Patches 401 through 500 are meant for s390 kexec-tools enablement
|
||||
#
|
||||
Patch401: http://intranet.corp.redhat.com/ic/intranet/JobBands.html
|
||||
|
||||
Patch501: kexec-tools-1.101-Makefile.patch
|
||||
|
||||
%description
|
||||
@ -47,6 +52,7 @@ rm -f ../kexec-tools-1.101.spec
|
||||
%patch101 -p1
|
||||
%patch201 -p1
|
||||
%patch301 -p1
|
||||
%patch401 -p1
|
||||
%patch501 -p1
|
||||
|
||||
cp $RPM_SOURCE_DIR/kdump.init .
|
||||
@ -97,7 +103,7 @@ exit 0
|
||||
%doc TODO
|
||||
|
||||
%changelog
|
||||
* Wed Jul 07 2006 Neil Horman <nhorman@redhat.com> 1.101-22.fc6
|
||||
* Wed Jul 07 2006 Neil Horman <nhorman@redhat.com> 1.101-27.fc6
|
||||
- Modify spec/sysconfig to not autobuild kdump kernel command line
|
||||
- Add dist to revision tag
|
||||
- Build for all arches
|
||||
|
Loading…
Reference in New Issue
Block a user