4f60176946
- Build perf with unwind support via libdw (rhbz 1025603)
16 lines
368 B
Diff
16 lines
368 B
Diff
diff --git a/tools/perf/config/Makefile b/tools/perf/config/Makefile
|
|
index ee21fa9..19ee413 100644
|
|
--- a/tools/perf/config/Makefile
|
|
+++ b/tools/perf/config/Makefile
|
|
@@ -34,6 +34,10 @@ ifeq ($(ARCH),arm)
|
|
LIBUNWIND_LIBS = -lunwind -lunwind-arm
|
|
endif
|
|
|
|
+ifneq ($(ARCH),x86)
|
|
+ NO_LIBDW_DWARF_UNWIND := 1
|
|
+endif
|
|
+
|
|
ifeq ($(LIBUNWIND_LIBS),)
|
|
NO_LIBUNWIND := 1
|
|
else
|