828 lines
14 KiB
Diff
828 lines
14 KiB
Diff
From 9661f78d01913a1dbdc2099966d858b62dff5b14 Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <uwu@icenowy.me>
|
|
Date: Wed, 20 Nov 2024 21:26:37 +0800
|
|
Subject: [PATCH 233/416] riscv: dts: eswin: add Pine64 StarPro64
|
|
|
|
Signed-off-by: Icenowy Zheng <uwu@icenowy.me>
|
|
---
|
|
arch/riscv/boot/dts/eswin/Makefile | 1 +
|
|
.../dts/eswin/eic7700-pine64-starpro64.dts | 794 ++++++++++++++++++
|
|
2 files changed, 795 insertions(+)
|
|
create mode 100644 arch/riscv/boot/dts/eswin/eic7700-pine64-starpro64.dts
|
|
|
|
diff --git a/arch/riscv/boot/dts/eswin/Makefile b/arch/riscv/boot/dts/eswin/Makefile
|
|
index 5e0aadfd548d..8c431bb594ea 100644
|
|
--- a/arch/riscv/boot/dts/eswin/Makefile
|
|
+++ b/arch/riscv/boot/dts/eswin/Makefile
|
|
@@ -4,6 +4,7 @@ dtb-$(CONFIG_SOC_SIFIVE) += eswin-win2030.dtb \
|
|
eic7700-evb-a2.dtb \
|
|
eic7700-hifive-premier-p550.dtb \
|
|
eic7700-milkv-megrez.dtb \
|
|
+ eic7700-pine64-starpro64.dtb \
|
|
eic7702-evb-a1-d0.dtb \
|
|
eic7702-evb-a1-d1.dtb
|
|
|
|
diff --git a/arch/riscv/boot/dts/eswin/eic7700-pine64-starpro64.dts b/arch/riscv/boot/dts/eswin/eic7700-pine64-starpro64.dts
|
|
new file mode 100644
|
|
index 000000000000..b7a599878685
|
|
--- /dev/null
|
|
+++ b/arch/riscv/boot/dts/eswin/eic7700-pine64-starpro64.dts
|
|
@@ -0,0 +1,794 @@
|
|
+// SPDX-License-Identifier: GPL-2.0
|
|
+/*
|
|
+ * Copyright 2024, Beijing ESWIN Computing Technology Co., Ltd.. All rights reserved.
|
|
+ * Copyright 2024 Icenowy Zheng <uwu@icenowy.me>
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#define RTCCLK_FREQ 1000000
|
|
+#define LSPCLK_FREQ 200000000
|
|
+
|
|
+/* If wanna enable ECC capability of DDR, should reserve highest zone of 1/8 all space for it */
|
|
+#define MEMORY_SIZE_H 0x4
|
|
+#define MEMORY_SIZE_L 0x0
|
|
+#define CMA_SIZE 0x20000000
|
|
+
|
|
+#include "eswin-win2030-die0-soc.dtsi"
|
|
+#include "eic7700-pinctrl.dtsi"
|
|
+#include <dt-bindings/interrupt-controller/irq.h>
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+#include <dt-bindings/input/input.h>
|
|
+#include <dt-bindings/leds/common.h>
|
|
+
|
|
+/* Clock frequency (in Hz) of the PCB crystal for rtcclk */
|
|
+
|
|
+/ {
|
|
+ #address-cells = <2>;
|
|
+ #size-cells = <2>;
|
|
+ model = "Pine64 StarPro64";
|
|
+ /* TODO: use appropriate compatible strings */
|
|
+ compatible = "sifive,hifive-unmatched-a00", "sifive,fu740-c000",
|
|
+ "sifive,fu740", "eswin,eic7700";
|
|
+
|
|
+ aliases {
|
|
+ serial0 = &d0_uart0;
|
|
+ ethernet0 = &d0_gmac0;
|
|
+ ethernet1 = &d0_gmac1;
|
|
+ rtc0 = &die0_rtc;
|
|
+ rtc1 = &pcf_rtc;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ opensbi_domain_config: domain-config {
|
|
+ compatible = "opensbi,domain,config";
|
|
+ system-suspend-test;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ cpus {
|
|
+ timebase-frequency = <RTCCLK_FREQ>;
|
|
+ };
|
|
+
|
|
+ memory@59000000 {
|
|
+ device_type = "memory";
|
|
+ reg = <0x0 0x59000000 0x0 0x400000>;
|
|
+ numa-node-id = <0>;
|
|
+ };
|
|
+
|
|
+ memory@80000000 {
|
|
+ device_type = "memory";
|
|
+ reg = <0x0 0x80000000 MEMORY_SIZE_H MEMORY_SIZE_L>;
|
|
+ numa-node-id = <0>;
|
|
+ };
|
|
+
|
|
+ reserved-memory {
|
|
+ #address-cells = <2>;
|
|
+ #size-cells = <2>;
|
|
+ ranges;
|
|
+
|
|
+ linux,cma {
|
|
+ compatible = "shared-dma-pool";
|
|
+ reusable;
|
|
+ size = <0x0 CMA_SIZE>;
|
|
+ alignment = <0x0 0x1000>;
|
|
+ alloc-ranges = <0x0 0x80000000 MEMORY_SIZE_H MEMORY_SIZE_L>;
|
|
+ linux,cma-default;
|
|
+ };
|
|
+
|
|
+ npu0_reserved: sprammemory@59000000 {
|
|
+ no-map;
|
|
+ reg = <0x0 0x59000000 0x0 0x400000>;
|
|
+ };
|
|
+
|
|
+ g2d_4GB_boundary_reserved_4k {
|
|
+ no-map;
|
|
+ reg = <0x0 0xfffff000 0x0 0x1000>;
|
|
+ };
|
|
+
|
|
+ g2d_8GB_boundary_reserved_4k {
|
|
+ no-map;
|
|
+ reg = <0x1 0xfffff000 0x0 0x1000>;
|
|
+ };
|
|
+
|
|
+ g2d_12GB_boundary_reserved_4k {
|
|
+ no-map;
|
|
+ reg = <0x2 0xfffff000 0x0 0x1000>;
|
|
+ };
|
|
+
|
|
+ mmz_nid_0_part_0 {
|
|
+ compatible = "eswin-reserve-memory";
|
|
+ reg = <0x3 0x0 0x1 0x80000000>;
|
|
+ no-map;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pinctrl_gpio27_default &pinctrl_gpio62_default>;
|
|
+
|
|
+ power {
|
|
+ gpios = <&portb 30 GPIO_ACTIVE_HIGH>;
|
|
+ function = LED_FUNCTION_POWER;
|
|
+ color = <LED_COLOR_ID_WHITE>;
|
|
+ linux,default-trigger = "default-on";
|
|
+ };
|
|
+
|
|
+ status {
|
|
+ gpios = <&porta 27 GPIO_ACTIVE_HIGH>;
|
|
+ function = LED_FUNCTION_STATUS;
|
|
+ color = <LED_COLOR_ID_RED>;
|
|
+ linux,default-trigger = "heartbeat";
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&d0_clock {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_reset {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_pmu {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ddr0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ddr1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&smmu0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&smmu_pmu0 {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&dev_foo_a {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_cfg_noc {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_llc_noc {
|
|
+ status = "okay";
|
|
+ stat,0 = "TracePort:ddr0_p0_req";
|
|
+ stat,1 = "TracePort:ddr1_p0_req";
|
|
+ //latency,0 = "TracePort:llcnoc_trans_probe";
|
|
+ //pending,0 = "TracePort:llcnoc_trans_probe";
|
|
+};
|
|
+
|
|
+&d0_sys_noc {
|
|
+ status = "okay";
|
|
+
|
|
+ //eswin,DSPT-qos-owner;
|
|
+ //eswin,NPU-qos-owner;
|
|
+ //eswin,SPISLV_TBU3-qos-owner;
|
|
+
|
|
+ stat,0 = "TracePort:ddr0_p1_req",
|
|
+ "InitFlow:mcput_snoc_mp/I/0";
|
|
+
|
|
+ stat,1 = "TracePort:ddr0_p2_req",
|
|
+ "InitFlow:dspt_snoc/I/0",
|
|
+ "AddrBase:0x81000000", "AddrSize:0x30",
|
|
+ "Opcode:RdWrLockUrg", "Status:ReqRsp", "Length:0x8000", "Urgency:0x0";
|
|
+
|
|
+ stat,2 = "TracePort:ddr1_p1_req",
|
|
+ "Status:Req", "AddrSize:0x28";
|
|
+
|
|
+ stat,3 = "TracePort:ddr1_p2_req";
|
|
+
|
|
+ latency,0 = "TracePort:sysnoc_trans_probe_0", "AddrSize:0x0";
|
|
+ latency,1 = "TracePort:sysnoc_trans_probe_1","Mode:latency","AddrBase:0x82000000","AddrSize:0x28","Opcode:RdWr";
|
|
+ //latency,2 = "TracePort:sysnoc_trans_probe_2";
|
|
+
|
|
+ //pending,0 = "TracePort:sysnoc_trans_probe_0";
|
|
+ //pending,1 = "TracePort:sysnoc_trans_probe_1","Mode:latency","AddrBase:0x82000000","AddrSize:0x0","Opcode:RdWr";
|
|
+ pending,0 = "TracePort:sysnoc_trans_probe_2", "AddrSize:0x3";
|
|
+};
|
|
+
|
|
+&d0_media_noc {
|
|
+ status = "okay";
|
|
+
|
|
+ //eswin,GPU-qos-owner;
|
|
+ //eswin,TBU2-qos-owner;
|
|
+ //eswin,VC-qos-owner;
|
|
+
|
|
+ stat,0 = "TracePort:ddr0_p3_req";
|
|
+ stat,1 = "TracePort:ddr1_p3_req";
|
|
+ //latency,0 = "TracePort:mnoc_trans_probe";
|
|
+ //pending,0 = "TracePort:mnoc_trans_probe";
|
|
+};
|
|
+
|
|
+&d0_realtime_noc {
|
|
+ status = "okay";
|
|
+
|
|
+ //eswin,TBU0-qos-owner;
|
|
+ //eswin,VO-qos-owner;
|
|
+
|
|
+ stat,0 = "TracePort:ddr0_p4_req";
|
|
+ stat,1 = "TracePort:ddr1_p4_req";
|
|
+ //latency,0 = "TracePort:rnoc_trans_probe";
|
|
+ //pending,0 = "TracePort:rnoc_trans_probe";
|
|
+};
|
|
+
|
|
+&d0_noc_wdt {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_ipc_scpu {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_lpcpu {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&pcie {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_npu{
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_dsp_subsys {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_dsp0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_dsp1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_dsp2 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_dsp3 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&gpu0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&gc820 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&vdec0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&venc0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&video_output {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&dc {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&dc_test {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&virtual_display {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&dsi_output {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&dsi_controller {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&dsi_panel {
|
|
+ status = "disabled";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pinctrl_gpio5_default &pinctrl_gpio111_default>;
|
|
+ backlight0-gpios = <&porta 5 GPIO_ACTIVE_HIGH>;
|
|
+ rst-gpios = <&portd 15 GPIO_ACTIVE_HIGH>;
|
|
+};
|
|
+
|
|
+&dw_hdmi {
|
|
+ status = "okay";
|
|
+ ports {
|
|
+ port@2 {
|
|
+ reg = <2>;
|
|
+ hdmi_in_i2s: endpoint@1 {
|
|
+ system-clock-frequency = <12288000>;
|
|
+ remote-endpoint = <&d0_i2s0_endpoint>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&dw_hdmi_hdcp2 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_i2s0 {
|
|
+ status = "okay";
|
|
+ d0_i2s0_port: port {
|
|
+ d0_i2s0_endpoint: endpoint {
|
|
+ remote-endpoint = <&hdmi_in_i2s>;
|
|
+ dai-format = "i2s";
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&d0_i2s1 {
|
|
+ status = "okay";
|
|
+ d0_i2s1_port: port {
|
|
+ d0_i2s1_endpoint: endpoint {
|
|
+ remote-endpoint = <&d0_codec0_endpoint>;
|
|
+ dai-format = "i2s";
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&d0_i2s2 {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_graphcard0 {
|
|
+ status = "okay";
|
|
+ label = "Analog Audio-0";
|
|
+ dais = <&d0_i2s1_port>;
|
|
+};
|
|
+
|
|
+&d0_graphcard1 {
|
|
+ status = "okay";
|
|
+ label = "HDMI Audio";
|
|
+ dais = <&d0_i2s0_port>;
|
|
+};
|
|
+
|
|
+&d0_graphcard2 {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&isp_0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&isp_1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&dewarp {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mipi_dphy_rx {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&csi_dma0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&csi_dma1 {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&csi2_0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&csi2_1 {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&sdhci_emmc {
|
|
+ /* emmc */
|
|
+ status = "okay";
|
|
+ delay_code = <0x17>;
|
|
+ drive-impedance-ohm = <50>;
|
|
+ enable-cmd-pullup;
|
|
+ enable-data-pullup;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pinctrl_emmc_led_control_default>;
|
|
+ no-sdio;
|
|
+ no-sd;
|
|
+};
|
|
+
|
|
+&sdio0 {
|
|
+ /* sd card */
|
|
+ status = "okay";
|
|
+ delay_code = <0x55>;
|
|
+ drive-impedance-ohm = <33>;
|
|
+ enable-cmd-pullup;
|
|
+ enable-data-pullup;
|
|
+ no-sdio;
|
|
+ no-mmc;
|
|
+ disable-wp;
|
|
+};
|
|
+
|
|
+&sdio1 {
|
|
+ /* wifi module */
|
|
+ status = "okay";
|
|
+ delay_code = <0x29>;
|
|
+ drive-impedance-ohm = <33>;
|
|
+ enable-cmd-pullup;
|
|
+ enable-data-pullup;
|
|
+ keep-power-in-suspend;
|
|
+ non-removable;
|
|
+ no-sd;
|
|
+ no-mmc;
|
|
+};
|
|
+
|
|
+&d0_gmac0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pinctrl_gpio94_default>;
|
|
+ rst-gpios = <&portc 30 GPIO_ACTIVE_LOW>;
|
|
+ eswin,rgmiisel = <&pinctrl 0x290 0x3>;
|
|
+ eswin,led-cfgs = <0x6100 0xa40 0x420>;
|
|
+
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_gmac1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pinctrl_gpio16_default>;
|
|
+ rst-gpios = <&porta 16 GPIO_ACTIVE_LOW>;
|
|
+ eswin,rgmiisel = <&pinctrl 0x294 0x3>;
|
|
+ eswin,led-cfgs = <0x6100 0xa40 0x420>;
|
|
+
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_sata {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_usbdrd3_0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_usbdrd_dwc3_0 {
|
|
+ status = "okay";
|
|
+ dr_mode = "host";
|
|
+ maximum-speed = "super-speed";
|
|
+};
|
|
+
|
|
+&d0_usbdrd3_1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_usbdrd_dwc3_1 {
|
|
+ status = "okay";
|
|
+ dr_mode = "host";
|
|
+ maximum-speed = "super-speed";
|
|
+};
|
|
+
|
|
+&d0_dmac0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_aon_dmac {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_uart0 {
|
|
+ /* debug */
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_uart1 {
|
|
+ /* BT M.2 KEY-E */
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_uart2 {
|
|
+ /* RS232 DB9 */
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_uart3 {
|
|
+ /* unused */
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_uart4 {
|
|
+ /* unused */
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&ssi0 {
|
|
+ /* spi flash */
|
|
+ status = "okay";
|
|
+ num-cs = <2>;
|
|
+ spi-flash@0 {
|
|
+ compatible = "winbond,w25q128fw",
|
|
+ "jedec,spi-nor";
|
|
+ reg = <0>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ spi-max-frequency = <4800000>;
|
|
+ rx-sample-delay-ns = <10>;
|
|
+ };
|
|
+ spi-flash@1 {
|
|
+ compatible = "winbond,w25q128fw",
|
|
+ "jedec,spi-nor";
|
|
+ reg = <1>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ spi-max-frequency = <4800000>;
|
|
+ rx-sample-delay-ns = <10>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ssi1 {
|
|
+ /* spi flash */
|
|
+ status = "disabled";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pinctrl_spi2_default>;
|
|
+ num-cs = <2>;
|
|
+ spi-flash@0 {
|
|
+ compatible = "winbond,w25q128fw",
|
|
+ "jedec,spi-nor";
|
|
+ reg = <0>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ spi-max-frequency = <4800000>;
|
|
+ rx-sample-delay-ns = <10>;
|
|
+ };
|
|
+ spi-flash@1 {
|
|
+ compatible = "winbond,w25q128fw",
|
|
+ "jedec,spi-nor";
|
|
+ reg = <1>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ spi-max-frequency = <4800000>;
|
|
+ rx-sample-delay-ns = <10>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&bootspi {
|
|
+ /* spi flash */
|
|
+ status = "okay";
|
|
+ num-cs = <1>;
|
|
+ cs-gpios = <&portd 0 GPIO_ACTIVE_LOW>;
|
|
+ wp-gpios = <&portd 4 GPIO_ACTIVE_LOW>;
|
|
+ spi-flash@0 {
|
|
+ compatible = "winbond,w25q128jw",
|
|
+ "jedec,spi-nor";
|
|
+ reg = <0>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <1>;
|
|
+ spi-max-frequency = <4800000>;
|
|
+ rx-sample-delay-ns = <10>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&d0_mbox0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_mbox1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_mbox2 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_mbox3 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_mbox4 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_mbox5 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_mbox6 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_mbox7 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&fan_control {
|
|
+ status = "okay";
|
|
+ eswin,pwm_inverted;
|
|
+};
|
|
+
|
|
+&d0_i2c0 {
|
|
+ /* codec es8388 */
|
|
+ status = "okay";
|
|
+ d0_es8388_0: es8388-0@10 {
|
|
+ compatible = "eswin,es8388";
|
|
+ reg = <0x10>;
|
|
+ #sound-dai-cells = <0>;
|
|
+ port {
|
|
+ d0_codec0_endpoint: endpoint {
|
|
+ system-clock-frequency = <12288000>;
|
|
+ remote-endpoint = <&d0_i2s1_endpoint>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&d0_i2c1 {
|
|
+ /* mpq8785 */
|
|
+ status = "okay";
|
|
+ mpq8785@10 {
|
|
+ compatible = "mps,mpq8785";
|
|
+ reg = <0x10>;
|
|
+ eswin,regulator_default-microvolt=<1000000>;
|
|
+ eswin,regulator_label = "supply vdd1", "npu vdd1", "npu current1", "npu temperature1";
|
|
+ label = "npu_vdd";
|
|
+ regulators{
|
|
+ npu_vcc1:npu_svcc{
|
|
+ regulator-name="NPU_SVCC";
|
|
+ regulator-min-microvolt=<700000>;
|
|
+ regulator-max-microvolt=<1100000>;
|
|
+ regulator-min-microamp=<20000000>;
|
|
+ regulator-max-microamp=<40000000>;
|
|
+ regulator-ov-protection-microvolt=<1100000>;
|
|
+ regulator-always-on;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&d0_i2c2 {
|
|
+ /* mipi dsi */
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_i2c3 {
|
|
+ /* mipi csi0/csi1 */
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&d0_i2c4 {
|
|
+ /* mipi csi2/csi3 */
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_i2c5 {
|
|
+ /* mipi csi4/csi5 */
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_i2c6 {
|
|
+ /* unused */
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_i2c7 {
|
|
+ /* unused */
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_i2c8 {
|
|
+ /* unused */
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_i2c9 {
|
|
+ /* unused */
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&d0_aon_i2c0 {
|
|
+ /* temp sensor & rtc */
|
|
+ status = "okay";
|
|
+ eswin,syscfg = <&d0_sys_con 0x3C0 16>;
|
|
+ pcf_rtc:rtc@51 {
|
|
+ compatible = "nxp,pcf8563";
|
|
+ reg = <0x51>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&pwm0 {
|
|
+ /* fan */
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&pvt0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&pvt1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&wdt0 {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&wdt1 {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&wdt2 {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&wdt3 {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&die0_rtc {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&timer0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&timer1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&timer2 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&timer3 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&pinctrl {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+/* GPIO Function Description
|
|
+
|
|
+ gpio0 : pcie prstn(I)
|
|
+ gpio6 : system key(broken now)(I)
|
|
+ gpio10 : dsi touch interrupt(I)
|
|
+ gpio11 : host wake wlan(O)
|
|
+ gpio12 : tf card power on/off(O)
|
|
+ gpio14 : bt wake host(I)
|
|
+ gpio15 : wlan wake host(I)
|
|
+ gpio16 : gphy1 resetn(O)
|
|
+ gpio27 : status LED(originally SATA LED, SATA not used)(O)
|
|
+ gpio28 : head phone plug/unplug detection1(I)
|
|
+ gpio62 : power LED(O)
|
|
+ gpio94 : gphy0 resetn(O)
|
|
+ gpio106 : touch reset(O)
|
|
+*/
|
|
+
|
|
+&gpio0 {
|
|
+ status = "okay";
|
|
+};
|
|
+&dev_llc_d0{
|
|
+ apply_npu_high_freq;
|
|
+};
|
|
+
|
|
+&d0_cpu_opp_table {
|
|
+ opp-1600000000 {
|
|
+ opp-hz = /bits/ 64 <CLK_FREQ_1600M>;
|
|
+ opp-microvolt = <900000>;
|
|
+ clock-latency-ns = <70000>;
|
|
+ };
|
|
+};
|
|
--
|
|
2.47.0
|
|
|