74 lines
2.6 KiB
Diff
74 lines
2.6 KiB
Diff
From 36be6e2f197b4abaf0e7c4fe2f525eb56b3f0298 Mon Sep 17 00:00:00 2001
|
|
From: Laura Abbott <labbott@redhat.com>
|
|
Date: Fri, 6 Jul 2018 17:21:01 -0700
|
|
Subject: [PATCHv2 7/7] Kbuild: Use HOST*FLAGS options from the command line
|
|
To: Masahiro Yamada <yamada.masahiro@socionext.com>
|
|
To: Josh Poimboeuf <jpoimboe@redhat.com>
|
|
To: Jiri Olsa <jolsa@kernel.org>
|
|
Cc: linux-kbuild@vger.kernel.org
|
|
Cc: linux-kernel@vger.kernel.org
|
|
Cc: Robin Jarry <robin.jarry@6wind.com>
|
|
Cc: Jonathan Corbet <corbet@lwn.net>
|
|
Cc: linux-doc@vger.kernel.org
|
|
|
|
|
|
Now that we have the rename in place, reuse the HOST*FLAGS options as
|
|
something that can be set from the command line and included with the
|
|
rest of the flags.
|
|
|
|
Signed-off-by: Laura Abbott <labbott@redhat.com>
|
|
---
|
|
v2: Use the correct name for HOSTLDLIBS, update documentation.
|
|
---
|
|
Documentation/kbuild/kbuild.txt | 16 ++++++++++++++++
|
|
Makefile | 9 +++++----
|
|
2 files changed, 21 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/Documentation/kbuild/kbuild.txt b/Documentation/kbuild/kbuild.txt
|
|
index 6c9c69ec3986..9847a5974826 100644
|
|
--- a/Documentation/kbuild/kbuild.txt
|
|
+++ b/Documentation/kbuild/kbuild.txt
|
|
@@ -238,3 +238,19 @@ KBUILD_VMLINUX_LIBS
|
|
All .a "lib" files for vmlinux.
|
|
KBUILD_VMLINUX_INIT, KBUILD_VMLINUX_MAIN, and KBUILD_VMLINUX_LIBS together
|
|
specify all the object files used to link vmlinux.
|
|
+
|
|
+HOSTCFLAGS
|
|
+--------------------------------------------------
|
|
+Additional flags to be passed to $(HOSTCC) when building host programs.
|
|
+
|
|
+HOSTLDFLAGS
|
|
+--------------------------------------------------
|
|
+Additional flags to be passed to $(HOSTLD) when building host programs.
|
|
+
|
|
+HOSTCXXFLAGS
|
|
+--------------------------------------------------
|
|
+Additional flags to be passed to $(HOSTCXX) when building host programs.
|
|
+
|
|
+HOSTLDLIBS
|
|
+--------------------------------------------------
|
|
+Additional libraries to link against when building host programs.
|
|
diff --git a/Makefile b/Makefile
|
|
index 96e34381d9ee..c2ee1d4c12c9 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -360,10 +360,11 @@ HOST_LFS_LIBS := $(shell getconf LFS_LIBS)
|
|
HOSTCC = gcc
|
|
HOSTCXX = g++
|
|
KBUILD_HOSTCFLAGS := -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 \
|
|
- -fomit-frame-pointer -std=gnu89 $(HOST_LFS_CFLAGS)
|
|
-KBUILD_HOSTCXXFLAGS := -O2 $(HOST_LFS_CFLAGS)
|
|
-KBUILD_HOSTLDFLAGS := $(HOST_LFS_LDFLAGS)
|
|
-KBUILD_HOSTLDLIBS := $(HOST_LFS_LIBS)
|
|
+ -fomit-frame-pointer -std=gnu89 $(HOST_LFS_CFLAGS) \
|
|
+ $(HOSTCFLAGS)
|
|
+KBUILD_HOSTCXXFLAGS := -O2 $(HOST_LFS_CFLAGS) $(HOSTCXXFLAGS)
|
|
+KBUILD_HOSTLDFLAGS := $(HOST_LFS_LDFLAGS) $(HOSTLDFLAGS)
|
|
+KBUILD_HOSTLDLIBS := $(HOST_LFS_LIBS) $(HOSTLDLIBS)
|
|
|
|
# Make variables (CC, etc...)
|
|
AS = $(CROSS_COMPILE)as
|
|
--
|
|
2.17.1
|
|
|