8803f4784b
This reverts commit feae0be2a7
.
561 lines
17 KiB
Diff
561 lines
17 KiB
Diff
From patchwork Sat Apr 21 11:28:34 2018
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [V2,1/9] ARM: dts: bcm283x: Fix PWM pin assignment
|
|
From: Stefan Wahren <stefan.wahren@i2se.com>
|
|
X-Patchwork-Id: 10354085
|
|
Message-Id: <1524310122-9439-2-git-send-email-stefan.wahren@i2se.com>
|
|
To: Rob Herring <robh+dt@kernel.org>, Mark Rutland <mark.rutland@arm.com>,
|
|
Eric Anholt <eric@anholt.net>, Catalin Marinas <catalin.marinas@arm.com>,
|
|
Will Deacon <will.deacon@arm.com>
|
|
Cc: Stefan Wahren <stefan.wahren@i2se.com>, devicetree@vger.kernel.org,
|
|
Florian Fainelli <f.fainelli@gmail.com>, Arnd Bergmann <arnd@arndb.de>,
|
|
Scott Branden <sbranden@broadcom.com>, Ray Jui <rjui@broadcom.com>,
|
|
Phil Elwell <phil@raspberrypi.org>, Alexander Graf <agraf@suse.de>,
|
|
bcm-kernel-feedback-list@broadcom.com,
|
|
linux-rpi-kernel@lists.infradead.org, linux-arm-kernel@lists.infradead.org
|
|
Date: Sat, 21 Apr 2018 13:28:34 +0200
|
|
|
|
All RPi 1 and 2 boards used the PWM (audio out) on pin 40 and 45.
|
|
So it was easy to define them in bcm2835-rpi.dtsi. Starting with RPi 3
|
|
this wont work anymore, because it uses pin 40 and 41. Furthermore the
|
|
Zero variants doesn't have audio out.
|
|
|
|
This patch fixes this pin conflict by moving the PWM node to the board-level.
|
|
|
|
Change summary:
|
|
RPi 3 B: PWM1 45 -> 41
|
|
Zero, Zero W: PWM disabled
|
|
all other: no functional change
|
|
|
|
Reported-by: Baruch Siach <baruch@tkos.co.il>
|
|
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
|
|
Reviewed-by: Eric Anholt <eric@anholt.net>
|
|
---
|
|
arch/arm/boot/dts/bcm2835-rpi-a-plus.dts | 6 ++++++
|
|
arch/arm/boot/dts/bcm2835-rpi-a.dts | 6 ++++++
|
|
arch/arm/boot/dts/bcm2835-rpi-b-plus.dts | 6 ++++++
|
|
arch/arm/boot/dts/bcm2835-rpi-b-rev2.dts | 6 ++++++
|
|
arch/arm/boot/dts/bcm2835-rpi-b.dts | 6 ++++++
|
|
arch/arm/boot/dts/bcm2835-rpi.dtsi | 6 ------
|
|
arch/arm/boot/dts/bcm2836-rpi-2-b.dts | 6 ++++++
|
|
arch/arm/boot/dts/bcm2837-rpi-3-b.dts | 6 ++++++
|
|
8 files changed, 42 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/arch/arm/boot/dts/bcm2835-rpi-a-plus.dts b/arch/arm/boot/dts/bcm2835-rpi-a-plus.dts
|
|
index aa1fc7b..2cd9c5e 100644
|
|
--- a/arch/arm/boot/dts/bcm2835-rpi-a-plus.dts
|
|
+++ b/arch/arm/boot/dts/bcm2835-rpi-a-plus.dts
|
|
@@ -101,6 +101,12 @@
|
|
hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
|
|
};
|
|
|
|
+&pwm {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio45>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart0_gpio14>;
|
|
diff --git a/arch/arm/boot/dts/bcm2835-rpi-a.dts b/arch/arm/boot/dts/bcm2835-rpi-a.dts
|
|
index 425f6b0..067d1f0 100644
|
|
--- a/arch/arm/boot/dts/bcm2835-rpi-a.dts
|
|
+++ b/arch/arm/boot/dts/bcm2835-rpi-a.dts
|
|
@@ -96,6 +96,12 @@
|
|
hpd-gpios = <&gpio 46 GPIO_ACTIVE_HIGH>;
|
|
};
|
|
|
|
+&pwm {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio45>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart0_gpio14>;
|
|
diff --git a/arch/arm/boot/dts/bcm2835-rpi-b-plus.dts b/arch/arm/boot/dts/bcm2835-rpi-b-plus.dts
|
|
index effa195..cfbdaac 100644
|
|
--- a/arch/arm/boot/dts/bcm2835-rpi-b-plus.dts
|
|
+++ b/arch/arm/boot/dts/bcm2835-rpi-b-plus.dts
|
|
@@ -103,6 +103,12 @@
|
|
hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
|
|
};
|
|
|
|
+&pwm {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio45>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart0_gpio14>;
|
|
diff --git a/arch/arm/boot/dts/bcm2835-rpi-b-rev2.dts b/arch/arm/boot/dts/bcm2835-rpi-b-rev2.dts
|
|
index 772ec3b..5641d16 100644
|
|
--- a/arch/arm/boot/dts/bcm2835-rpi-b-rev2.dts
|
|
+++ b/arch/arm/boot/dts/bcm2835-rpi-b-rev2.dts
|
|
@@ -96,6 +96,12 @@
|
|
hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
|
|
};
|
|
|
|
+&pwm {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio45>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart0_gpio14>;
|
|
diff --git a/arch/arm/boot/dts/bcm2835-rpi-b.dts b/arch/arm/boot/dts/bcm2835-rpi-b.dts
|
|
index 434483d..31ff602 100644
|
|
--- a/arch/arm/boot/dts/bcm2835-rpi-b.dts
|
|
+++ b/arch/arm/boot/dts/bcm2835-rpi-b.dts
|
|
@@ -91,6 +91,12 @@
|
|
hpd-gpios = <&gpio 46 GPIO_ACTIVE_HIGH>;
|
|
};
|
|
|
|
+&pwm {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio45>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart0_gpio14>;
|
|
diff --git a/arch/arm/boot/dts/bcm2835-rpi.dtsi b/arch/arm/boot/dts/bcm2835-rpi.dtsi
|
|
index 6c3cfaa..cb2d6d7 100644
|
|
--- a/arch/arm/boot/dts/bcm2835-rpi.dtsi
|
|
+++ b/arch/arm/boot/dts/bcm2835-rpi.dtsi
|
|
@@ -83,12 +83,6 @@
|
|
bus-width = <4>;
|
|
};
|
|
|
|
-&pwm {
|
|
- pinctrl-names = "default";
|
|
- pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio45>;
|
|
- status = "okay";
|
|
-};
|
|
-
|
|
&usb {
|
|
power-domains = <&power RPI_POWER_DOMAIN_USB>;
|
|
};
|
|
diff --git a/arch/arm/boot/dts/bcm2836-rpi-2-b.dts b/arch/arm/boot/dts/bcm2836-rpi-2-b.dts
|
|
index 5c339ad..2fef70a 100644
|
|
--- a/arch/arm/boot/dts/bcm2836-rpi-2-b.dts
|
|
+++ b/arch/arm/boot/dts/bcm2836-rpi-2-b.dts
|
|
@@ -41,6 +41,12 @@
|
|
hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
|
|
};
|
|
|
|
+&pwm {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio45>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart0_gpio14>;
|
|
diff --git a/arch/arm/boot/dts/bcm2837-rpi-3-b.dts b/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
|
|
index 0b31d99..cc39b6f 100644
|
|
--- a/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
|
|
+++ b/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
|
|
@@ -42,6 +42,12 @@
|
|
};
|
|
};
|
|
|
|
+&pwm {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio41>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
/* uart0 communicates with the BT module */
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
From patchwork Sat Apr 21 11:28:35 2018
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [V2,2/9] ARM: dts: bcm2837: Add missing GPIOs of Expander
|
|
From: Stefan Wahren <stefan.wahren@i2se.com>
|
|
X-Patchwork-Id: 10354079
|
|
Message-Id: <1524310122-9439-3-git-send-email-stefan.wahren@i2se.com>
|
|
To: Rob Herring <robh+dt@kernel.org>, Mark Rutland <mark.rutland@arm.com>,
|
|
Eric Anholt <eric@anholt.net>, Catalin Marinas <catalin.marinas@arm.com>,
|
|
Will Deacon <will.deacon@arm.com>
|
|
Cc: Stefan Wahren <stefan.wahren@i2se.com>, devicetree@vger.kernel.org,
|
|
Florian Fainelli <f.fainelli@gmail.com>, Arnd Bergmann <arnd@arndb.de>,
|
|
Scott Branden <sbranden@broadcom.com>, Ray Jui <rjui@broadcom.com>,
|
|
Phil Elwell <phil@raspberrypi.org>, Alexander Graf <agraf@suse.de>,
|
|
bcm-kernel-feedback-list@broadcom.com,
|
|
linux-rpi-kernel@lists.infradead.org, linux-arm-kernel@lists.infradead.org
|
|
Date: Sat, 21 Apr 2018 13:28:35 +0200
|
|
|
|
After commit a98d90e7d588 ("gpio: raspberrypi-exp: Driver for RPi3 GPIO
|
|
expander via mailbox service") we are able to control the rest of the
|
|
GPIOs of the RPi 3. So add all the missing parts (ACT LED,
|
|
Wifi & BT control, HDMI detect) to the DT.
|
|
|
|
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
|
|
Reviewed-by: Eric Anholt <eric@anholt.net>
|
|
---
|
|
arch/arm/boot/dts/bcm2837-rpi-3-b.dts | 20 +++++++++++++++++++-
|
|
1 file changed, 19 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/arch/arm/boot/dts/bcm2837-rpi-3-b.dts b/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
|
|
index cc39b6f..c318bcb 100644
|
|
--- a/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
|
|
+++ b/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
|
|
@@ -20,9 +20,14 @@
|
|
|
|
leds {
|
|
act {
|
|
- gpios = <&gpio 47 GPIO_ACTIVE_HIGH>;
|
|
+ gpios = <&expgpio 2 GPIO_ACTIVE_HIGH>;
|
|
};
|
|
};
|
|
+
|
|
+ wifi_pwrseq: wifi-pwrseq {
|
|
+ compatible = "mmc-pwrseq-simple";
|
|
+ reset-gpios = <&expgpio 1 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
};
|
|
|
|
&firmware {
|
|
@@ -48,6 +53,10 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&hdmi {
|
|
+ hpd-gpios = <&expgpio 4 GPIO_ACTIVE_LOW>;
|
|
+};
|
|
+
|
|
/* uart0 communicates with the BT module */
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
@@ -57,6 +66,7 @@
|
|
bluetooth {
|
|
compatible = "brcm,bcm43438-bt";
|
|
max-speed = <2000000>;
|
|
+ shutdown-gpios = <&expgpio 0 GPIO_ACTIVE_HIGH>;
|
|
};
|
|
};
|
|
|
|
@@ -69,11 +79,19 @@
|
|
|
|
/* SDHCI is used to control the SDIO for wireless */
|
|
&sdhci {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&emmc_gpio34>;
|
|
status = "okay";
|
|
bus-width = <4>;
|
|
non-removable;
|
|
+ mmc-pwrseq = <&wifi_pwrseq>;
|
|
+
|
|
+ brcmf: wifi@1 {
|
|
+ reg = <1>;
|
|
+ compatible = "brcm,bcm4329-fmac";
|
|
+ };
|
|
};
|
|
|
|
/* SDHOST is used to drive the SD card */
|
|
From patchwork Sat Apr 21 11:28:36 2018
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [V2,3/9] dt-bindings: bcm: Add Raspberry Pi 3 B+
|
|
From: Stefan Wahren <stefan.wahren@i2se.com>
|
|
X-Patchwork-Id: 10354081
|
|
Message-Id: <1524310122-9439-4-git-send-email-stefan.wahren@i2se.com>
|
|
To: Rob Herring <robh+dt@kernel.org>, Mark Rutland <mark.rutland@arm.com>,
|
|
Eric Anholt <eric@anholt.net>, Catalin Marinas <catalin.marinas@arm.com>,
|
|
Will Deacon <will.deacon@arm.com>
|
|
Cc: Stefan Wahren <stefan.wahren@i2se.com>, devicetree@vger.kernel.org,
|
|
Florian Fainelli <f.fainelli@gmail.com>, Arnd Bergmann <arnd@arndb.de>,
|
|
Scott Branden <sbranden@broadcom.com>, Ray Jui <rjui@broadcom.com>,
|
|
Phil Elwell <phil@raspberrypi.org>, Alexander Graf <agraf@suse.de>,
|
|
bcm-kernel-feedback-list@broadcom.com,
|
|
linux-rpi-kernel@lists.infradead.org, linux-arm-kernel@lists.infradead.org
|
|
Date: Sat, 21 Apr 2018 13:28:36 +0200
|
|
|
|
This adds the root properties for the Raspberry Pi 3 B+
|
|
|
|
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
|
|
Reviewed-by: Eric Anholt <eric@anholt.net>
|
|
Reviewed-by: Rob Herring <robh@kernel.org>
|
|
---
|
|
Documentation/devicetree/bindings/arm/bcm/brcm,bcm2835.txt | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/Documentation/devicetree/bindings/arm/bcm/brcm,bcm2835.txt b/Documentation/devicetree/bindings/arm/bcm/brcm,bcm2835.txt
|
|
index 3e3efa0..1e3e29a 100644
|
|
--- a/Documentation/devicetree/bindings/arm/bcm/brcm,bcm2835.txt
|
|
+++ b/Documentation/devicetree/bindings/arm/bcm/brcm,bcm2835.txt
|
|
@@ -34,6 +34,10 @@ Raspberry Pi 3 Model B
|
|
Required root node properties:
|
|
compatible = "raspberrypi,3-model-b", "brcm,bcm2837";
|
|
|
|
+Raspberry Pi 3 Model B+
|
|
+Required root node properties:
|
|
+compatible = "raspberrypi,3-model-b-plus", "brcm,bcm2837";
|
|
+
|
|
Raspberry Pi Compute Module
|
|
Required root node properties:
|
|
compatible = "raspberrypi,compute-module", "brcm,bcm2835";
|
|
From patchwork Sat Apr 21 11:28:37 2018
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [V2,4/9] ARM: dts: bcm2837: Add Raspberry Pi 3 B+
|
|
From: Stefan Wahren <stefan.wahren@i2se.com>
|
|
X-Patchwork-Id: 10354075
|
|
Message-Id: <1524310122-9439-5-git-send-email-stefan.wahren@i2se.com>
|
|
To: Rob Herring <robh+dt@kernel.org>, Mark Rutland <mark.rutland@arm.com>,
|
|
Eric Anholt <eric@anholt.net>, Catalin Marinas <catalin.marinas@arm.com>,
|
|
Will Deacon <will.deacon@arm.com>
|
|
Cc: Stefan Wahren <stefan.wahren@i2se.com>, devicetree@vger.kernel.org,
|
|
Florian Fainelli <f.fainelli@gmail.com>, Arnd Bergmann <arnd@arndb.de>,
|
|
Scott Branden <sbranden@broadcom.com>, Ray Jui <rjui@broadcom.com>,
|
|
Phil Elwell <phil@raspberrypi.org>, Alexander Graf <agraf@suse.de>,
|
|
bcm-kernel-feedback-list@broadcom.com,
|
|
linux-rpi-kernel@lists.infradead.org, linux-arm-kernel@lists.infradead.org
|
|
Date: Sat, 21 Apr 2018 13:28:37 +0200
|
|
|
|
The Raspberry Pi 3 B+ has the following major differences compared
|
|
to the model 3 B:
|
|
* Microchip LAN7515 (Gigabit Ethernet with integrated USB 2.0 HUB)
|
|
* Cypress CYW43455 (802.11n/ac and BT 4.2)
|
|
|
|
We need to add the USB LAN chip so the bootloader can add the MAC address.
|
|
This is necessary because there ain't an EEPROM or a valid OTP.
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
|
|
Reviewed-by: Eric Anholt <eric@anholt.net>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts | 108 +++++++++++++++++++++++++++++
|
|
arch/arm/boot/dts/bcm283x-rpi-lan7515.dtsi | 27 ++++++++
|
|
3 files changed, 136 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts
|
|
create mode 100644 arch/arm/boot/dts/bcm283x-rpi-lan7515.dtsi
|
|
|
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
index 7e24249..a300a35 100644
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -75,6 +75,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += \
|
|
bcm2835-rpi-a-plus.dtb \
|
|
bcm2836-rpi-2-b.dtb \
|
|
bcm2837-rpi-3-b.dtb \
|
|
+ bcm2837-rpi-3-b-plus.dtb \
|
|
bcm2835-rpi-zero.dtb \
|
|
bcm2835-rpi-zero-w.dtb
|
|
dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
|
diff --git a/arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts b/arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts
|
|
new file mode 100644
|
|
index 0000000..4adb85e
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm2837-rpi-3-b-plus.dts
|
|
@@ -0,0 +1,108 @@
|
|
+// SPDX-License-Identifier: GPL-2.0
|
|
+/dts-v1/;
|
|
+#include "bcm2837.dtsi"
|
|
+#include "bcm2835-rpi.dtsi"
|
|
+#include "bcm283x-rpi-lan7515.dtsi"
|
|
+#include "bcm283x-rpi-usb-host.dtsi"
|
|
+
|
|
+/ {
|
|
+ compatible = "raspberrypi,3-model-b-plus", "brcm,bcm2837";
|
|
+ model = "Raspberry Pi 3 Model B+";
|
|
+
|
|
+ chosen {
|
|
+ /* 8250 auxiliary UART instead of pl011 */
|
|
+ stdout-path = "serial1:115200n8";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ reg = <0 0x40000000>;
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ act {
|
|
+ gpios = <&gpio 29 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+
|
|
+ pwr {
|
|
+ label = "PWR";
|
|
+ gpios = <&expgpio 2 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ wifi_pwrseq: wifi-pwrseq {
|
|
+ compatible = "mmc-pwrseq-simple";
|
|
+ reset-gpios = <&expgpio 1 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&firmware {
|
|
+ expgpio: gpio {
|
|
+ compatible = "raspberrypi,firmware-gpio";
|
|
+ gpio-controller;
|
|
+ #gpio-cells = <2>;
|
|
+ gpio-line-names = "BT_ON",
|
|
+ "WL_ON",
|
|
+ "STATUS_LED",
|
|
+ "LAN_RUN",
|
|
+ "",
|
|
+ "CAM_GPIO0",
|
|
+ "CAM_GPIO1",
|
|
+ "";
|
|
+ status = "okay";
|
|
+ };
|
|
+};
|
|
+
|
|
+&hdmi {
|
|
+ hpd-gpios = <&gpio 28 GPIO_ACTIVE_LOW>;
|
|
+};
|
|
+
|
|
+&pwm {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pwm0_gpio40 &pwm1_gpio41>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+/* SDHCI is used to control the SDIO for wireless */
|
|
+&sdhci {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&emmc_gpio34>;
|
|
+ status = "okay";
|
|
+ bus-width = <4>;
|
|
+ non-removable;
|
|
+ mmc-pwrseq = <&wifi_pwrseq>;
|
|
+
|
|
+ brcmf: wifi@1 {
|
|
+ reg = <1>;
|
|
+ compatible = "brcm,bcm4329-fmac";
|
|
+ };
|
|
+};
|
|
+
|
|
+/* SDHOST is used to drive the SD card */
|
|
+&sdhost {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&sdhost_gpio48>;
|
|
+ status = "okay";
|
|
+ bus-width = <4>;
|
|
+};
|
|
+
|
|
+/* uart0 communicates with the BT module */
|
|
+&uart0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart0_ctsrts_gpio30 &uart0_gpio32 &gpclk2_gpio43>;
|
|
+ status = "okay";
|
|
+
|
|
+ bluetooth {
|
|
+ compatible = "brcm,bcm43438-bt";
|
|
+ max-speed = <2000000>;
|
|
+ shutdown-gpios = <&expgpio 0 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+};
|
|
+
|
|
+/* uart1 is mapped to the pin header */
|
|
+&uart1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart1_gpio14>;
|
|
+ status = "okay";
|
|
+};
|
|
diff --git a/arch/arm/boot/dts/bcm283x-rpi-lan7515.dtsi b/arch/arm/boot/dts/bcm283x-rpi-lan7515.dtsi
|
|
new file mode 100644
|
|
index 0000000..9403da0
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm283x-rpi-lan7515.dtsi
|
|
@@ -0,0 +1,27 @@
|
|
+// SPDX-License-Identifier: GPL-2.0
|
|
+/ {
|
|
+ aliases {
|
|
+ ethernet0 = ðernet;
|
|
+ };
|
|
+};
|
|
+
|
|
+&usb {
|
|
+ usb-port@1 {
|
|
+ compatible = "usb424,2514";
|
|
+ reg = <1>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ usb-port@1 {
|
|
+ compatible = "usb424,2514";
|
|
+ reg = <1>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ ethernet: ethernet@1 {
|
|
+ compatible = "usb424,7800";
|
|
+ reg = <1>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
From patchwork Sat Apr 21 11:28:42 2018
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [V2,9/9] arm64: dts: broadcom: Add reference to Raspberry Pi 3 B+
|
|
From: Stefan Wahren <stefan.wahren@i2se.com>
|
|
X-Patchwork-Id: 10354077
|
|
Message-Id: <1524310122-9439-10-git-send-email-stefan.wahren@i2se.com>
|
|
To: Rob Herring <robh+dt@kernel.org>, Mark Rutland <mark.rutland@arm.com>,
|
|
Eric Anholt <eric@anholt.net>, Catalin Marinas <catalin.marinas@arm.com>,
|
|
Will Deacon <will.deacon@arm.com>
|
|
Cc: Stefan Wahren <stefan.wahren@i2se.com>, devicetree@vger.kernel.org,
|
|
Florian Fainelli <f.fainelli@gmail.com>, Arnd Bergmann <arnd@arndb.de>,
|
|
Scott Branden <sbranden@broadcom.com>, Ray Jui <rjui@broadcom.com>,
|
|
Phil Elwell <phil@raspberrypi.org>, Alexander Graf <agraf@suse.de>,
|
|
bcm-kernel-feedback-list@broadcom.com,
|
|
linux-rpi-kernel@lists.infradead.org, linux-arm-kernel@lists.infradead.org
|
|
Date: Sat, 21 Apr 2018 13:28:42 +0200
|
|
|
|
This adds a reference to the dts of the Raspberry Pi 3 B+
|
|
in arm, so don't need to maintain the content in arm64.
|
|
|
|
Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
|
|
Reviewed-by: Eric Anholt <eric@anholt.net>
|
|
---
|
|
arch/arm64/boot/dts/broadcom/Makefile | 3 ++-
|
|
arch/arm64/boot/dts/broadcom/bcm2837-rpi-3-b-plus.dts | 2 ++
|
|
2 files changed, 4 insertions(+), 1 deletion(-)
|
|
create mode 100644 arch/arm64/boot/dts/broadcom/bcm2837-rpi-3-b-plus.dts
|
|
|
|
diff --git a/arch/arm64/boot/dts/broadcom/Makefile b/arch/arm64/boot/dts/broadcom/Makefile
|
|
index 2a2591e..1193a9e 100644
|
|
--- a/arch/arm64/boot/dts/broadcom/Makefile
|
|
+++ b/arch/arm64/boot/dts/broadcom/Makefile
|
|
@@ -1,5 +1,6 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
-dtb-$(CONFIG_ARCH_BCM2835) += bcm2837-rpi-3-b.dtb
|
|
+dtb-$(CONFIG_ARCH_BCM2835) += bcm2837-rpi-3-b.dtb \
|
|
+ bcm2837-rpi-3-b-plus.dtb
|
|
|
|
subdir-y += northstar2
|
|
subdir-y += stingray
|
|
diff --git a/arch/arm64/boot/dts/broadcom/bcm2837-rpi-3-b-plus.dts b/arch/arm64/boot/dts/broadcom/bcm2837-rpi-3-b-plus.dts
|
|
new file mode 100644
|
|
index 0000000..46ad202
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcm2837-rpi-3-b-plus.dts
|
|
@@ -0,0 +1,2 @@
|
|
+// SPDX-License-Identifier: GPL-2.0
|
|
+#include "arm/bcm2837-rpi-3-b-plus.dts"
|