kernel/0001-initial-commit-Add-Red...

44 lines
1.3 KiB
Diff

From cd3a5d30570279538623ea8a1255db0ee4b728f7 Mon Sep 17 00:00:00 2001
From: Laura Abbott <labbott@redhat.com>
Date: Tue, 23 Jul 2019 11:39:36 -0400
Subject: [PATCH] [initial commit] Add Red Hat variables in the top level
makefile
Signed-off-by: Laura Abbott <labbott@redhat.com>
---
Makefile | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 3e4868a6498b..502f9a9a2806 100644
--- a/Makefile
+++ b/Makefile
@@ -15,6 +15,9 @@ NAME = Bobtail Squid
PHONY := _all
_all:
+# Set RHEL variables
+include Makefile.rhelver
+
# We are using a recursive build, so we need to do a little thinking
# to get the ordering right.
#
@@ -1160,7 +1163,13 @@ endef
define filechk_version.h
echo \#define LINUX_VERSION_CODE $(shell \
expr $(VERSION) \* 65536 + 0$(PATCHLEVEL) \* 256 + 0$(SUBLEVEL)); \
- echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))'
+ echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))'; \
+ echo '#define RHEL_MAJOR $(RHEL_MAJOR)'; \
+ echo '#define RHEL_MINOR $(RHEL_MINOR)'; \
+ echo '#define RHEL_RELEASE_VERSION(a,b) (((a) << 8) + (b))'; \
+ echo '#define RHEL_RELEASE_CODE \
+ $(shell expr $(RHEL_MAJOR) \* 256 + $(RHEL_MINOR))'; \
+ echo '#define RHEL_RELEASE "$(RHEL_RELEASE)"'
endef
$(version_h): FORCE
--
2.26.2