39 lines
1.0 KiB
Diff
39 lines
1.0 KiB
Diff
From c45bb6761613476a411a3e4d42d60e0b0dc85472 Mon Sep 17 00:00:00 2001
|
|
From: Fedora Kernel Team <kernel-team@fedoraproject.org>
|
|
Date: Wed, 7 Nov 2018 20:48:31 +0000
|
|
Subject: [PATCH] riscv64 fixes
|
|
|
|
---
|
|
arch/riscv/Makefile | 4 ++++
|
|
arch/riscv/include/asm/module.h | 1 +
|
|
2 files changed, 5 insertions(+)
|
|
|
|
diff --git a/arch/riscv/Makefile b/arch/riscv/Makefile
|
|
index d101461..4af153a 100644
|
|
--- a/arch/riscv/Makefile
|
|
+++ b/arch/riscv/Makefile
|
|
@@ -77,4 +77,8 @@ core-y += arch/riscv/kernel/ arch/riscv/mm/
|
|
|
|
libs-y += arch/riscv/lib/
|
|
|
|
+PHONY += vdso_install
|
|
+vdso_install:
|
|
+ $(Q)$(MAKE) $(build)=arch/riscv/kernel/vdso $@
|
|
+
|
|
all: vmlinux
|
|
diff --git a/arch/riscv/include/asm/module.h b/arch/riscv/include/asm/module.h
|
|
index 349df33..cd2af4b 100644
|
|
--- a/arch/riscv/include/asm/module.h
|
|
+++ b/arch/riscv/include/asm/module.h
|
|
@@ -8,6 +8,7 @@
|
|
|
|
#define MODULE_ARCH_VERMAGIC "riscv"
|
|
|
|
+struct module;
|
|
u64 module_emit_got_entry(struct module *mod, u64 val);
|
|
u64 module_emit_plt_entry(struct module *mod, u64 val);
|
|
|
|
--
|
|
2.19.1
|
|
|