59 lines
1.6 KiB
Diff
59 lines
1.6 KiB
Diff
diff -uNr linux-3.10.0-0.rc7.git0.2.fc20.x86_64/arch/arm/boot/dts/imx6q-wandboard.dts linux-3.10.0-0.rc7.git0.2.fc20.armv7hl/arch/arm/boot/dts/imx6q-wandboard.dts
|
|
--- linux-3.10.0-0.rc7.git0.2.fc20.x86_64/arch/arm/boot/dts/imx6q-wandboard.dts 1969-12-31 18:00:00.000000000 -0600
|
|
+++ linux-3.10.0-0.rc7.git0.2.fc20.armv7hl/arch/arm/boot/dts/imx6q-wandboard.dts 2013-06-30 15:09:21.350610898 -0500
|
|
@@ -0,0 +1,44 @@
|
|
+/*
|
|
+ * Copyright 2013 Freescale Semiconductor, Inc.
|
|
+ *
|
|
+ * Author: Fabio Estevam <fabio.estevam@freescale.com>
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 as
|
|
+ * published by the Free Software Foundation.
|
|
+ *
|
|
+ */
|
|
+/dts-v1/;
|
|
+#include "imx6q.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Wandboard i.MX6 Quad Board";
|
|
+ compatible = "wand,imx6q-wandboard", "fsl,imx6q";
|
|
+
|
|
+ memory {
|
|
+ reg = <0x10000000 0x80000000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&fec {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pinctrl_enet_1>;
|
|
+ phy-mode = "rgmii";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart1 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pinctrl_uart1_1>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usbh1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usdhc3 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pinctrl_usdhc3_2>;
|
|
+ status = "okay";
|
|
+};
|
|
--- linux-3.11.0-0.rc0.git6.2.fc20.x86_64/arch/arm/boot/dts/Makefile.orig 2013-07-12 10:45:40.231087368 -0500
|
|
+++ linux-3.11.0-0.rc0.git6.2.fc20.x86_64/arch/arm/boot/dts/Makefile 2013-07-12 10:48:39.973819470 -0500
|
|
@@ -131,6 +131,7 @@
|
|
imx6q-sabrelite.dtb \
|
|
imx6q-sabresd.dtb \
|
|
imx6q-sbc6x.dtb \
|
|
+ imx6q-wandboard.dtb \
|
|
imx6sl-evk.dtb \
|
|
vf610-twr.dtb
|
|
dtb-$(CONFIG_ARCH_MXS) += imx23-evk.dtb \
|