bb584dd537
perf hardcodes $libdir to be lib for all but x86_64, so kludge around it until upstream gets their act together. --kyle
18 lines
401 B
Diff
18 lines
401 B
Diff
diff --git a/tools/perf/config/Makefile b/tools/perf/config/Makefile
|
|
index 802cf54..7f30bfa 100644
|
|
--- a/tools/perf/config/Makefile
|
|
+++ b/tools/perf/config/Makefile
|
|
@@ -621,8 +621,12 @@ endif
|
|
ifeq ($(IS_X86_64),1)
|
|
lib = lib64
|
|
else
|
|
+ifdef MULTILIBDIR
|
|
+lib = $(MULTILIBDIR)
|
|
+else
|
|
lib = lib
|
|
endif
|
|
+endif
|
|
libdir = $(prefix)/$(lib)
|
|
|
|
# Shell quote (do not use $(call) to accommodate ancient setups);
|