49 lines
1.9 KiB
Diff
49 lines
1.9 KiB
Diff
From patchwork Tue Apr 25 16:45:08 2017
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: ARM: dts: Add devicetree for the Raspberry Pi 3, for arm32 (v6)
|
|
From: Eric Anholt <eric@anholt.net>
|
|
X-Patchwork-Id: 9698781
|
|
Message-Id: <20170425164508.32242-1-eric@anholt.net>
|
|
To: Lee Jones <lee@kernel.org>, Florian Fainelli <f.fainelli@gmail.com>,
|
|
Olof Johansson <olof@lixom.net>, Rob Herring <robh+dt@kernel.org>,
|
|
Mark Rutland <mark.rutland@arm.com>, devicetree@vger.kernel.org
|
|
Cc: Stefan Wahren <stefan.wahren@i2se.com>, linux-kernel@vger.kernel.org,
|
|
Eric Anholt <eric@anholt.net>, bcm-kernel-feedback-list@broadcom.com,
|
|
Gerd Hoffmann <kraxel@redhat.com>, linux-arm-kernel@lists.infradead.org,
|
|
linux-rpi-kernel@lists.infradead.org
|
|
Date: Tue, 25 Apr 2017 09:45:08 -0700
|
|
|
|
Raspbian and Fedora have decided to support the Pi3 in 32-bit mode for
|
|
now, so it's useful to be able to test that mode on an upstream
|
|
kernel. It's also been useful for me to use the same board for 32-bit
|
|
and 64-bit development.
|
|
|
|
Signed-off-by: Eric Anholt <eric@anholt.net>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 1 +
|
|
arch/arm/boot/dts/bcm2837-rpi-3-b.dts | 1 +
|
|
2 files changed, 2 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/bcm2837-rpi-3-b.dts
|
|
|
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
index 011808490fed..eded842d9978 100644
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -72,6 +72,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += \
|
|
bcm2835-rpi-b-plus.dtb \
|
|
bcm2835-rpi-a-plus.dtb \
|
|
bcm2836-rpi-2-b.dtb \
|
|
+ bcm2837-rpi-3-b.dtb \
|
|
bcm2835-rpi-zero.dtb
|
|
dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
|
bcm4708-asus-rt-ac56u.dtb \
|
|
diff --git a/arch/arm/boot/dts/bcm2837-rpi-3-b.dts b/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
|
|
new file mode 100644
|
|
index 000000000000..c72a27d908b6
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/bcm2837-rpi-3-b.dts
|
|
@@ -0,0 +1 @@
|
|
+#include "../../../arm64/boot/dts/broadcom/bcm2837-rpi-3-b.dts"
|