kernel/0001-Revert-tools-build-Sup...

52 lines
1.7 KiB
Diff

From 13304cca47c956c308ce8f3fc7b37b61895fa1ea Mon Sep 17 00:00:00 2001
From: Laura Abbott <labbott@redhat.com>
Date: Tue, 11 Oct 2016 13:10:26 -0700
Subject: [PATCH 1/2] Revert "tools build: Support compiling C++ source file"
This reverts commit f61bdc3304281e9ff9eec4f1ed9fb15bcf4d8a5e.
---
tools/build/Build.include | 1 -
tools/build/Makefile.build | 7 -------
2 files changed, 8 deletions(-)
diff --git a/tools/build/Build.include b/tools/build/Build.include
index 1dcb95e..0248938 100644
--- a/tools/build/Build.include
+++ b/tools/build/Build.include
@@ -90,7 +90,6 @@ if_changed = $(if $(strip $(any-prereq) $(arg-check)), \
# - per object C flags
# - BUILD_STR macro to allow '-D"$(variable)"' constructs
c_flags = -Wp,-MD,$(depfile),-MT,$@ $(CFLAGS) -D"BUILD_STR(s)=\#s" $(CFLAGS_$(basetarget).o) $(CFLAGS_$(obj))
-cxx_flags = -Wp,-MD,$(depfile),-MT,$@ $(CXXFLAGS) -D"BUILD_STR(s)=\#s" $(CXXFLAGS_$(basetarget).o) $(CXXFLAGS_$(obj))
###
## HOSTCC C flags
diff --git a/tools/build/Makefile.build b/tools/build/Makefile.build
index 99c0ccd..190519a 100644
--- a/tools/build/Makefile.build
+++ b/tools/build/Makefile.build
@@ -61,9 +61,6 @@ quiet_cmd_cc_o_c = CC $@
quiet_cmd_host_cc_o_c = HOSTCC $@
cmd_host_cc_o_c = $(HOSTCC) $(host_c_flags) -c -o $@ $<
-quiet_cmd_cxx_o_c = CXX $@
- cmd_cxx_o_c = $(CXX) $(cxx_flags) -c -o $@ $<
-
quiet_cmd_cpp_i_c = CPP $@
cmd_cpp_i_c = $(CC) $(c_flags) -E -o $@ $<
@@ -91,10 +88,6 @@ $(OUTPUT)%.o: %.c FORCE
$(call rule_mkdir)
$(call if_changed_dep,$(host)cc_o_c)
-$(OUTPUT)%.o: %.cpp FORCE
- $(call rule_mkdir)
- $(call if_changed_dep,cxx_o_c)
-
$(OUTPUT)%.o: %.S FORCE
$(call rule_mkdir)
$(call if_changed_dep,$(host)cc_o_c)
--
2.7.4