3252fbd882
- Add patch to fix oops on keyring gc (rhbz 1116347)
30 lines
732 B
Diff
30 lines
732 B
Diff
From 45047d94152b3dc0484c699cecc2413a9eccda63 Mon Sep 17 00:00:00 2001
|
|
From: "kernel-team@fedoraproject.org" <kernel-team@fedoraproject.org>
|
|
Date: Fri, 18 Apr 2014 06:58:29 -0400
|
|
Subject: [PATCH] disable libdw unwind on non-x86
|
|
|
|
Bugzilla: 1025603
|
|
Upstream-status: ??
|
|
---
|
|
tools/perf/config/Makefile | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/tools/perf/config/Makefile b/tools/perf/config/Makefile
|
|
index 1f67aa02d240..86c21a24da46 100644
|
|
--- a/tools/perf/config/Makefile
|
|
+++ b/tools/perf/config/Makefile
|
|
@@ -52,6 +52,10 @@ ifeq ($(ARCH),powerpc)
|
|
CFLAGS += -DHAVE_SKIP_CALLCHAIN_IDX
|
|
endif
|
|
|
|
+ifneq ($(ARCH),x86)
|
|
+ NO_LIBDW_DWARF_UNWIND := 1
|
|
+endif
|
|
+
|
|
ifeq ($(LIBUNWIND_LIBS),)
|
|
NO_LIBUNWIND := 1
|
|
else
|
|
--
|
|
1.9.3
|
|
|