6c5f57724d
- Updates and new SoCs for aarch64 and ARMv7 - Add aarch64 support for PINE64 and Geekbox devices - Fix ethernet naming on Armada 38x devices - Serial console fixes for Tegra
438 lines
12 KiB
Diff
438 lines
12 KiB
Diff
From a516bbf04744817e49e173b2a217a2a6366b5f9c Mon Sep 17 00:00:00 2001
|
|
From: Peter Robinson <pbrobinson@gmail.com>
|
|
Date: Wed, 2 Mar 2016 18:12:09 +0000
|
|
Subject: [PATCH] Geekbox device tree support
|
|
|
|
---
|
|
Documentation/devicetree/bindings/arm/rockchip.txt | 9 +
|
|
arch/arm64/boot/dts/rockchip/Makefile | 2 +
|
|
.../dts/rockchip/rk3368-geekbox-landingship.dts | 56 ++++
|
|
arch/arm64/boot/dts/rockchip/rk3368-geekbox.dts | 321 +++++++++++++++++++++
|
|
4 files changed, 388 insertions(+)
|
|
create mode 100644 arch/arm64/boot/dts/rockchip/rk3368-geekbox-landingship.dts
|
|
create mode 100644 arch/arm64/boot/dts/rockchip/rk3368-geekbox.dts
|
|
|
|
diff --git a/Documentation/devicetree/bindings/arm/rockchip.txt b/Documentation/devicetree/bindings/arm/rockchip.txt
|
|
index 078c14f..c6d95f2 100644
|
|
--- a/Documentation/devicetree/bindings/arm/rockchip.txt
|
|
+++ b/Documentation/devicetree/bindings/arm/rockchip.txt
|
|
@@ -87,6 +87,15 @@ Rockchip platforms device tree bindings
|
|
"google,veyron-speedy-rev3", "google,veyron-speedy-rev2",
|
|
"google,veyron-speedy", "google,veyron", "rockchip,rk3288";
|
|
|
|
+- GeekBuying GeekBox:
|
|
+ Required root node properties:
|
|
+ - compatible = "geekbuying,geekbox", "rockchip,rk3368";
|
|
+
|
|
+- GeekBuying Landingship:
|
|
+ Required root node properties:
|
|
+ - compatible = "geekbuying,landingship",
|
|
+ "geekbuying,geekbox", "rockchip,rk3368";
|
|
+
|
|
- Rockchip RK3368 evb:
|
|
Required root node properties:
|
|
- compatible = "rockchip,rk3368-evb-act8846", "rockchip,rk3368";
|
|
diff --git a/arch/arm64/boot/dts/rockchip/Makefile b/arch/arm64/boot/dts/rockchip/Makefile
|
|
index e3f0b5f..201bcd9 100644
|
|
--- a/arch/arm64/boot/dts/rockchip/Makefile
|
|
+++ b/arch/arm64/boot/dts/rockchip/Makefile
|
|
@@ -1,4 +1,6 @@
|
|
dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3368-evb-act8846.dtb
|
|
+dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3368-geekbox.dtb
|
|
+dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3368-geekbox-landingship.dtb
|
|
dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3368-r88.dtb
|
|
|
|
always := $(dtb-y)
|
|
diff --git a/arch/arm64/boot/dts/rockchip/rk3368-geekbox-landingship.dts b/arch/arm64/boot/dts/rockchip/rk3368-geekbox-landingship.dts
|
|
new file mode 100644
|
|
index 0000000..e4a1175
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/rockchip/rk3368-geekbox-landingship.dts
|
|
@@ -0,0 +1,56 @@
|
|
+/*
|
|
+ * Copyright (c) 2016 Andreas Färber
|
|
+ *
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
+ * licensing only applies to this file, and not this project as a
|
|
+ * whole.
|
|
+ *
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
+ * License, or (at your option) any later version.
|
|
+ *
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * Or, alternatively,
|
|
+ *
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
+ * obtaining a copy of this software and associated documentation
|
|
+ * files (the "Software"), to deal in the Software without
|
|
+ * restriction, including without limitation the rights to use,
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
+ * Software is furnished to do so, subject to the following
|
|
+ * conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+#include "rk3368-geekbox.dts"
|
|
+
|
|
+/ {
|
|
+ model = "GeekBox on Landingship";
|
|
+ compatible = "geekbuying,landingship", "geekbuying,geekbox", "rockchip,rk3368";
|
|
+};
|
|
+
|
|
+&i2c1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&i2c2 {
|
|
+ status = "okay";
|
|
+};
|
|
diff --git a/arch/arm64/boot/dts/rockchip/rk3368-geekbox.dts b/arch/arm64/boot/dts/rockchip/rk3368-geekbox.dts
|
|
new file mode 100644
|
|
index 0000000..7e51876
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/rockchip/rk3368-geekbox.dts
|
|
@@ -0,0 +1,321 @@
|
|
+/*
|
|
+ * Copyright (c) 2016 Andreas Färber
|
|
+ *
|
|
+ * This file is dual-licensed: you can use it either under the terms
|
|
+ * of the GPL or the X11 license, at your option. Note that this dual
|
|
+ * licensing only applies to this file, and not this project as a
|
|
+ * whole.
|
|
+ *
|
|
+ * a) This file is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License as
|
|
+ * published by the Free Software Foundation; either version 2 of the
|
|
+ * License, or (at your option) any later version.
|
|
+ *
|
|
+ * This file is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * Or, alternatively,
|
|
+ *
|
|
+ * b) Permission is hereby granted, free of charge, to any person
|
|
+ * obtaining a copy of this software and associated documentation
|
|
+ * files (the "Software"), to deal in the Software without
|
|
+ * restriction, including without limitation the rights to use,
|
|
+ * copy, modify, merge, publish, distribute, sublicense, and/or
|
|
+ * sell copies of the Software, and to permit persons to whom the
|
|
+ * Software is furnished to do so, subject to the following
|
|
+ * conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be
|
|
+ * included in all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
|
|
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
|
|
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
|
|
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
|
|
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
|
|
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
|
|
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
|
|
+ * OTHER DEALINGS IN THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+#include "rk3368.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "GeekBox";
|
|
+ compatible = "geekbuying,geekbox", "rockchip,rk3368";
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial2:115200n8";
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ device_type = "memory";
|
|
+ reg = <0x0 0x0 0x0 0x80000000>;
|
|
+ };
|
|
+
|
|
+ ext_gmac: gmac-clk {
|
|
+ compatible = "fixed-clock";
|
|
+ clock-frequency = <125000000>;
|
|
+ clock-output-names = "ext_gmac";
|
|
+ #clock-cells = <0>;
|
|
+ };
|
|
+
|
|
+ ir: ir-receiver {
|
|
+ compatible = "gpio-ir-receiver";
|
|
+ gpios = <&gpio3 30 GPIO_ACTIVE_LOW>;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&ir_int>;
|
|
+ };
|
|
+
|
|
+ keys: gpio-keys {
|
|
+ compatible = "gpio-keys";
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pwr_key>;
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+
|
|
+ button@0 {
|
|
+ reg = <0>;
|
|
+ gpio-key,wakeup = <1>;
|
|
+ gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
|
|
+ label = "GPIO Power";
|
|
+ linux,code = <116>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ leds: gpio-leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ blue {
|
|
+ gpios = <&gpio2 2 GPIO_ACTIVE_HIGH>;
|
|
+ label = "geekbox:blue:led";
|
|
+ default-state = "on";
|
|
+ };
|
|
+
|
|
+ red {
|
|
+ gpios = <&gpio2 3 GPIO_ACTIVE_HIGH>;
|
|
+ label = "geekbox:red:led";
|
|
+ default-state = "off";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ vcc_sys: vcc-sys-regulator {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "vcc_sys";
|
|
+ regulator-min-microvolt = <5000000>;
|
|
+ regulator-max-microvolt = <5000000>;
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ };
|
|
+};
|
|
+
|
|
+&emmc {
|
|
+ status = "okay";
|
|
+ bus-width = <8>;
|
|
+ cap-mmc-highspeed;
|
|
+ clock-frequency = <150000000>;
|
|
+ disable-wp;
|
|
+ keep-power-in-suspend;
|
|
+ non-removable;
|
|
+ num-slots = <1>;
|
|
+ vmmc-supply = <&vcc_io>;
|
|
+ vqmmc-supply = <&vcc18_flash>;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&emmc_clk>, <&emmc_cmd>, <&emmc_bus8>;
|
|
+};
|
|
+
|
|
+&gmac {
|
|
+ status = "okay";
|
|
+ phy-supply = <&vcc_lan>;
|
|
+ phy-mode = "rgmii";
|
|
+ clock_in_out = "input";
|
|
+ assigned-clocks = <&cru SCLK_MAC>;
|
|
+ assigned-clock-parents = <&ext_gmac>;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&rgmii_pins>;
|
|
+ tx_delay = <0x30>;
|
|
+ rx_delay = <0x10>;
|
|
+};
|
|
+
|
|
+&i2c0 {
|
|
+ status = "okay";
|
|
+
|
|
+ rk808: pmic@1b {
|
|
+ compatible = "rockchip,rk808";
|
|
+ reg = <0x1b>;
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&pmic_int>, <&pmic_sleep>;
|
|
+ interrupt-parent = <&gpio0>;
|
|
+ interrupts = <5 IRQ_TYPE_LEVEL_LOW>;
|
|
+ rockchip,system-power-controller;
|
|
+ vcc1-supply = <&vcc_sys>;
|
|
+ vcc2-supply = <&vcc_sys>;
|
|
+ vcc3-supply = <&vcc_sys>;
|
|
+ vcc4-supply = <&vcc_sys>;
|
|
+ vcc6-supply = <&vcc_sys>;
|
|
+ vcc7-supply = <&vcc_sys>;
|
|
+ vcc8-supply = <&vcc_io>;
|
|
+ vcc9-supply = <&vcc_sys>;
|
|
+ vcc10-supply = <&vcc_sys>;
|
|
+ vcc11-supply = <&vcc_sys>;
|
|
+ vcc12-supply = <&vcc_io>;
|
|
+ clock-output-names = "xin32k", "rk808-clkout2";
|
|
+ #clock-cells = <1>;
|
|
+
|
|
+ regulators {
|
|
+ vdd_cpu: DCDC_REG1 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <700000>;
|
|
+ regulator-max-microvolt = <1500000>;
|
|
+ regulator-name = "vdd_cpu";
|
|
+ };
|
|
+
|
|
+ vdd_log: DCDC_REG2 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <700000>;
|
|
+ regulator-max-microvolt = <1500000>;
|
|
+ regulator-name = "vdd_log";
|
|
+ };
|
|
+
|
|
+ vcc_ddr: DCDC_REG3 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-name = "vcc_ddr";
|
|
+ };
|
|
+
|
|
+ vcc_io: DCDC_REG4 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ regulator-name = "vcc_io";
|
|
+ };
|
|
+
|
|
+ vcc18_flash: LDO_REG1 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+ regulator-name = "vcc18_flash";
|
|
+ };
|
|
+
|
|
+ vcc33_lcd: LDO_REG2 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <3300000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ regulator-name = "vcc33_lcd";
|
|
+ };
|
|
+
|
|
+ vdd_10: LDO_REG3 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <1000000>;
|
|
+ regulator-max-microvolt = <1000000>;
|
|
+ regulator-name = "vdd_10";
|
|
+ };
|
|
+
|
|
+ vcca_18: LDO_REG4 {
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+ regulator-name = "vcca_18";
|
|
+ };
|
|
+
|
|
+ vccio_sd: LDO_REG5 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <3300000>;
|
|
+ regulator-name = "vccio_sd";
|
|
+ };
|
|
+
|
|
+ vdd10_lcd: LDO_REG6 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <1000000>;
|
|
+ regulator-max-microvolt = <1000000>;
|
|
+ regulator-name = "vdd10_lcd";
|
|
+ };
|
|
+
|
|
+ vcc_18: LDO_REG7 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+ regulator-name = "vcc_18";
|
|
+ };
|
|
+
|
|
+ vcc18_lcd: LDO_REG8 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-min-microvolt = <1800000>;
|
|
+ regulator-max-microvolt = <1800000>;
|
|
+ regulator-name = "vcc18_lcd";
|
|
+ };
|
|
+
|
|
+ vcc_sd: SWITCH_REG1 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-name = "vcc_sd";
|
|
+ };
|
|
+
|
|
+ vcc_lan: SWITCH_REG2 {
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ regulator-name = "vcc_lan";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&pinctrl {
|
|
+ ir {
|
|
+ ir_int: ir-int {
|
|
+ rockchip,pins = <3 30 RK_FUNC_GPIO &pcfg_pull_up>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ keys {
|
|
+ pwr_key: pwr-key {
|
|
+ rockchip,pins = <0 2 RK_FUNC_GPIO &pcfg_pull_up>;
|
|
+ };
|
|
+ };
|
|
+
|
|
+ pmic {
|
|
+ pmic_sleep: pmic-sleep {
|
|
+ rockchip,pins = <0 0 RK_FUNC_2 &pcfg_pull_none>;
|
|
+ };
|
|
+
|
|
+ pmic_int: pmic-int {
|
|
+ rockchip,pins = <0 5 RK_FUNC_GPIO &pcfg_pull_up>;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&tsadc {
|
|
+ status = "okay";
|
|
+ rockchip,hw-tshut-mode = <0>; /* CRU */
|
|
+ rockchip,hw-tshut-polarity = <0>; /* low */
|
|
+};
|
|
+
|
|
+&uart2 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb_host0_ehci {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb_otg {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&wdt {
|
|
+ status = "okay";
|
|
+};
|
|
--
|
|
2.5.0
|
|
|