f7a3bf6547
* Thu Aug 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc0.20200813gitdc06fe51d26e.1] - dc06fe51d26e rebase - More mismatches ("Justin M. Forbes") - Fedora config change due to deps ("Justin M. Forbes") - CONFIG_SND_SOC_MAX98390 is now selected by SND_SOC_INTEL_DA7219_MAX98357A_GENERIC ("Justin M. Forbes") - Config change required for build part 2 ("Justin M. Forbes") - Config change required for build ("Justin M. Forbes") - Fedora config update ("Justin M. Forbes") - Revert "Merge branch 'make_configs_fix' into 'os-build'" (Justin Forbes) - redhat/configs/process_configs.sh: Remove *.config.orig files (Prarit Bhargava) - redhat/configs/process_configs.sh: Add process_configs_known_broken flag (Prarit Bhargava) - redhat/Makefile: Fix '*-configs' targets (Prarit Bhargava) - Updated changelog for the release based on v5.8 (Fedora Kernel Team) - Add ability to sync upstream through Makefile (Don Zickus) - Add master merge check (Don Zickus) - Replace hardcoded values 'os-build' and project id with variables (Don Zickus) - gitattributes: Remove unnecesary export restrictions (Prarit Bhargava) - redhat/Makefile.common: Fix MARKER (Prarit Bhargava) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
44 lines
1.6 KiB
Diff
44 lines
1.6 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Jonathan Toppins <jtoppins@redhat.com>
|
|
Date: Tue, 24 Jul 2018 19:17:40 -0400
|
|
Subject: [PATCH] ice: mark driver as tech-preview
|
|
|
|
Message-id: <f087de8dbe4e8eac9f0992cc34def0a07aba206d.1532459145.git.jtoppins@redhat.com>
|
|
Patchwork-id: 8526
|
|
O-Subject: [kernel team] [PATCH RHEL8 1/3] [redhat] ice: mark driver as tech-preview
|
|
Bugzilla: 1495347
|
|
RH-Acked-by: Steve Best <sbest@redhat.com>
|
|
RH-Acked-by: Don Dutile <ddutile@redhat.com>
|
|
RH-Acked-by: David S. Miller <davem@redhat.com>
|
|
RH-Acked-by: Jarod Wilson <jarod@redhat.com>
|
|
RH-Acked-by: Neil Horman <nhorman@redhat.com>
|
|
RH-Acked-by: Prarit Bhargava <prarit@redhat.com>
|
|
|
|
Upstream Status: RHEL-only
|
|
Bugzilla: 1495347
|
|
Build Info: https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=17334539
|
|
Tested: booted and verified taint flags were set when the driver was loaded.
|
|
|
|
Upstream Status: RHEL only
|
|
Signed-off-by: Jonathan Toppins <jtoppins@redhat.com>
|
|
Signed-off-by: Herton R. Krzesinski <herton@redhat.com>
|
|
---
|
|
drivers/net/ethernet/intel/ice/ice_main.c | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/drivers/net/ethernet/intel/ice/ice_main.c b/drivers/net/ethernet/intel/ice/ice_main.c
|
|
index 4634b48949bb..e93470340eda 100644
|
|
--- a/drivers/net/ethernet/intel/ice/ice_main.c
|
|
+++ b/drivers/net/ethernet/intel/ice/ice_main.c
|
|
@@ -4786,6 +4786,7 @@ static int __init ice_module_init(void)
|
|
|
|
pr_info("%s\n", ice_driver_string);
|
|
pr_info("%s\n", ice_copyright);
|
|
+ mark_tech_preview(DRV_SUMMARY, THIS_MODULE);
|
|
|
|
ice_wq = alloc_workqueue("%s", WQ_MEM_RECLAIM, 0, KBUILD_MODNAME);
|
|
if (!ice_wq) {
|
|
--
|
|
2.26.2
|
|
|