Linux v3.19-4542-g8cc748aa76c9
This commit is contained in:
parent
a281db6571
commit
fe6305dc49
@ -14,7 +14,7 @@ Signed-off-by: David Howells <dhowells@redhat.com>
|
|||||||
1 file changed, 20 insertions(+)
|
1 file changed, 20 insertions(+)
|
||||||
|
|
||||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||||
index 33d555e5d8e7..02068cc2883d 100644
|
index c74cbd892032..1293d0e0bf90 100644
|
||||||
--- a/include/linux/efi.h
|
--- a/include/linux/efi.h
|
||||||
+++ b/include/linux/efi.h
|
+++ b/include/linux/efi.h
|
||||||
@@ -589,6 +589,12 @@ void efi_native_runtime_setup(void);
|
@@ -589,6 +589,12 @@ void efi_native_runtime_setup(void);
|
||||||
|
@ -159,10 +159,10 @@ index 000000000000..424896a0b169
|
|||||||
+ return 0;
|
+ return 0;
|
||||||
+}
|
+}
|
||||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||||
index 02068cc2883d..f71d1700a187 100644
|
index 1293d0e0bf90..706b16fa6de8 100644
|
||||||
--- a/include/linux/efi.h
|
--- a/include/linux/efi.h
|
||||||
+++ b/include/linux/efi.h
|
+++ b/include/linux/efi.h
|
||||||
@@ -923,6 +923,10 @@ extern bool efi_poweroff_required(void);
|
@@ -925,6 +925,10 @@ extern bool efi_poweroff_required(void);
|
||||||
char * __init efi_md_typeattr_format(char *buf, size_t size,
|
char * __init efi_md_typeattr_format(char *buf, size_t size,
|
||||||
const efi_memory_desc_t *md);
|
const efi_memory_desc_t *md);
|
||||||
|
|
||||||
|
@ -81,10 +81,10 @@ index 421e29e4cd81..61c1eb97806c 100644
|
|||||||
input_set_drvdata(udev->dev, udev);
|
input_set_drvdata(udev->dev, udev);
|
||||||
|
|
||||||
diff --git a/drivers/tty/sysrq.c b/drivers/tty/sysrq.c
|
diff --git a/drivers/tty/sysrq.c b/drivers/tty/sysrq.c
|
||||||
index 42bad18c66c9..496e073b09d7 100644
|
index 259a4d5a4e8f..512c21dcb86f 100644
|
||||||
--- a/drivers/tty/sysrq.c
|
--- a/drivers/tty/sysrq.c
|
||||||
+++ b/drivers/tty/sysrq.c
|
+++ b/drivers/tty/sysrq.c
|
||||||
@@ -463,6 +463,7 @@ static struct sysrq_key_op *sysrq_key_table[36] = {
|
@@ -464,6 +464,7 @@ static struct sysrq_key_op *sysrq_key_table[36] = {
|
||||||
&sysrq_showstate_blocked_op, /* w */
|
&sysrq_showstate_blocked_op, /* w */
|
||||||
/* x: May be registered on ppc/powerpc for xmon */
|
/* x: May be registered on ppc/powerpc for xmon */
|
||||||
/* x: May be registered on sparc64 for global PMU dump */
|
/* x: May be registered on sparc64 for global PMU dump */
|
||||||
@ -92,7 +92,7 @@ index 42bad18c66c9..496e073b09d7 100644
|
|||||||
NULL, /* x */
|
NULL, /* x */
|
||||||
/* y: May be registered on sparc64 for global register dump */
|
/* y: May be registered on sparc64 for global register dump */
|
||||||
NULL, /* y */
|
NULL, /* y */
|
||||||
@@ -506,7 +507,7 @@ static void __sysrq_put_key_op(int key, struct sysrq_key_op *op_p)
|
@@ -507,7 +508,7 @@ static void __sysrq_put_key_op(int key, struct sysrq_key_op *op_p)
|
||||||
sysrq_key_table[i] = op_p;
|
sysrq_key_table[i] = op_p;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -101,7 +101,7 @@ index 42bad18c66c9..496e073b09d7 100644
|
|||||||
{
|
{
|
||||||
struct sysrq_key_op *op_p;
|
struct sysrq_key_op *op_p;
|
||||||
int orig_log_level;
|
int orig_log_level;
|
||||||
@@ -526,11 +527,15 @@ void __handle_sysrq(int key, bool check_mask)
|
@@ -527,11 +528,15 @@ void __handle_sysrq(int key, bool check_mask)
|
||||||
|
|
||||||
op_p = __sysrq_get_key_op(key);
|
op_p = __sysrq_get_key_op(key);
|
||||||
if (op_p) {
|
if (op_p) {
|
||||||
@ -115,10 +115,10 @@ index 42bad18c66c9..496e073b09d7 100644
|
|||||||
*/
|
*/
|
||||||
- if (!check_mask || sysrq_on_mask(op_p->enable_mask)) {
|
- if (!check_mask || sysrq_on_mask(op_p->enable_mask)) {
|
||||||
+ if (from == SYSRQ_FROM_KERNEL || sysrq_on_mask(op_p->enable_mask)) {
|
+ if (from == SYSRQ_FROM_KERNEL || sysrq_on_mask(op_p->enable_mask)) {
|
||||||
printk("%s\n", op_p->action_msg);
|
pr_cont("%s\n", op_p->action_msg);
|
||||||
console_loglevel = orig_log_level;
|
console_loglevel = orig_log_level;
|
||||||
op_p->handler(key);
|
op_p->handler(key);
|
||||||
@@ -562,7 +567,7 @@ void __handle_sysrq(int key, bool check_mask)
|
@@ -563,7 +568,7 @@ void __handle_sysrq(int key, bool check_mask)
|
||||||
void handle_sysrq(int key)
|
void handle_sysrq(int key)
|
||||||
{
|
{
|
||||||
if (sysrq_on())
|
if (sysrq_on())
|
||||||
@ -127,7 +127,7 @@ index 42bad18c66c9..496e073b09d7 100644
|
|||||||
}
|
}
|
||||||
EXPORT_SYMBOL(handle_sysrq);
|
EXPORT_SYMBOL(handle_sysrq);
|
||||||
|
|
||||||
@@ -642,7 +647,7 @@ static void sysrq_do_reset(unsigned long _state)
|
@@ -643,7 +648,7 @@ static void sysrq_do_reset(unsigned long _state)
|
||||||
static void sysrq_handle_reset_request(struct sysrq_state *state)
|
static void sysrq_handle_reset_request(struct sysrq_state *state)
|
||||||
{
|
{
|
||||||
if (state->reset_requested)
|
if (state->reset_requested)
|
||||||
@ -136,7 +136,7 @@ index 42bad18c66c9..496e073b09d7 100644
|
|||||||
|
|
||||||
if (sysrq_reset_downtime_ms)
|
if (sysrq_reset_downtime_ms)
|
||||||
mod_timer(&state->keyreset_timer,
|
mod_timer(&state->keyreset_timer,
|
||||||
@@ -793,8 +798,10 @@ static bool sysrq_handle_keypress(struct sysrq_state *sysrq,
|
@@ -794,8 +799,10 @@ static bool sysrq_handle_keypress(struct sysrq_state *sysrq,
|
||||||
|
|
||||||
default:
|
default:
|
||||||
if (sysrq->active && value && value != 2) {
|
if (sysrq->active && value && value != 2) {
|
||||||
@ -148,7 +148,7 @@ index 42bad18c66c9..496e073b09d7 100644
|
|||||||
}
|
}
|
||||||
break;
|
break;
|
||||||
}
|
}
|
||||||
@@ -1089,7 +1096,7 @@ static ssize_t write_sysrq_trigger(struct file *file, const char __user *buf,
|
@@ -1090,7 +1097,7 @@ static ssize_t write_sysrq_trigger(struct file *file, const char __user *buf,
|
||||||
|
|
||||||
if (get_user(c, buf))
|
if (get_user(c, buf))
|
||||||
return -EFAULT;
|
return -EFAULT;
|
||||||
|
@ -43,7 +43,7 @@ Signed-off-by: Josh Stone <jistone@redhat.com>
|
|||||||
2 files changed, 21 insertions(+), 1 deletion(-)
|
2 files changed, 21 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index b15036b1890c..0fbc68ed4ce9 100644
|
index 5fa2e3035509..f2ffff2addbb 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
|
@@ -706,7 +706,11 @@ KBUILD_CFLAGS += -fomit-frame-pointer
|
||||||
|
@ -25,7 +25,7 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|||||||
create mode 100644 kernel/modsign_uefi.c
|
create mode 100644 kernel/modsign_uefi.c
|
||||||
|
|
||||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||||
index f71d1700a187..9d3f61593d9a 100644
|
index 706b16fa6de8..470e8dfcb517 100644
|
||||||
--- a/include/linux/efi.h
|
--- a/include/linux/efi.h
|
||||||
+++ b/include/linux/efi.h
|
+++ b/include/linux/efi.h
|
||||||
@@ -595,6 +595,12 @@ void efi_native_runtime_setup(void);
|
@@ -595,6 +595,12 @@ void efi_native_runtime_setup(void);
|
||||||
@ -62,7 +62,7 @@ index ac49b6e83436..5cdb1c323f62 100644
|
|||||||
prompt "Which hash algorithm should modules be signed with?"
|
prompt "Which hash algorithm should modules be signed with?"
|
||||||
depends on MODULE_SIG
|
depends on MODULE_SIG
|
||||||
diff --git a/kernel/Makefile b/kernel/Makefile
|
diff --git a/kernel/Makefile b/kernel/Makefile
|
||||||
index 616994f0a76f..43b9d7ba757f 100644
|
index 1408b3353a3c..8a3be67a3a15 100644
|
||||||
--- a/kernel/Makefile
|
--- a/kernel/Makefile
|
||||||
+++ b/kernel/Makefile
|
+++ b/kernel/Makefile
|
||||||
@@ -46,6 +46,7 @@ obj-$(CONFIG_UID16) += uid16.o
|
@@ -46,6 +46,7 @@ obj-$(CONFIG_UID16) += uid16.o
|
||||||
|
@ -15,10 +15,10 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
|
|||||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
|
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
|
||||||
index 512a35929f94..466b7e9758d0 100644
|
index a89e32637570..78f2a8704bb1 100644
|
||||||
--- a/Documentation/kernel-parameters.txt
|
--- a/Documentation/kernel-parameters.txt
|
||||||
+++ b/Documentation/kernel-parameters.txt
|
+++ b/Documentation/kernel-parameters.txt
|
||||||
@@ -3808,7 +3808,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
|
@@ -3810,7 +3810,7 @@ bytes respectively. Such letter suffixes can also be entirely omitted.
|
||||||
the allocated input device; If set to 0, video driver
|
the allocated input device; If set to 0, video driver
|
||||||
will only send out the event without touching backlight
|
will only send out the event without touching backlight
|
||||||
brightness level.
|
brightness level.
|
||||||
|
@ -154,3 +154,4 @@ CONFIG_SATA_AHCI_PLATFORM=y
|
|||||||
# CONFIG_SND_SOC is not set
|
# CONFIG_SND_SOC is not set
|
||||||
|
|
||||||
# CONFIG_PMIC_OPREGION is not set
|
# CONFIG_PMIC_OPREGION is not set
|
||||||
|
# CONFIG_DEBUG_RODATA is not set
|
||||||
|
@ -2364,7 +2364,7 @@ CONFIG_TCG_TIS=m
|
|||||||
CONFIG_TCG_NSC=m
|
CONFIG_TCG_NSC=m
|
||||||
CONFIG_TCG_ATMEL=m
|
CONFIG_TCG_ATMEL=m
|
||||||
# CONFIG_TCG_INFINEON is not set
|
# CONFIG_TCG_INFINEON is not set
|
||||||
# CONFIG_TCG_ST33_I2C is not set
|
# CONFIG_TCG_TIS_I2C_ST33 is not set
|
||||||
# CONFIG_TCG_XEN is not set
|
# CONFIG_TCG_XEN is not set
|
||||||
CONFIG_TELCLOCK=m
|
CONFIG_TELCLOCK=m
|
||||||
|
|
||||||
@ -5352,6 +5352,7 @@ CONFIG_HWSPINLOCK=m
|
|||||||
CONFIG_PSTORE=y
|
CONFIG_PSTORE=y
|
||||||
CONFIG_PSTORE_RAM=m
|
CONFIG_PSTORE_RAM=m
|
||||||
# CONFIG_PSTORE_CONSOLE is not set
|
# CONFIG_PSTORE_CONSOLE is not set
|
||||||
|
# CONFIG_PSTORE_PMSG is not set
|
||||||
# CONFIG_PSTORE_FTRACE is not set
|
# CONFIG_PSTORE_FTRACE is not set
|
||||||
|
|
||||||
# CONFIG_TEST_LKM is not set
|
# CONFIG_TEST_LKM is not set
|
||||||
@ -5380,6 +5381,7 @@ CONFIG_BCMA_DRIVER_GPIO=y
|
|||||||
CONFIG_IOMMU_SUPPORT=y
|
CONFIG_IOMMU_SUPPORT=y
|
||||||
|
|
||||||
# CONFIG_MAILBOX is not set
|
# CONFIG_MAILBOX is not set
|
||||||
|
# CONFIG_ALTERA_MBOX is not set
|
||||||
|
|
||||||
# CONFIG_RESET_CONTROLLER is not set
|
# CONFIG_RESET_CONTROLLER is not set
|
||||||
|
|
||||||
|
@ -206,6 +206,7 @@ CONFIG_VMCP=y
|
|||||||
|
|
||||||
CONFIG_SCHED_MC=y
|
CONFIG_SCHED_MC=y
|
||||||
CONFIG_SCHED_BOOK=y
|
CONFIG_SCHED_BOOK=y
|
||||||
|
CONFIG_SCHED_TOPOLOGY=y
|
||||||
|
|
||||||
# CONFIG_WARN_DYNAMIC_STACK is not set
|
# CONFIG_WARN_DYNAMIC_STACK is not set
|
||||||
|
|
||||||
|
@ -199,6 +199,7 @@ CONFIG_EDAC_IE31200=m
|
|||||||
CONFIG_SCHED_MC=y
|
CONFIG_SCHED_MC=y
|
||||||
|
|
||||||
CONFIG_TCG_INFINEON=m
|
CONFIG_TCG_INFINEON=m
|
||||||
|
CONFIG_TCG_CRB=m
|
||||||
|
|
||||||
CONFIG_HW_RANDOM_INTEL=m
|
CONFIG_HW_RANDOM_INTEL=m
|
||||||
CONFIG_HW_RANDOM_AMD=m
|
CONFIG_HW_RANDOM_AMD=m
|
||||||
|
@ -26,10 +26,10 @@ index 90de17f70b16..c5a7fe1c197c 100644
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
diff --git a/include/linux/efi.h b/include/linux/efi.h
|
||||||
index b674837e2b98..33d555e5d8e7 100644
|
index cf7e431cbc73..c74cbd892032 100644
|
||||||
--- a/include/linux/efi.h
|
--- a/include/linux/efi.h
|
||||||
+++ b/include/linux/efi.h
|
+++ b/include/linux/efi.h
|
||||||
@@ -940,6 +940,7 @@ extern int __init efi_setup_pcdp_console(char *);
|
@@ -942,6 +942,7 @@ extern int __init efi_setup_pcdp_console(char *);
|
||||||
#define EFI_64BIT 5 /* Is the firmware 64-bit? */
|
#define EFI_64BIT 5 /* Is the firmware 64-bit? */
|
||||||
#define EFI_PARAVIRT 6 /* Access is via a paravirt interface */
|
#define EFI_PARAVIRT 6 /* Access is via a paravirt interface */
|
||||||
#define EFI_ARCH_1 7 /* First arch-specific bit */
|
#define EFI_ARCH_1 7 /* First arch-specific bit */
|
||||||
|
11
kernel.spec
11
kernel.spec
@ -69,7 +69,7 @@ Summary: The Linux kernel
|
|||||||
# The rc snapshot level
|
# The rc snapshot level
|
||||||
%define rcrev 0
|
%define rcrev 0
|
||||||
# The git snapshot level
|
# The git snapshot level
|
||||||
%define gitrev 3
|
%define gitrev 4
|
||||||
# Set rpm version accordingly
|
# Set rpm version accordingly
|
||||||
%define rpmversion 3.%{upstream_sublevel}.0
|
%define rpmversion 3.%{upstream_sublevel}.0
|
||||||
%endif
|
%endif
|
||||||
@ -612,9 +612,6 @@ Patch26129: samsung-laptop-Add-use_native_backlight-quirk-and-en.patch
|
|||||||
#rhbz 1094948
|
#rhbz 1094948
|
||||||
Patch26131: acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
Patch26131: acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
||||||
|
|
||||||
#rhbz 1188638
|
|
||||||
Patch26132: nfs-don-t-call-blocking-operations-while-TASK_RUNNIN.patch
|
|
||||||
|
|
||||||
#rhbz 1188074
|
#rhbz 1188074
|
||||||
Patch26133: ntp-Fixup-adjtimex-freq-validation-on-32bit-systems.patch
|
Patch26133: ntp-Fixup-adjtimex-freq-validation-on-32bit-systems.patch
|
||||||
|
|
||||||
@ -1341,9 +1338,6 @@ ApplyPatch samsung-laptop-Add-use_native_backlight-quirk-and-en.patch
|
|||||||
#rhbz 1094948
|
#rhbz 1094948
|
||||||
ApplyPatch acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
ApplyPatch acpi-video-Add-disable_native_backlight-quirk-for-Sa.patch
|
||||||
|
|
||||||
#rhbz 1188638
|
|
||||||
ApplyPatch nfs-don-t-call-blocking-operations-while-TASK_RUNNIN.patch
|
|
||||||
|
|
||||||
#rhbz 1188074
|
#rhbz 1188074
|
||||||
ApplyPatch ntp-Fixup-adjtimex-freq-validation-on-32bit-systems.patch
|
ApplyPatch ntp-Fixup-adjtimex-freq-validation-on-32bit-systems.patch
|
||||||
|
|
||||||
@ -2215,6 +2209,9 @@ fi
|
|||||||
# ||----w |
|
# ||----w |
|
||||||
# || ||
|
# || ||
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 12 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.20.0-0.rc0.git4.1
|
||||||
|
- Linux v3.19-4542-g8cc748aa76c9
|
||||||
|
|
||||||
* Thu Feb 12 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.20.0-0.rc0.git3.1
|
* Thu Feb 12 2015 Josh Boyer <jwboyer@fedoraproject.org> - 3.20.0-0.rc0.git3.1
|
||||||
- Linux v3.19-4020-gce01e871a1d4
|
- Linux v3.19-4020-gce01e871a1d4
|
||||||
|
|
||||||
|
@ -1,91 +0,0 @@
|
|||||||
From: Jeff Layton <jlayton@primarydata.com>
|
|
||||||
Date: Wed, 14 Jan 2015 13:08:57 -0500
|
|
||||||
Subject: [PATCH] nfs: don't call blocking operations while !TASK_RUNNING
|
|
||||||
|
|
||||||
Bruce reported seeing this warning pop when mounting using v4.1:
|
|
||||||
|
|
||||||
------------[ cut here ]------------
|
|
||||||
WARNING: CPU: 1 PID: 1121 at kernel/sched/core.c:7300 __might_sleep+0xbd/0xd0()
|
|
||||||
do not call blocking ops when !TASK_RUNNING; state=1 set at [<ffffffff810ff58f>] prepare_to_wait+0x2f/0x90
|
|
||||||
Modules linked in: rpcsec_gss_krb5 auth_rpcgss nfsv4 dns_resolver nfs lockd grace sunrpc fscache ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw snd_hda_codec_generic snd_hda_intel snd_hda_controller snd_hda_codec snd_hwdep snd_pcm snd_timer ppdev joydev snd virtio_console virtio_balloon pcspkr serio_raw parport_pc parport pvpanic floppy soundcore i2c_piix4 virtio_blk virtio_net qxl drm_kms_helper ttm drm virtio_pci virtio_ring ata_generic virtio pata_acpi
|
|
||||||
CPU: 1 PID: 1121 Comm: nfsv4.1-svc Not tainted 3.19.0-rc4+ #25
|
|
||||||
Hardware name: QEMU Standard PC (i440FX + PIIX, 1996), BIOS 1.7.5-20140709_153950- 04/01/2014
|
|
||||||
0000000000000000 000000004e5e3f73 ffff8800b998fb48 ffffffff8186ac78
|
|
||||||
0000000000000000 ffff8800b998fba0 ffff8800b998fb88 ffffffff810ac9da
|
|
||||||
ffff8800b998fb68 ffffffff81c923e7 00000000000004d9 0000000000000000
|
|
||||||
Call Trace:
|
|
||||||
[<ffffffff8186ac78>] dump_stack+0x4c/0x65
|
|
||||||
[<ffffffff810ac9da>] warn_slowpath_common+0x8a/0xc0
|
|
||||||
[<ffffffff810aca65>] warn_slowpath_fmt+0x55/0x70
|
|
||||||
[<ffffffff810ff58f>] ? prepare_to_wait+0x2f/0x90
|
|
||||||
[<ffffffff810ff58f>] ? prepare_to_wait+0x2f/0x90
|
|
||||||
[<ffffffff810dd2ad>] __might_sleep+0xbd/0xd0
|
|
||||||
[<ffffffff8124c973>] kmem_cache_alloc_trace+0x243/0x430
|
|
||||||
[<ffffffff810d941e>] ? groups_alloc+0x3e/0x130
|
|
||||||
[<ffffffff810d941e>] groups_alloc+0x3e/0x130
|
|
||||||
[<ffffffffa0301b1e>] svcauth_unix_accept+0x16e/0x290 [sunrpc]
|
|
||||||
[<ffffffffa0300571>] svc_authenticate+0xe1/0xf0 [sunrpc]
|
|
||||||
[<ffffffffa02fc564>] svc_process_common+0x244/0x6a0 [sunrpc]
|
|
||||||
[<ffffffffa02fd044>] bc_svc_process+0x1c4/0x260 [sunrpc]
|
|
||||||
[<ffffffffa03d5478>] nfs41_callback_svc+0x128/0x1f0 [nfsv4]
|
|
||||||
[<ffffffff810ff970>] ? wait_woken+0xc0/0xc0
|
|
||||||
[<ffffffffa03d5350>] ? nfs4_callback_svc+0x60/0x60 [nfsv4]
|
|
||||||
[<ffffffff810d45bf>] kthread+0x11f/0x140
|
|
||||||
[<ffffffff810ea815>] ? local_clock+0x15/0x30
|
|
||||||
[<ffffffff810d44a0>] ? kthread_create_on_node+0x250/0x250
|
|
||||||
[<ffffffff81874bfc>] ret_from_fork+0x7c/0xb0
|
|
||||||
[<ffffffff810d44a0>] ? kthread_create_on_node+0x250/0x250
|
|
||||||
---[ end trace 675220a11e30f4f2 ]---
|
|
||||||
|
|
||||||
nfs41_callback_svc does most of its work while in TASK_INTERRUPTIBLE,
|
|
||||||
which is just wrong. Fix that by finishing the wait immediately if we've
|
|
||||||
found that the list has something on it.
|
|
||||||
|
|
||||||
Also, we don't expect this kthread to accept signals, so we should be
|
|
||||||
using a TASK_UNINTERRUPTIBLE sleep instead. That however, opens us up
|
|
||||||
hung task warnings from the watchdog, so have the schedule_timeout
|
|
||||||
wake up every 60s if there's no callback activity.
|
|
||||||
|
|
||||||
Reported-by: "J. Bruce Fields" <bfields@fieldses.org>
|
|
||||||
Signed-off-by: Jeff Layton <jlayton@primarydata.com>
|
|
||||||
Cc: stable@vger.kernel.org
|
|
||||||
Signed-off-by: Trond Myklebust <trond.myklebust@primarydata.com>
|
|
||||||
---
|
|
||||||
fs/nfs/callback.c | 8 +++++---
|
|
||||||
1 file changed, 5 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/fs/nfs/callback.c b/fs/nfs/callback.c
|
|
||||||
index b8fb3a4ef649..351be9205bf8 100644
|
|
||||||
--- a/fs/nfs/callback.c
|
|
||||||
+++ b/fs/nfs/callback.c
|
|
||||||
@@ -128,22 +128,24 @@ nfs41_callback_svc(void *vrqstp)
|
|
||||||
if (try_to_freeze())
|
|
||||||
continue;
|
|
||||||
|
|
||||||
- prepare_to_wait(&serv->sv_cb_waitq, &wq, TASK_INTERRUPTIBLE);
|
|
||||||
+ prepare_to_wait(&serv->sv_cb_waitq, &wq, TASK_UNINTERRUPTIBLE);
|
|
||||||
spin_lock_bh(&serv->sv_cb_lock);
|
|
||||||
if (!list_empty(&serv->sv_cb_list)) {
|
|
||||||
req = list_first_entry(&serv->sv_cb_list,
|
|
||||||
struct rpc_rqst, rq_bc_list);
|
|
||||||
list_del(&req->rq_bc_list);
|
|
||||||
spin_unlock_bh(&serv->sv_cb_lock);
|
|
||||||
+ finish_wait(&serv->sv_cb_waitq, &wq);
|
|
||||||
dprintk("Invoking bc_svc_process()\n");
|
|
||||||
error = bc_svc_process(serv, req, rqstp);
|
|
||||||
dprintk("bc_svc_process() returned w/ error code= %d\n",
|
|
||||||
error);
|
|
||||||
} else {
|
|
||||||
spin_unlock_bh(&serv->sv_cb_lock);
|
|
||||||
- schedule();
|
|
||||||
+ /* schedule_timeout to game the hung task watchdog */
|
|
||||||
+ schedule_timeout(60 * HZ);
|
|
||||||
+ finish_wait(&serv->sv_cb_waitq, &wq);
|
|
||||||
}
|
|
||||||
- finish_wait(&serv->sv_cb_waitq, &wq);
|
|
||||||
}
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
d3fc8316d4d4d04b65cbc2d70799e763 linux-3.19.tar.xz
|
d3fc8316d4d4d04b65cbc2d70799e763 linux-3.19.tar.xz
|
||||||
15d8d2f97ce056488451a5bfb2944603 perf-man-3.19.tar.gz
|
15d8d2f97ce056488451a5bfb2944603 perf-man-3.19.tar.gz
|
||||||
45b8653c33b56672bd0255ddcf9e8c5c patch-3.19-git3.xz
|
99edddd55ccd2254cdaf97898949cb78 patch-3.19-git4.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user