kernel-5.8.0-0.rc5.20200717git07a56bb875af.1
* Fri Jul 17 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc5.20200717git07a56bb875af.1] - 07a56bb875af rebase - redhat/configs: Fix common CONFIGs (Prarit Bhargava) - redhat/configs: General CONFIG cleanups (Prarit Bhargava) - redhat/configs: Update & generalize evaluate_configs (Prarit Bhargava) - arch/x86: Remove vendor specific CPU ID checks (Prarit Bhargava) - Updated changelog for the release based on e9919e11e219 (Fedora Kernel Team) Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
parent
bd3a95eca9
commit
fc8ee97867
128
0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
Normal file
128
0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
Normal file
@ -0,0 +1,128 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Prarit Bhargava <prarit@redhat.com>
|
||||
Date: Thu, 11 Jun 2020 21:03:36 -0400
|
||||
Subject: [PATCH] arch/x86: Remove vendor specific CPU ID checks
|
||||
|
||||
Upstream Status: RHEL only
|
||||
|
||||
After discussions with Devel, QE, Support, and Certification we have
|
||||
decided to drop the CPU specific checks in rh_check_supported().
|
||||
Certification is adopting a new process in which CPU certifications will
|
||||
be tracked on https://catalog.redhat.com.
|
||||
|
||||
Remove the vendor specific CPU ID checks from rh_check_supported().
|
||||
|
||||
Signed-off-by: Prarit Bhargava <prarit@redhat.com>
|
||||
Cc: David Arcari <darcari@redhat.com>
|
||||
---
|
||||
arch/x86/kernel/setup.c | 85 -----------------------------------------
|
||||
1 file changed, 85 deletions(-)
|
||||
|
||||
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
|
||||
index 6d31895c8e92..4e43f6957621 100644
|
||||
--- a/arch/x86/kernel/setup.c
|
||||
+++ b/arch/x86/kernel/setup.c
|
||||
@@ -757,72 +757,6 @@ static void __init trim_low_memory_range(void)
|
||||
}
|
||||
|
||||
#ifdef CONFIG_RHEL_DIFFERENCES
|
||||
-static bool valid_amd_processor(__u8 family, const char *model_id)
|
||||
-{
|
||||
- bool valid;
|
||||
-
|
||||
- switch(family) {
|
||||
- case 0x15:
|
||||
- valid = true;
|
||||
- break;
|
||||
-
|
||||
- case 0x17:
|
||||
- valid = strstr(model_id, "AMD EPYC 7");
|
||||
- break;
|
||||
-
|
||||
- default:
|
||||
- valid = false;
|
||||
- break;
|
||||
- }
|
||||
-
|
||||
- return valid;
|
||||
-}
|
||||
-
|
||||
-static bool valid_intel_processor(__u8 family, __u8 model, __u8 stepping)
|
||||
-{
|
||||
- bool valid;
|
||||
-
|
||||
- if (family != 6)
|
||||
- return false;
|
||||
-
|
||||
- switch(model) {
|
||||
- case INTEL_FAM6_ATOM_GOLDMONT_D:
|
||||
- case INTEL_FAM6_ATOM_GOLDMONT_PLUS:
|
||||
-
|
||||
- case INTEL_FAM6_BROADWELL:
|
||||
- case INTEL_FAM6_BROADWELL_G:
|
||||
- case INTEL_FAM6_BROADWELL_X:
|
||||
- case INTEL_FAM6_BROADWELL_D:
|
||||
-
|
||||
- case INTEL_FAM6_HASWELL:
|
||||
- case INTEL_FAM6_HASWELL_G:
|
||||
- case INTEL_FAM6_HASWELL_L:
|
||||
- case INTEL_FAM6_HASWELL_X:
|
||||
- valid = true;
|
||||
- break;
|
||||
-
|
||||
- case INTEL_FAM6_KABYLAKE:
|
||||
- valid = (stepping <= 10);
|
||||
- break;
|
||||
-
|
||||
- case INTEL_FAM6_KABYLAKE_L:
|
||||
- valid = (stepping <= 11);
|
||||
- break;
|
||||
-
|
||||
- case INTEL_FAM6_SKYLAKE_L:
|
||||
- case INTEL_FAM6_SKYLAKE:
|
||||
- case INTEL_FAM6_SKYLAKE_X:
|
||||
- /* stepping > 4 is Cascade Lake and is not supported */
|
||||
- valid = (stepping <= 4);
|
||||
- break;
|
||||
-
|
||||
- default:
|
||||
- valid = false;
|
||||
- break;
|
||||
- }
|
||||
-
|
||||
- return valid;
|
||||
-}
|
||||
|
||||
static void rh_check_supported(void)
|
||||
{
|
||||
@@ -843,27 +777,8 @@ static void rh_check_supported(void)
|
||||
*/
|
||||
switch (boot_cpu_data.x86_vendor) {
|
||||
case X86_VENDOR_AMD:
|
||||
- if (!valid_amd_processor(boot_cpu_data.x86,
|
||||
- boot_cpu_data.x86_model_id)) {
|
||||
- pr_crit("Detected CPU family %xh model %d\n",
|
||||
- boot_cpu_data.x86,
|
||||
- boot_cpu_data.x86_model);
|
||||
- mark_hardware_unsupported("AMD Processor");
|
||||
- }
|
||||
- break;
|
||||
-
|
||||
case X86_VENDOR_INTEL:
|
||||
- if (!valid_intel_processor(boot_cpu_data.x86,
|
||||
- boot_cpu_data.x86_model,
|
||||
- boot_cpu_data.x86_stepping)) {
|
||||
- pr_crit("Detected CPU family %d model %d stepping %d\n",
|
||||
- boot_cpu_data.x86,
|
||||
- boot_cpu_data.x86_model,
|
||||
- boot_cpu_data.x86_stepping);
|
||||
- mark_hardware_unsupported("Intel Processor");
|
||||
- }
|
||||
break;
|
||||
-
|
||||
default:
|
||||
pr_crit("Detected processor %s %s\n",
|
||||
boot_cpu_data.x86_vendor_id,
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,123 +0,0 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Hans de Goede <hdegoede@redhat.com>
|
||||
Date: Tue, 19 May 2020 12:21:30 +0200
|
||||
Subject: [PATCH] virt: vbox: Fix VBGL_IOCTL_VMMDEV_REQUEST_BIG and _LOG req
|
||||
numbers to match upstream
|
||||
|
||||
Until this commit the mainline kernel version (this version) of the
|
||||
vboxguest module contained a bug where it defined
|
||||
VBGL_IOCTL_VMMDEV_REQUEST_BIG and VBGL_IOCTL_LOG using
|
||||
_IOC(_IOC_READ | _IOC_WRITE, 'V', ...) instead of
|
||||
_IO(V, ...) as the out of tree VirtualBox upstream version does.
|
||||
|
||||
Since the VirtualBox userspace bits are always built against VirtualBox
|
||||
upstream's headers, this means that so far the mainline kernel version
|
||||
of the vboxguest module has been failing these 2 ioctls with -ENOTTY.
|
||||
I guess that VBGL_IOCTL_VMMDEV_REQUEST_BIG is never used causing us to
|
||||
not hit that one and sofar the vboxguest driver has failed to actually
|
||||
log any log messages passed it through VBGL_IOCTL_LOG.
|
||||
|
||||
This commit changes the VBGL_IOCTL_VMMDEV_REQUEST_BIG and VBGL_IOCTL_LOG
|
||||
defines to match the out of tree VirtualBox upstream vboxguest version,
|
||||
while keeping compatibility with the old wrong request defines so as
|
||||
to not break the kernel ABI in case someone has been using the old
|
||||
request defines.
|
||||
|
||||
Fixes: f6ddd094f579 ("virt: Add vboxguest driver for Virtual Box Guest integration UAPI")
|
||||
Cc: stable@vger.kernel.org
|
||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
Upstream Status: https://lore.kernel.org/lkml/20200520195440.38759-1-hdegoede@redhat.com/
|
||||
---
|
||||
drivers/virt/vboxguest/vboxguest_core.c | 4 +++-
|
||||
drivers/virt/vboxguest/vboxguest_core.h | 15 +++++++++++++++
|
||||
drivers/virt/vboxguest/vboxguest_linux.c | 3 ++-
|
||||
include/uapi/linux/vboxguest.h | 4 ++--
|
||||
4 files changed, 22 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/drivers/virt/vboxguest/vboxguest_core.c b/drivers/virt/vboxguest/vboxguest_core.c
|
||||
index b690a8a4bf9e..8fab04e76c14 100644
|
||||
--- a/drivers/virt/vboxguest/vboxguest_core.c
|
||||
+++ b/drivers/virt/vboxguest/vboxguest_core.c
|
||||
@@ -1520,7 +1520,8 @@ int vbg_core_ioctl(struct vbg_session *session, unsigned int req, void *data)
|
||||
|
||||
/* For VMMDEV_REQUEST hdr->type != VBG_IOCTL_HDR_TYPE_DEFAULT */
|
||||
if (req_no_size == VBG_IOCTL_VMMDEV_REQUEST(0) ||
|
||||
- req == VBG_IOCTL_VMMDEV_REQUEST_BIG)
|
||||
+ req == VBG_IOCTL_VMMDEV_REQUEST_BIG ||
|
||||
+ req == VBG_IOCTL_VMMDEV_REQUEST_BIG_ALT)
|
||||
return vbg_ioctl_vmmrequest(gdev, session, data);
|
||||
|
||||
if (hdr->type != VBG_IOCTL_HDR_TYPE_DEFAULT)
|
||||
@@ -1558,6 +1559,7 @@ int vbg_core_ioctl(struct vbg_session *session, unsigned int req, void *data)
|
||||
case VBG_IOCTL_HGCM_CALL(0):
|
||||
return vbg_ioctl_hgcm_call(gdev, session, f32bit, data);
|
||||
case VBG_IOCTL_LOG(0):
|
||||
+ case VBG_IOCTL_LOG_ALT(0):
|
||||
return vbg_ioctl_log(data);
|
||||
}
|
||||
|
||||
diff --git a/drivers/virt/vboxguest/vboxguest_core.h b/drivers/virt/vboxguest/vboxguest_core.h
|
||||
index 4188c12b839f..77c3a9c8255d 100644
|
||||
--- a/drivers/virt/vboxguest/vboxguest_core.h
|
||||
+++ b/drivers/virt/vboxguest/vboxguest_core.h
|
||||
@@ -15,6 +15,21 @@
|
||||
#include <linux/vboxguest.h>
|
||||
#include "vmmdev.h"
|
||||
|
||||
+/*
|
||||
+ * The mainline kernel version (this version) of the vboxguest module
|
||||
+ * contained a bug where it defined VBGL_IOCTL_VMMDEV_REQUEST_BIG and
|
||||
+ * VBGL_IOCTL_LOG using _IOC(_IOC_READ | _IOC_WRITE, 'V', ...) instead
|
||||
+ * of _IO(V, ...) as the out of tree VirtualBox upstream version does.
|
||||
+ *
|
||||
+ * These _ALT definitions keep compatibility with the wrong defines the
|
||||
+ * mainline kernel version used for a while.
|
||||
+ * Note the VirtualBox userspace bits have always been built against
|
||||
+ * VirtualBox upstream's headers, so this is likely not necessary. But
|
||||
+ * we must never break our ABI so we keep these around to be 100% sure.
|
||||
+ */
|
||||
+#define VBG_IOCTL_VMMDEV_REQUEST_BIG_ALT _IOC(_IOC_READ | _IOC_WRITE, 'V', 3, 0)
|
||||
+#define VBG_IOCTL_LOG_ALT(s) _IOC(_IOC_READ | _IOC_WRITE, 'V', 9, s)
|
||||
+
|
||||
struct vbg_session;
|
||||
|
||||
/** VBox guest memory balloon. */
|
||||
diff --git a/drivers/virt/vboxguest/vboxguest_linux.c b/drivers/virt/vboxguest/vboxguest_linux.c
|
||||
index 6e8c0f1c1056..32c2c52f7e84 100644
|
||||
--- a/drivers/virt/vboxguest/vboxguest_linux.c
|
||||
+++ b/drivers/virt/vboxguest/vboxguest_linux.c
|
||||
@@ -131,7 +131,8 @@ static long vbg_misc_device_ioctl(struct file *filp, unsigned int req,
|
||||
* the need for a bounce-buffer and another copy later on.
|
||||
*/
|
||||
is_vmmdev_req = (req & ~IOCSIZE_MASK) == VBG_IOCTL_VMMDEV_REQUEST(0) ||
|
||||
- req == VBG_IOCTL_VMMDEV_REQUEST_BIG;
|
||||
+ req == VBG_IOCTL_VMMDEV_REQUEST_BIG ||
|
||||
+ req == VBG_IOCTL_VMMDEV_REQUEST_BIG_ALT;
|
||||
|
||||
if (is_vmmdev_req)
|
||||
buf = vbg_req_alloc(size, VBG_IOCTL_HDR_TYPE_DEFAULT,
|
||||
diff --git a/include/uapi/linux/vboxguest.h b/include/uapi/linux/vboxguest.h
|
||||
index 9cec58a6a5ea..f79d7abe27db 100644
|
||||
--- a/include/uapi/linux/vboxguest.h
|
||||
+++ b/include/uapi/linux/vboxguest.h
|
||||
@@ -103,7 +103,7 @@ VMMDEV_ASSERT_SIZE(vbg_ioctl_driver_version_info, 24 + 20);
|
||||
|
||||
|
||||
/* IOCTL to perform a VMM Device request larger then 1KB. */
|
||||
-#define VBG_IOCTL_VMMDEV_REQUEST_BIG _IOC(_IOC_READ | _IOC_WRITE, 'V', 3, 0)
|
||||
+#define VBG_IOCTL_VMMDEV_REQUEST_BIG _IO('V', 3)
|
||||
|
||||
|
||||
/** VBG_IOCTL_HGCM_CONNECT data structure. */
|
||||
@@ -198,7 +198,7 @@ struct vbg_ioctl_log {
|
||||
} u;
|
||||
};
|
||||
|
||||
-#define VBG_IOCTL_LOG(s) _IOC(_IOC_READ | _IOC_WRITE, 'V', 9, s)
|
||||
+#define VBG_IOCTL_LOG(s) _IO('V', 9)
|
||||
|
||||
|
||||
/** VBG_IOCTL_WAIT_FOR_EVENTS data structure. */
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,47 +0,0 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Hans de Goede <hdegoede@redhat.com>
|
||||
Date: Tue, 19 May 2020 13:23:06 +0200
|
||||
Subject: [PATCH] virt: vbox: Fix guest capabilities mask check
|
||||
|
||||
Check the passed in capabilities against VMMDEV_GUEST_CAPABILITIES_MASK
|
||||
instead of against VMMDEV_EVENT_VALID_EVENT_MASK.
|
||||
This tightens the allowed mask from 0x7ff to 0x7.
|
||||
|
||||
Fixes: 0ba002bc4393 ("virt: Add vboxguest driver for Virtual Box Guest integration")
|
||||
Cc: stable@vger.kernel.org
|
||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
Upstream Status: https://lore.kernel.org/lkml/20200520195440.38759-1-hdegoede@redhat.com/
|
||||
---
|
||||
drivers/virt/vboxguest/vboxguest_core.c | 2 +-
|
||||
drivers/virt/vboxguest/vmmdev.h | 2 ++
|
||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/virt/vboxguest/vboxguest_core.c b/drivers/virt/vboxguest/vboxguest_core.c
|
||||
index 8fab04e76c14..18ebd7a6af98 100644
|
||||
--- a/drivers/virt/vboxguest/vboxguest_core.c
|
||||
+++ b/drivers/virt/vboxguest/vboxguest_core.c
|
||||
@@ -1444,7 +1444,7 @@ static int vbg_ioctl_change_guest_capabilities(struct vbg_dev *gdev,
|
||||
or_mask = caps->u.in.or_mask;
|
||||
not_mask = caps->u.in.not_mask;
|
||||
|
||||
- if ((or_mask | not_mask) & ~VMMDEV_EVENT_VALID_EVENT_MASK)
|
||||
+ if ((or_mask | not_mask) & ~VMMDEV_GUEST_CAPABILITIES_MASK)
|
||||
return -EINVAL;
|
||||
|
||||
ret = vbg_set_session_capabilities(gdev, session, or_mask, not_mask,
|
||||
diff --git a/drivers/virt/vboxguest/vmmdev.h b/drivers/virt/vboxguest/vmmdev.h
|
||||
index 6337b8d75d96..21f408120e3f 100644
|
||||
--- a/drivers/virt/vboxguest/vmmdev.h
|
||||
+++ b/drivers/virt/vboxguest/vmmdev.h
|
||||
@@ -206,6 +206,8 @@ VMMDEV_ASSERT_SIZE(vmmdev_mask, 24 + 8);
|
||||
* not.
|
||||
*/
|
||||
#define VMMDEV_GUEST_SUPPORTS_GRAPHICS BIT(2)
|
||||
+/* The mask of valid capabilities, for sanity checking. */
|
||||
+#define VMMDEV_GUEST_CAPABILITIES_MASK 0x00000007U
|
||||
|
||||
/** struct vmmdev_hypervisorinfo - Hypervisor info structure. */
|
||||
struct vmmdev_hypervisorinfo {
|
||||
--
|
||||
2.26.2
|
||||
|
@ -68,8 +68,6 @@
|
||||
0001-arm64-allwinner-dts-a64-add-LCD-related-device-nodes.patch
|
||||
0001-e1000e-bump-up-timeout-to-wait-when-ME-un-configure-.patch
|
||||
0001-x86-Fix-compile-issues-with-rh_check_supported.patch
|
||||
0001-virt-vbox-Fix-VBGL_IOCTL_VMMDEV_REQUEST_BIG-and-_LOG.patch
|
||||
0001-virt-vbox-Fix-guest-capabilities-mask-check.patch
|
||||
0001-virt-vbox-Rename-guest_caps-struct-members-to-set_gu.patch
|
||||
0001-virt-vbox-Add-vbg_set_host_capabilities-helper-funct.patch
|
||||
0001-virt-vbox-Add-support-for-the-new-VBG_IOCTL_ACQUIRE_.patch
|
||||
@ -77,6 +75,7 @@
|
||||
0001-virt-vbox-Log-unknown-ioctl-requests-as-error.patch
|
||||
0001-PCI-tegra-Revert-raw_violation_fixup-for-tegra124.patch
|
||||
0001-redhat-Replace-hardware.redhat.com-link-in-Unsupport.patch
|
||||
0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
||||
0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||
0001-selinux-allow-reading-labels-before-policy-is-loaded.patch
|
||||
0001-Revert-dt-bindings-panel-add-binding-for-Xingbangda-.patch
|
||||
|
102
kernel.spec
102
kernel.spec
@ -30,7 +30,7 @@ Summary: The Linux kernel
|
||||
# For a stable, released kernel, released_kernel should be 1.
|
||||
%global released_kernel 0
|
||||
|
||||
%global distro_build 0.rc5.20200715gite9919e11e219.1
|
||||
%global distro_build 0.rc5.20200717git07a56bb875af.1
|
||||
|
||||
%if 0%{?fedora}
|
||||
%define secure_boot_arch x86_64
|
||||
@ -69,13 +69,13 @@ Summary: The Linux kernel
|
||||
%endif
|
||||
|
||||
%define rpmversion 5.8.0
|
||||
%define pkgrelease 0.rc5.20200715gite9919e11e219.1
|
||||
%define pkgrelease 0.rc5.20200717git07a56bb875af.1
|
||||
|
||||
# This is needed to do merge window version magic
|
||||
%define patchlevel 8
|
||||
|
||||
# allow pkg_release to have configurable %%{?dist} tag
|
||||
%define specrelease 0.rc5.20200715gite9919e11e219.1%{?buildid}%{?dist}
|
||||
%define specrelease 0.rc5.20200717git07a56bb875af.1%{?buildid}%{?dist}
|
||||
|
||||
%define pkg_release %{specrelease}
|
||||
|
||||
@ -567,7 +567,7 @@ BuildRequires: asciidoc
|
||||
# exact git commit you can run
|
||||
#
|
||||
# xzcat -qq ${TARBALL} | git get-tar-commit-id
|
||||
Source0: linux-20200715gite9919e11e219.tar.xz
|
||||
Source0: linux-20200717git07a56bb875af.tar.xz
|
||||
|
||||
Source1: Makefile.rhelver
|
||||
|
||||
@ -591,13 +591,13 @@ Source15: redhatsecureboot301.cer
|
||||
Source16: secureboot_s390.cer
|
||||
Source17: secureboot_ppc.cer
|
||||
|
||||
%define secureboot_ca_0 %{SOURCE12}
|
||||
%define secureboot_ca_1 %{SOURCE13}
|
||||
%define secureboot_ca_1 %{SOURCE12}
|
||||
%define secureboot_ca_0 %{SOURCE13}
|
||||
%ifarch x86_64 aarch64
|
||||
%define secureboot_key_0 %{SOURCE14}
|
||||
%define pesign_name_0 redhatsecureboot501
|
||||
%define secureboot_key_1 %{SOURCE15}
|
||||
%define pesign_name_1 redhatsecureboot301
|
||||
%define secureboot_key_1 %{SOURCE14}
|
||||
%define pesign_name_1 redhatsecureboot501
|
||||
%define secureboot_key_0 %{SOURCE15}
|
||||
%define pesign_name_0 redhatsecureboot301
|
||||
%endif
|
||||
%ifarch s390x
|
||||
%define secureboot_key_0 %{SOURCE16}
|
||||
@ -616,12 +616,12 @@ Source13: redhatsecurebootca2.cer
|
||||
Source14: redhatsecureboot401.cer
|
||||
Source15: redhatsecureboot003.cer
|
||||
|
||||
%define secureboot_ca_0 %{SOURCE12}
|
||||
%define secureboot_ca_1 %{SOURCE13}
|
||||
%define secureboot_key_0 %{SOURCE14}
|
||||
%define pesign_name_0 redhatsecureboot401
|
||||
%define secureboot_key_1 %{SOURCE15}
|
||||
%define pesign_name_1 redhatsecureboot003
|
||||
%define secureboot_ca_1 %{SOURCE12}
|
||||
%define secureboot_ca_0 %{SOURCE13}
|
||||
%define secureboot_key_1 %{SOURCE14}
|
||||
%define pesign_name_1 redhatsecureboot401
|
||||
%define secureboot_key_0 %{SOURCE15}
|
||||
%define pesign_name_0 redhatsecureboot003
|
||||
|
||||
# released_kernel
|
||||
%endif
|
||||
@ -786,34 +786,33 @@ Patch68: 0001-drm-sun4i-sun6i_mipi_dsi-fix-horizontal-timing-calcu.patch
|
||||
Patch69: 0001-arm64-allwinner-dts-a64-add-LCD-related-device-nodes.patch
|
||||
Patch70: 0001-e1000e-bump-up-timeout-to-wait-when-ME-un-configure-.patch
|
||||
Patch71: 0001-x86-Fix-compile-issues-with-rh_check_supported.patch
|
||||
Patch72: 0001-virt-vbox-Fix-VBGL_IOCTL_VMMDEV_REQUEST_BIG-and-_LOG.patch
|
||||
Patch73: 0001-virt-vbox-Fix-guest-capabilities-mask-check.patch
|
||||
Patch74: 0001-virt-vbox-Rename-guest_caps-struct-members-to-set_gu.patch
|
||||
Patch75: 0001-virt-vbox-Add-vbg_set_host_capabilities-helper-funct.patch
|
||||
Patch76: 0001-virt-vbox-Add-support-for-the-new-VBG_IOCTL_ACQUIRE_.patch
|
||||
Patch77: 0001-virt-vbox-Add-a-few-new-vmmdev-request-types-to-the-.patch
|
||||
Patch78: 0001-virt-vbox-Log-unknown-ioctl-requests-as-error.patch
|
||||
Patch79: 0001-PCI-tegra-Revert-raw_violation_fixup-for-tegra124.patch
|
||||
Patch80: 0001-redhat-Replace-hardware.redhat.com-link-in-Unsupport.patch
|
||||
Patch81: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||
Patch82: 0001-selinux-allow-reading-labels-before-policy-is-loaded.patch
|
||||
Patch83: 0001-Revert-dt-bindings-panel-add-binding-for-Xingbangda-.patch
|
||||
Patch84: 0001-Revert-drm-panel-add-Xingbangda-XBD599-panel.patch
|
||||
Patch85: 0001-Revert-drm-sun4i-sun6i_mipi_dsi-fix-horizontal-timin.patch
|
||||
Patch86: 0001-Revert-arm64-allwinner-dts-a64-add-LCD-related-devic.patch
|
||||
Patch87: 0001-dt-bindings-vendor-prefixes-Add-Xingbangda.patch
|
||||
Patch88: 0001-dt-bindings-panel-Convert-rocktech-jh057n00900-to-ya.patch
|
||||
Patch89: 0001-dt-bindings-panel-Add-compatible-for-Xingbangda-XBD5.patch
|
||||
Patch90: 0001-drm-panel-rocktech-jh057n00900-Rename-the-driver-to-.patch
|
||||
Patch91: 0001-drm-panel-st7703-Rename-functions-from-jh057n-prefix.patch
|
||||
Patch92: 0001-drm-panel-st7703-Prepare-for-supporting-multiple-pan.patch
|
||||
Patch93: 0001-drm-panel-st7703-Move-code-specific-to-jh057n-closer.patch
|
||||
Patch94: 0001-drm-panel-st7703-Move-generic-part-of-init-sequence-.patch
|
||||
Patch95: 0001-drm-panel-st7703-Add-support-for-Xingbangda-XBD599.patch
|
||||
Patch96: 0001-drm-panel-st7703-Enter-sleep-after-display-off.patch
|
||||
Patch97: 0001-drm-panel-st7703-Assert-reset-prior-to-powering-down.patch
|
||||
Patch98: 0001-arm64-dts-sun50i-a64-pinephone-Enable-LCD-support-on.patch
|
||||
Patch99: 0001-arm64-dts-sun50i-a64-pinephone-Add-touchscreen-suppo.patch
|
||||
Patch72: 0001-virt-vbox-Rename-guest_caps-struct-members-to-set_gu.patch
|
||||
Patch73: 0001-virt-vbox-Add-vbg_set_host_capabilities-helper-funct.patch
|
||||
Patch74: 0001-virt-vbox-Add-support-for-the-new-VBG_IOCTL_ACQUIRE_.patch
|
||||
Patch75: 0001-virt-vbox-Add-a-few-new-vmmdev-request-types-to-the-.patch
|
||||
Patch76: 0001-virt-vbox-Log-unknown-ioctl-requests-as-error.patch
|
||||
Patch77: 0001-PCI-tegra-Revert-raw_violation_fixup-for-tegra124.patch
|
||||
Patch78: 0001-redhat-Replace-hardware.redhat.com-link-in-Unsupport.patch
|
||||
Patch79: 0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
||||
Patch80: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||
Patch81: 0001-selinux-allow-reading-labels-before-policy-is-loaded.patch
|
||||
Patch82: 0001-Revert-dt-bindings-panel-add-binding-for-Xingbangda-.patch
|
||||
Patch83: 0001-Revert-drm-panel-add-Xingbangda-XBD599-panel.patch
|
||||
Patch84: 0001-Revert-drm-sun4i-sun6i_mipi_dsi-fix-horizontal-timin.patch
|
||||
Patch85: 0001-Revert-arm64-allwinner-dts-a64-add-LCD-related-devic.patch
|
||||
Patch86: 0001-dt-bindings-vendor-prefixes-Add-Xingbangda.patch
|
||||
Patch87: 0001-dt-bindings-panel-Convert-rocktech-jh057n00900-to-ya.patch
|
||||
Patch88: 0001-dt-bindings-panel-Add-compatible-for-Xingbangda-XBD5.patch
|
||||
Patch89: 0001-drm-panel-rocktech-jh057n00900-Rename-the-driver-to-.patch
|
||||
Patch90: 0001-drm-panel-st7703-Rename-functions-from-jh057n-prefix.patch
|
||||
Patch91: 0001-drm-panel-st7703-Prepare-for-supporting-multiple-pan.patch
|
||||
Patch92: 0001-drm-panel-st7703-Move-code-specific-to-jh057n-closer.patch
|
||||
Patch93: 0001-drm-panel-st7703-Move-generic-part-of-init-sequence-.patch
|
||||
Patch94: 0001-drm-panel-st7703-Add-support-for-Xingbangda-XBD599.patch
|
||||
Patch95: 0001-drm-panel-st7703-Enter-sleep-after-display-off.patch
|
||||
Patch96: 0001-drm-panel-st7703-Assert-reset-prior-to-powering-down.patch
|
||||
Patch97: 0001-arm64-dts-sun50i-a64-pinephone-Enable-LCD-support-on.patch
|
||||
Patch98: 0001-arm64-dts-sun50i-a64-pinephone-Add-touchscreen-suppo.patch
|
||||
|
||||
%endif
|
||||
|
||||
@ -1309,8 +1308,8 @@ ApplyOptionalPatch()
|
||||
fi
|
||||
}
|
||||
|
||||
%setup -q -n kernel-20200715gite9919e11e219 -c
|
||||
mv linux-20200715gite9919e11e219 linux-%{KVERREL}
|
||||
%setup -q -n kernel-20200717git07a56bb875af -c
|
||||
mv linux-20200717git07a56bb875af linux-%{KVERREL}
|
||||
|
||||
cd linux-%{KVERREL}
|
||||
cp -a %{SOURCE1} .
|
||||
@ -1387,8 +1386,6 @@ ApplyOptionalPatch 0001-drm-sun4i-sun6i_mipi_dsi-fix-horizontal-timing-calcu.pat
|
||||
ApplyOptionalPatch 0001-arm64-allwinner-dts-a64-add-LCD-related-device-nodes.patch
|
||||
ApplyOptionalPatch 0001-e1000e-bump-up-timeout-to-wait-when-ME-un-configure-.patch
|
||||
ApplyOptionalPatch 0001-x86-Fix-compile-issues-with-rh_check_supported.patch
|
||||
ApplyOptionalPatch 0001-virt-vbox-Fix-VBGL_IOCTL_VMMDEV_REQUEST_BIG-and-_LOG.patch
|
||||
ApplyOptionalPatch 0001-virt-vbox-Fix-guest-capabilities-mask-check.patch
|
||||
ApplyOptionalPatch 0001-virt-vbox-Rename-guest_caps-struct-members-to-set_gu.patch
|
||||
ApplyOptionalPatch 0001-virt-vbox-Add-vbg_set_host_capabilities-helper-funct.patch
|
||||
ApplyOptionalPatch 0001-virt-vbox-Add-support-for-the-new-VBG_IOCTL_ACQUIRE_.patch
|
||||
@ -1396,6 +1393,7 @@ ApplyOptionalPatch 0001-virt-vbox-Add-a-few-new-vmmdev-request-types-to-the-.pat
|
||||
ApplyOptionalPatch 0001-virt-vbox-Log-unknown-ioctl-requests-as-error.patch
|
||||
ApplyOptionalPatch 0001-PCI-tegra-Revert-raw_violation_fixup-for-tegra124.patch
|
||||
ApplyOptionalPatch 0001-redhat-Replace-hardware.redhat.com-link-in-Unsupport.patch
|
||||
ApplyOptionalPatch 0001-arch-x86-Remove-vendor-specific-CPU-ID-checks.patch
|
||||
ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
|
||||
ApplyOptionalPatch 0001-selinux-allow-reading-labels-before-policy-is-loaded.patch
|
||||
ApplyOptionalPatch 0001-Revert-dt-bindings-panel-add-binding-for-Xingbangda-.patch
|
||||
@ -2848,6 +2846,14 @@ fi
|
||||
#
|
||||
#
|
||||
%changelog
|
||||
* Fri Jul 17 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc5.20200717git07a56bb875af.1]
|
||||
- 07a56bb875af rebase
|
||||
- redhat/configs: Fix common CONFIGs (Prarit Bhargava)
|
||||
- redhat/configs: General CONFIG cleanups (Prarit Bhargava)
|
||||
- redhat/configs: Update & generalize evaluate_configs (Prarit Bhargava)
|
||||
- arch/x86: Remove vendor specific CPU ID checks (Prarit Bhargava)
|
||||
- Updated changelog for the release based on e9919e11e219 (Fedora Kernel Team)
|
||||
|
||||
* Wed Jul 15 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.8.0-0.rc5.20200715gite9919e11e219.1]
|
||||
- e9919e11e219 rebase
|
||||
- arm64: dts: sun50i-a64-pinephone: Add touchscreen support (Ondrej Jirman)
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (linux-20200715gite9919e11e219.tar.xz) = b2fad0748427144e3af77e195d77395d89ff80a20cfdc0c1a80eec4193c0b68af49e548be6edc9c685e302844caae27bf538c1994f3bc8e3a446fad8aa28b662
|
||||
SHA512 (kernel-abi-whitelists-5.8.0-0.rc5.20200715gite9919e11e219.1.tar.bz2) = af377a88a76dbfdd440afdd7cab2d1717b47cd85c73f063e446364e987a59a6e971768d241e1393c4d807801f29e9a37609e4b8f47adbb9a37e43fd9b593684d
|
||||
SHA512 (kernel-kabi-dw-5.8.0-0.rc5.20200715gite9919e11e219.1.tar.bz2) = 6b067d03da6e9952eefa759234cc0f541bc45b30bd4f498e0d2090de112503875f8f88c81a0f3efc7dc9c93493c03aac6d41c2b32199a13e5fe4ae790b0b948f
|
||||
SHA512 (linux-20200717git07a56bb875af.tar.xz) = da8e5cc6515e6fdd66acee550bc3e552af9dbc190f1193733c1f4dc77ff2d9fe77ed9652d7f44418ebea0f7635a8b64a6e042d5d98384701f5f91493f006980b
|
||||
SHA512 (kernel-abi-whitelists-5.8.0-0.rc5.20200717git07a56bb875af.1.tar.bz2) = 6bced500b7240924cb8beb9ed9c321980f448dd06aa37d1392f3b6cafca41a898d1b0c7fae30824fb58521783bdc0b6e007a686ec3b721d4e3548e606089615f
|
||||
SHA512 (kernel-kabi-dw-5.8.0-0.rc5.20200717git07a56bb875af.1.tar.bz2) = c56a5f3184002cda31ec2e9930ac26561d0943156555db71fa23ceca0d8a680deb758a89660007c5c40775ce87e500a0dd9f7f0bdab8b1dc2740fef97bd863b4
|
||||
|
Loading…
Reference in New Issue
Block a user