kernel-5.11.19-0

* Fri May 07 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.19-0]
- Fedora-5.12: Make amd_pinctrl module builtin (Hans de Goede)
- ALSA: hda/realtek: Fix silent headphone output on ASUS UX430UA (Takashi Iwai)
- nitro_enclaves: Fix stale file descriptors on failed usercopy (Mathias Krause)
Resolves: rhbz#

Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
This commit is contained in:
Justin M. Forbes 2021-05-07 08:40:12 -05:00
parent 4a0e1984f8
commit fbd93473ed
8 changed files with 78 additions and 22 deletions

View File

@ -1,3 +1,6 @@
https://gitlab.com/cki-project/kernel-ark/-/commit/398fc8a1fce86d37d63fefc15daca4da0f6189dd
398fc8a1fce86d37d63fefc15daca4da0f6189dd ALSA: hda/realtek: Fix silent headphone output on ASUS UX430UA
https://gitlab.com/cki-project/kernel-ark/-/commit/3f376f878f898469dfbbc1b244b20ffb69f00076
3f376f878f898469dfbbc1b244b20ffb69f00076 nitro_enclaves: Fix stale file descriptors on failed usercopy

View File

@ -4595,7 +4595,7 @@ CONFIG_PHYSICAL_START=0x400000
CONFIG_PID_NS=y
CONFIG_PINCONF=y
CONFIG_PINCTRL_ALDERLAKE=m
CONFIG_PINCTRL_AMD=m
CONFIG_PINCTRL_AMD=y
CONFIG_PINCTRL_BAYTRAIL=y
CONFIG_PINCTRL_BROXTON=m
CONFIG_PINCTRL_CANNONLAKE=m

View File

@ -4573,7 +4573,7 @@ CONFIG_PHYSICAL_START=0x400000
CONFIG_PID_NS=y
CONFIG_PINCONF=y
CONFIG_PINCTRL_ALDERLAKE=m
CONFIG_PINCTRL_AMD=m
CONFIG_PINCTRL_AMD=y
CONFIG_PINCTRL_BAYTRAIL=y
CONFIG_PINCTRL_BROXTON=m
CONFIG_PINCTRL_CANNONLAKE=m

View File

@ -4633,7 +4633,7 @@ CONFIG_PHYSICAL_START=0x1000000
CONFIG_PID_NS=y
CONFIG_PINCONF=y
CONFIG_PINCTRL_ALDERLAKE=m
CONFIG_PINCTRL_AMD=m
CONFIG_PINCTRL_AMD=y
CONFIG_PINCTRL_BAYTRAIL=y
CONFIG_PINCTRL_BROXTON=m
CONFIG_PINCTRL_CANNONLAKE=m

View File

@ -4611,7 +4611,7 @@ CONFIG_PHYSICAL_START=0x1000000
CONFIG_PID_NS=y
CONFIG_PINCONF=y
CONFIG_PINCTRL_ALDERLAKE=m
CONFIG_PINCTRL_AMD=m
CONFIG_PINCTRL_AMD=y
CONFIG_PINCTRL_BAYTRAIL=y
CONFIG_PINCTRL_BROXTON=m
CONFIG_PINCTRL_CANNONLAKE=m

View File

@ -104,7 +104,7 @@ Summary: The Linux kernel
%define primary_target rhel
%endif
%define rpmversion 5.11.18
%define rpmversion 5.11.19
%define stableversion 5.11
%define pkgrelease 200
@ -603,7 +603,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
Source0: linux-5.11.18.tar.xz
Source0: linux-5.11.19.tar.xz
Source1: Makefile.rhelver
@ -1251,8 +1251,8 @@ ApplyOptionalPatch()
fi
}
%setup -q -n kernel-5.11.18 -c
mv linux-5.11.18 linux-%{KVERREL}
%setup -q -n kernel-5.11.19 -c
mv linux-5.11.19 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@ -2765,7 +2765,9 @@ fi
#
#
%changelog
* Mon May 03 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.18-200]
* Fri May 07 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.19-0]
- Fedora-5.12: Make amd_pinctrl module builtin (Hans de Goede)
- ALSA: hda/realtek: Fix silent headphone output on ASUS UX430UA (Takashi Iwai)
- nitro_enclaves: Fix stale file descriptors on failed usercopy (Mathias Krause)
* Mon May 03 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.18-0]

View File

@ -72,6 +72,7 @@
security/security.c | 6 +
sound/hda/Kconfig | 14 +
sound/hda/intel-dsp-config.c | 29 +-
sound/pci/hda/patch_realtek.c | 18 +
sound/soc/sof/intel/apl.c | 3 +-
sound/soc/sof/intel/cnl.c | 3 +-
sound/soc/sof/intel/hda-dsp.c | 6 +
@ -81,7 +82,7 @@
sound/soc/sof/ops.h | 8 +
sound/soc/sof/sof-pci-dev.c | 2 +-
sound/soc/sof/sof-priv.h | 4 +-
83 files changed, 2404 insertions(+), 366 deletions(-)
84 files changed, 2422 insertions(+), 366 deletions(-)
diff --git a/Documentation/ABI/testing/sysfs-platform_profile b/Documentation/ABI/testing/sysfs-platform_profile
new file mode 100644
@ -295,7 +296,7 @@ index 000000000000..c33a71263d9e
+ 2. Add the new profile name, along with a clear description of the
+ expected behaviour, to the sysfs-platform_profile ABI documentation.
diff --git a/Makefile b/Makefile
index 6cf79e492f72..9d762784ce21 100644
index a3b7a2602100..6eb7ce52c05b 100644
--- a/Makefile
+++ b/Makefile
@@ -495,6 +495,7 @@ KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
@ -1477,7 +1478,7 @@ index b3631b722de3..5089dbd240f4 100644
return;
diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c
index 99eb0d7bbc44..85feb5742296 100644
index 31a197f172fd..218cfb6faa27 100644
--- a/drivers/gpu/drm/i915/i915_drv.c
+++ b/drivers/gpu/drm/i915/i915_drv.c
@@ -609,14 +609,15 @@ static int i915_driver_hw_probe(struct drm_i915_private *dev_priv)
@ -3046,7 +3047,7 @@ index 5b81bafa5c16..cc42af2a0a98 100644
}
#endif
diff --git a/drivers/platform/x86/thinkpad_acpi.c b/drivers/platform/x86/thinkpad_acpi.c
index 9f8da7155a89..9ecf7829b3d8 100644
index 77d457915925..02f9c281dd54 100644
--- a/drivers/platform/x86/thinkpad_acpi.c
+++ b/drivers/platform/x86/thinkpad_acpi.c
@@ -66,6 +66,7 @@
@ -3057,7 +3058,7 @@ index 9f8da7155a89..9ecf7829b3d8 100644
#include <sound/core.h>
#include <sound/control.h>
#include <sound/initval.h>
@@ -9850,6 +9851,11 @@ static struct ibm_struct lcdshadow_driver_data = {
@@ -9863,6 +9864,11 @@ static struct ibm_struct lcdshadow_driver_data = {
* Thinkpad sensor interfaces
*/
@ -3069,7 +3070,7 @@ index 9f8da7155a89..9ecf7829b3d8 100644
#define DYTC_CMD_GET 2 /* To get current IC function and mode */
#define DYTC_GET_LAPMODE_BIT 17 /* Set when in lapmode */
@@ -9860,17 +9866,56 @@ static bool has_palmsensor;
@@ -9873,17 +9879,56 @@ static bool has_palmsensor;
static bool has_lapsensor;
static bool palm_state;
static bool lap_state;
@ -3131,7 +3132,7 @@ index 9f8da7155a89..9ecf7829b3d8 100644
*present = true; /*If we get his far, we have lapmode support*/
*state = output & BIT(DYTC_GET_LAPMODE_BIT) ? true : false;
@@ -9968,7 +10013,18 @@ static int tpacpi_proxsensor_init(struct ibm_init_struct *iibm)
@@ -9981,7 +10026,18 @@ static int tpacpi_proxsensor_init(struct ibm_init_struct *iibm)
if (err)
return err;
}
@ -3151,7 +3152,7 @@ index 9f8da7155a89..9ecf7829b3d8 100644
err = sysfs_create_file(&tpacpi_pdev->dev.kobj, &dev_attr_dytc_lapmode.attr);
if (err)
return err;
@@ -9989,6 +10045,434 @@ static struct ibm_struct proxsensor_driver_data = {
@@ -10002,6 +10058,434 @@ static struct ibm_struct proxsensor_driver_data = {
.exit = proxsensor_exit,
};
@ -3586,7 +3587,7 @@ index 9f8da7155a89..9ecf7829b3d8 100644
/****************************************************************************
****************************************************************************
*
@@ -10037,8 +10521,12 @@ static void tpacpi_driver_event(const unsigned int hkey_event)
@@ -10050,8 +10534,12 @@ static void tpacpi_driver_event(const unsigned int hkey_event)
mutex_unlock(&kbdlight_mutex);
}
@ -3600,7 +3601,7 @@ index 9f8da7155a89..9ecf7829b3d8 100644
}
static void hotkey_driver_event(const unsigned int scancode)
@@ -10481,6 +10969,14 @@ static struct ibm_init_struct ibms_init[] __initdata = {
@@ -10494,6 +10982,14 @@ static struct ibm_init_struct ibms_init[] __initdata = {
.init = tpacpi_proxsensor_init,
.data = &proxsensor_driver_data,
},
@ -4192,6 +4193,56 @@ index c45686172517..68bb977c6a37 100644
.acpi_hid = "808622A8",
},
#endif
diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index a7544b77d3f7..7569fd8c9cff 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -5667,6 +5667,18 @@ static void alc_fixup_tpt470_dacs(struct hda_codec *codec,
spec->gen.preferred_dacs = preferred_pairs;
}
+static void alc295_fixup_asus_dacs(struct hda_codec *codec,
+ const struct hda_fixup *fix, int action)
+{
+ static const hda_nid_t preferred_pairs[] = {
+ 0x17, 0x02, 0x21, 0x03, 0
+ };
+ struct alc_spec *spec = codec->spec;
+
+ if (action == HDA_FIXUP_ACT_PRE_PROBE)
+ spec->gen.preferred_dacs = preferred_pairs;
+}
+
static void alc_shutup_dell_xps13(struct hda_codec *codec)
{
struct alc_spec *spec = codec->spec;
@@ -6427,6 +6439,7 @@ enum {
ALC282_FIXUP_ACER_DISABLE_LINEOUT,
ALC255_FIXUP_ACER_LIMIT_INT_MIC_BOOST,
ALC256_FIXUP_ACER_HEADSET_MIC,
+ ALC295_FIXUP_ASUS_DACS,
};
static const struct hda_fixup alc269_fixups[] = {
@@ -7901,6 +7914,10 @@ static const struct hda_fixup alc269_fixups[] = {
.chained = true,
.chain_id = ALC269_FIXUP_HEADSET_MODE_NO_HP_MIC
},
+ [ALC295_FIXUP_ASUS_DACS] = {
+ .type = HDA_FIXUP_FUNC,
+ .v.func = alc295_fixup_asus_dacs,
+ },
};
static const struct snd_pci_quirk alc269_fixup_tbl[] = {
@@ -8096,6 +8113,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
SND_PCI_QUIRK(0x1043, 0x1427, "Asus Zenbook UX31E", ALC269VB_FIXUP_ASUS_ZENBOOK),
SND_PCI_QUIRK(0x1043, 0x1517, "Asus Zenbook UX31A", ALC269VB_FIXUP_ASUS_ZENBOOK_UX31A),
SND_PCI_QUIRK(0x1043, 0x16e3, "ASUS UX50", ALC269_FIXUP_STEREO_DMIC),
+ SND_PCI_QUIRK(0x1043, 0x1740, "ASUS UX430UA", ALC295_FIXUP_ASUS_DACS),
SND_PCI_QUIRK(0x1043, 0x17d1, "ASUS UX431FL", ALC294_FIXUP_ASUS_DUAL_SPK),
SND_PCI_QUIRK(0x1043, 0x18b1, "Asus MJ401TA", ALC256_FIXUP_ASUS_HEADSET_MIC),
SND_PCI_QUIRK(0x1043, 0x18f1, "Asus FX505DT", ALC256_FIXUP_ASUS_HEADSET_MIC),
diff --git a/sound/soc/sof/intel/apl.c b/sound/soc/sof/intel/apl.c
index fc29b91b8932..c7ed2b3d6abc 100644
--- a/sound/soc/sof/intel/apl.c

View File

@ -1,3 +1,3 @@
SHA512 (linux-5.11.18.tar.xz) = 05b7bb0a0653bef5c34ec5831429ebdaf00fe700b2dbc58f729c69c4c72f1adea00a29fbd70425b1bc07a462dcbb9aceefe374431897ba20afca6a90863dce2d
SHA512 (kernel-abi-whitelists-5.11.18-200.tar.bz2) = 758da71cc47ea748aa6af032239fc07ffe717c23011b9f2c80ab2f2d78661957c418f5b092fc22f7be98520ede3d7d57c0ee9e20158c21059a3689d10595b8a5
SHA512 (kernel-kabi-dw-5.11.18-200.tar.bz2) = 10e7f20555d1cc2f8d10c9a58f22cb2e189e9bb4286d7d4ee30e58c9b95aff5ee7774bdf34b5e75d5211056b9a393d0d3fb76c610572ca6c04b8068d8ae74399
SHA512 (linux-5.11.19.tar.xz) = 92284df3abe828cb2fafa4ae9e04e184050050ad7f4daac9493f4bcbde08e0d21e4e1993f3075ccbeafb3fff1a354c8ea4ead10fc0ce40e7058bcd39528cdb6c
SHA512 (kernel-abi-whitelists-5.11.19-200.tar.bz2) = 2fce97d202d3fe787bbd8c1fabe75cf7e1ee567929d9a239f776467d1720f0ba9f3d13e5bb130b60d0af46b5446a39afb42c036f9f97fb37ebcd49b1deb78ada
SHA512 (kernel-kabi-dw-5.11.19-200.tar.bz2) = 5f44444b048c7eff537756c562008f76af3c2e7b91e84377033e01d88f04c544ba7c8a7290a263ce26b812fd06a719fa291ac492f484de0daf9bfeb8c0274c94