Add support for Atheros 04ca:3004 bluetooth devices (rhbz 844750)
This commit is contained in:
parent
5c860185af
commit
f540242774
@ -0,0 +1,61 @@
|
||||
From fe7963cbe464048cfae4523975aa208a6c7dc420 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Boyer <jwboyer@redhat.com>
|
||||
Date: Mon, 18 Feb 2013 10:32:13 -0500
|
||||
Subject: [PATCH] bluetooth: Add support for atheros 04ca:3004 device to ath3k
|
||||
|
||||
Yet another version of the atheros bluetooth chipset
|
||||
|
||||
T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
|
||||
D: Ver= 1.10 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
|
||||
P: Vendor=04ca ProdID=3004 Rev=00.01
|
||||
S: Manufacturer=Atheros Communications
|
||||
S: Product=Bluetooth USB Host Controller
|
||||
S: SerialNumber=Alaska Day 2006
|
||||
C: #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
|
||||
I: If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
|
||||
I: If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
|
||||
|
||||
This resolves https://bugzilla.redhat.com/show_bug.cgi?id=844750
|
||||
|
||||
Reported-by: niktr@mail.ru
|
||||
Signed-off-by: Josh Boyer <jwboyer@redhat.com>
|
||||
---
|
||||
drivers/bluetooth/ath3k.c | 2 ++
|
||||
drivers/bluetooth/btusb.c | 1 +
|
||||
2 files changed, 3 insertions(+)
|
||||
|
||||
diff --git a/drivers/bluetooth/ath3k.c b/drivers/bluetooth/ath3k.c
|
||||
index 33c9a44..b9908dd 100644
|
||||
--- a/drivers/bluetooth/ath3k.c
|
||||
+++ b/drivers/bluetooth/ath3k.c
|
||||
@@ -76,6 +76,7 @@ static struct usb_device_id ath3k_table[] = {
|
||||
{ USB_DEVICE(0x0CF3, 0x3004) },
|
||||
{ USB_DEVICE(0x0CF3, 0x311D) },
|
||||
{ USB_DEVICE(0x13d3, 0x3375) },
|
||||
+ { USB_DEVICE(0x04CA, 0x3004) },
|
||||
{ USB_DEVICE(0x04CA, 0x3005) },
|
||||
{ USB_DEVICE(0x04CA, 0x3006) },
|
||||
{ USB_DEVICE(0x04CA, 0x3008) },
|
||||
@@ -108,6 +109,7 @@ static struct usb_device_id ath3k_blist_tbl[] = {
|
||||
{ USB_DEVICE(0x0cf3, 0x3004), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x0cf3, 0x311D), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x13d3, 0x3375), .driver_info = BTUSB_ATH3012 },
|
||||
+ { USB_DEVICE(0x04ca, 0x3004), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x04ca, 0x3005), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x04ca, 0x3006), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x04ca, 0x3008), .driver_info = BTUSB_ATH3012 },
|
||||
diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
|
||||
index 7e351e3..59cde8e 100644
|
||||
--- a/drivers/bluetooth/btusb.c
|
||||
+++ b/drivers/bluetooth/btusb.c
|
||||
@@ -134,6 +134,7 @@ static struct usb_device_id blacklist_table[] = {
|
||||
{ USB_DEVICE(0x0cf3, 0x3004), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x0cf3, 0x311d), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x13d3, 0x3375), .driver_info = BTUSB_ATH3012 },
|
||||
+ { USB_DEVICE(0x04ca, 0x3004), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x04ca, 0x3005), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x04ca, 0x3006), .driver_info = BTUSB_ATH3012 },
|
||||
{ USB_DEVICE(0x04ca, 0x3008), .driver_info = BTUSB_ATH3012 },
|
||||
--
|
||||
1.8.1.2
|
||||
|
13
kernel.spec
13
kernel.spec
@ -745,17 +745,20 @@ Patch21247: ath9k_rx_dma_stop_check.patch
|
||||
#rhbz 910126
|
||||
Patch21249: pstore-Create-a-convenient-mount-point-for-pstore.patch
|
||||
|
||||
#rhbz 844750
|
||||
Patch21250: 0001-bluetooth-Add-support-for-atheros-04ca-3004-device-t.patch
|
||||
|
||||
#rhbz 909591
|
||||
Patch21255: usb-cypress-supertop.patch
|
||||
|
||||
#rhbz 812111
|
||||
Patch21260: alps-v2.patch
|
||||
|
||||
Patch22000: weird-root-dentry-name-debug.patch
|
||||
|
||||
#selinux ptrace child permissions
|
||||
Patch22001: selinux-apply-different-permission-to-ptrace-child.patch
|
||||
|
||||
#rhbz 812111
|
||||
Patch21260: alps-v2.patch
|
||||
|
||||
# END OF PATCH DEFINITIONS
|
||||
|
||||
%endif
|
||||
@ -1458,6 +1461,9 @@ ApplyPatch pstore-Create-a-convenient-mount-point-for-pstore.patch
|
||||
#rhbz 909591
|
||||
ApplyPatch usb-cypress-supertop.patch
|
||||
|
||||
#rhbz 844750
|
||||
ApplyPatch 0001-bluetooth-Add-support-for-atheros-04ca-3004-device-t.patch
|
||||
|
||||
#rhbz 812111
|
||||
ApplyPatch alps-v2.patch
|
||||
|
||||
@ -2317,6 +2323,7 @@ fi
|
||||
# || ||
|
||||
%changelog
|
||||
* Tue Feb 19 2013 Josh Boyer <jwboyer@redhat.com>
|
||||
- Add support for Atheros 04ca:3004 bluetooth devices (rhbz 844750)
|
||||
- Backport support for newer ALPS touchpads (rhbz 812111)
|
||||
- Enable CONFIG_AUDIT_LOGINUID_IMMUTABLE
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user